Jump to content

Erro "Só são aceites ficheiros em formato XML ou CSV." no envio do inventário


Recommended Posts

Alguns dos meus clientes estão a reportar que a página da AT está a dar a mensagem "Só são aceites ficheiros em formato XML ou CSV." ao tentar carregar o(s) ficheiro(s) do inventário.

Inclusive se tentar carregar os de anos anteriores que foram processados correctamente.

Foram feitas tentativas com vários browsers diferentes, e até vários PCs, mas deu sempre o mesmo erro.

Qual será o problema? No meu PC consigo validar os ficheiros sem qualquer erro.

Link to comment
Share on other sites

Em 11/01/2022 às 19:06, Pedro Moita disse:

Alguns dos meus clientes estão a reportar que a página da AT está a dar a mensagem "Só são aceites ficheiros em formato XML ou CSV." ao tentar carregar o(s) ficheiro(s) do inventário.

Inclusive se tentar carregar os de anos anteriores que foram processados correctamente.

Foram feitas tentativas com vários browsers diferentes, e até vários PCs, mas deu sempre o mesmo erro.

Qual será o problema? No meu PC consigo validar os ficheiros sem qualquer erro.

Mais algém com este problema?

Também me deu o erro num cliente, em vários PC's, mas nos nossos PC's o ficheiro dele consegue ser lido.

Já experimentei:

- usar exatamente o mesmo ficheiro que ele está a tentar entregar e que nos nossos não dá erro
- vários browsers: chrome, ie, etc.
- não ocultar as extensões

 
Link to comment
Share on other sites

Pelas experiencias que fiz numa maquina virtual vazia, fica resolvido se se instalar o microsoft office, nem que seja só a versão demo de 30 dias (sem inserir chave). Se se desinstalar logo de seguida deixa de dar.

Num outro computador, consegui, indo ao Registry e inserindo manualmente a chave "Excel.CSV" na predefinição do ".csv" em Root, LocalMachine e LocalUser, mas não tenho a certeza se não terá sido sorte. Só fazendo mais testes e não tenho tempo.

 
Link to comment
Share on other sites

acabei de ter esse problema com outro cliente e confirma-se : tem o open office assim como os outros clientes que tiveram o mesmo problema.

mas no ano passado não houve essa questão,

embora se note diferenças no aspecto dos botões da página, portanto algio for alterado.

Edited by CJCV
emenda
Link to comment
Share on other sites

13 minutos atrás, CJCV disse:

acabei de ter esse problema com outro cliente e confirma-se : tem o open office assim como os outros clientes que tiveram o mesmo problema.

mas no ano passado não houve essa questão,

embora se note diferenças no aspecto dos botões da página, portanto algio for alterado.

Sim, no ano passado a entrega obrigava a ter JAVA e a deste ano não precisa, por isso deve ter sido toda refeita.

Pelo que pesquisei no site "stackoverflow" parece-me que, para obter o maximo de compatibilidade entre Windows/Mac´s, versões de SO, etc., onde a AT tem:

<input id="addFiles" type="file" hidden="true" name="files" accept=".xml,.csv" multiple/>

deveria ter:

<input id="addFiles" type="file" hidden="true" name="files" accept=".xml,.csv,text/csv" multiple/>

Mas como isso é do lado de lá, não há nada a fazer do nosso lado.

  • Thanks 1
Link to comment
Share on other sites

1 hour ago, Cr4zyKingLi0n said:

Para já um workaround é instalar um setup do office mesmo que não seja activado.

Isso é, no mínimo, muito parvo, embora tenhas toda a razão! 😕
É abrir tickets de suporte a queixarem-se, nenhum utilizador tem de ter o MS Office instalado para um sistema da AT funcione...

10 REM Generation 48K!
20 INPUT "URL:", A$
30 IF A$(1 TO 4) = "HTTP" THEN PRINT "400 Bad Request": GOTO 50
40 PRINT "404 Not Found"
50 PRINT "./M6 @ Portugal a Programar."

 

Link to comment
Share on other sites

O problema não será o caracter "Delimitador do Campo" que no Libre/OpenOffice sugerem por defeito "," em vez do ";"

Quando se faz SAVE (ainda agora o fiz) o LibreOffice mostra uma janela/sugere "," mas tem como opção ";".

Edited by antseq
erro ortográfico
Link to comment
Share on other sites

36 minutos atrás, antseq disse:

O problema não será o caracter "Delimitador do Campo" que no Libre/OpenOffice sugerem por defeito "," em vez do ";"

Quando se faz SAVE (ainda agora o fiz) o LibreOffice mostra uma janela/sugere "," mas tem como opção ";".

Não há problema nenhum com os ficheiros que usei. Abrindo com o Notepad++ estão perfeitos. Aliás, se fosse isso não abriam e validavam noutros PC's.

Link to comment
Share on other sites

Boa tarde,

Já alguém consegui resolver o problema?

Fiz um pedido à AT e a resposta que me deram foi esta.

Quote

A Autoridade Tributária e Aduaneira (AT) agradece o seu contacto.
O ficheiro exemplo enviado com uma linha preenchida não apresenta erros, faltando no entanto o no fim da linha.
Com os melhores cumprimentos
AT- Autoridade Tributária e Aduaneira

Estou a gerar o ficheiro num mac. De base, um CSV gerado no Mac é diferente do gerado no Windows.

Mas usei um plugin na aplicação que uso para converter a quebra de linha para o formato Windows (CRLF), mas mesmo assim o site não está a aceitar o ficheiro.

Isto é uma coisa que deveria ser tão simples, mas mesmo assim eles complicam.

Se alguém encontrar alguma solução, agradeço!

 
Link to comment
Share on other sites

Ainda não tive esse problema... e acho estranho (mas vindo da AT tudo pode acontecer) a situação.

Alguém consegue partilhar/link de um ficheiro que tenha 2 ou mais linhas e efectivamente não seja aceite?

[gostava de analisar um ficheiro, na sua forma original, exactamente tal como foi tentado a sua submissão e rejeitado]

Link to comment
Share on other sites

20 minutes ago, Joao Coutinho said:

Boa tarde,

Já alguém consegui resolver o problema?

Fiz um pedido à AT e a resposta que me deram foi esta.

Estou a gerar o ficheiro num mac. De base, um CSV gerado no Mac é diferente do gerado no Windows.

Mas usei um plugin na aplicação que uso para converter a quebra de linha para o formato Windows (CRLF), mas mesmo assim o site não está a aceitar o ficheiro.

Isto é uma coisa que deveria ser tão simples, mas mesmo assim eles complicam.

Se alguém encontrar alguma solução, agradeço!

 

Já obtive resposta da AT que me pediu para seguir o exemplo que eles têm no site.

https://info.portaldasfinancas.gov.pt/pt/apoio_contribuinte/Comunicacao_inventarios_existências/Documents/Inventario.csv

Ao submeter este ficheiro da própria AT no inventário o erro que recebo é exatamente o mesmo.

Há por isso um problema no site, só pode.

Link to comment
Share on other sites

2 minutes ago, antseq said:

Ainda não tive esse problema... e acho estranho (mas vindo da AT tudo pode acontecer) a situação.

Alguém consegue partilhar/link de um ficheiro que tenha 2 ou mais linhas e efectivamente não seja aceite?

[gostava de analisar um ficheiro, na sua forma original, exactamente tal como foi tentado a sua submissão e rejeitado]

O meu ficheiro que dá erro é este: https://drive.google.com/file/d/1AU_l5JEkcXzShkS5fcCwSftD8L8todEQ/view?usp=sharing

Link to comment
Share on other sites

9 minutos atrás, Joao Coutinho disse:

A única diferença que encontro no teu ficheiro e o exemplo da AT + os ficheiros que gero é na última linha que não tem CRLF.

Sempre que gravo uma linha, faço tipo "WriteLn" portanto todas tem CRLF, inclusive a última.

Link to comment
Share on other sites

42 minutes ago, antseq said:

A única diferença que encontro no teu ficheiro e o exemplo da AT + os ficheiros que gero é na última linha que não tem CRLF.

Sempre que gravo uma linha, faço tipo "WriteLn" portanto todas tem CRLF, inclusive a última.

O problema é que o ficheiro da AT também não consigo submeter. Dá-me o mesmo erro.

Não percebo.

Link to comment
Share on other sites

Boa tarde, 

Ainda não percebi porque continuam a dizer que é erro dos ficheiros. Eu e o Américo, já falamos sobre isso. Os ficheiros são rigorosamente iguais ao ano passado, simplesmente e pelo que percebi a AT mudou o método de submissão para não usar java. Portanto se quiserem enviar os ficheiros não percam mais tempo. A não ser que alguem tenha uma solução melhor façam uma instalação do office mesmo que não activem e voilá problema resolvido (pelo menos em windows).

  • Vote 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.