Jump to content

Diagrama de blocos para algoritmo


Glauber Guttierges
 Share

Recommended Posts

Glauber Guttierges

Olá meu primeiro post aqui, peço que movam para a área correta caso esteja errada.

estou precisando fazer um diagrama de blocos através desse algorítimo, se alguém puder me ajudar

algoritmo "idade homem e mulher"
var
somahv_mn, prod_hn_mv, mulher1, mulher2, homem1, homem2: inteiro
mulhern, mulherv, homemn, homemv: inteiro
inicio

//  Seção de Comandos

escreval( "Este programa compara a idade entre 4 pessoas")
escreval( "Digite a idade da 1ª mulher")
leia(mulher1)
escreval("Digite a idade da 2ª mulher")
leia(mulher2)
escreval("Digite a idade do 1º homem")
leia(homem1)
escreval("Digite a idade do 2º homem")
leia(homem2)
se(mulher1 < mulher2)  entao
mulhern:=mulher1
mulherv:=mulher2
senao
mulherv:= mulher1
mulhern:= mulher2
fimse
se(homem1 < homem2) entao
homemn:= homem1
homemv:= homem2
senao
homemv:= homem1
homemn:= homem2
fimse
somahv_mn := homemv+ mulhern
prod_hn_mv:= homemn*mulherv
escreval( "A soma das idades do homem mais  velho com a mulher mais nova é ")
escreval( somahv_mn)
escreval( "O produto das idades do homem mais novo com a mulher mais velha é ")
escreval( prod_hn_mv)
FIMALGORITMO

agradecido

Link to comment
Share on other sites

Podes usar o LibbreOffice Draw para fazeres o diagrama.

10 REM Generation 48K!
20 INPUT "URL:", A$
30 IF A$(1 TO 4) = "HTTP" THEN PRINT "400 Bad Request": GOTO 50
40 PRINT "404 Not Found"
50 PRINT "./M6 @ Portugal a Programar."

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.