Jump to content

Pip install não funciona


@Andre Filipe

Recommended Posts

@Andre Filipe

Olá,

  Infelizmente o pip install não funciona no cmd . Tenho uma vaga ideia que o python possa não ter instalado automaticamente o pip, com este problema em mãos decidi pesquisar e encontrei um resultado que dizia que tínhamos de instalar: setuptools de um binário próprio do windows e pip de um binário próprio do windows, mesmo assim dá sempre aquele erro clássico ('pip', não é reconhecido como um comando interno ou externo, etc.. . Preciso de resolver este problema rápidamente para poder trabalhar com Bluetooth ou PyBluez.

Versão: Python 3.2

Como posso resolver ?

Edited by @Andre Filipe
Link to post
Share on other sites
AshKetshup

Experimenta usar o comando

pip3 install <nome_da_package>

Espero ter ajudado.

Mas façam o que fizerem nunca façam:

sudo apt remove python

 

Link to post
Share on other sites
@Andre Filipe

Olá,

    Infelizmente tenho de dizer que o pip3, também não funcionou sabem como posso instalar o Python 3 mais completo, ao dizer mais completo digo(+ pip instalado). Sabem onde posso instalar o Python 3.2 mais completo?

  

Link to post
Share on other sites

O pip já vem com o python, a parti das versões 2.7.9 e 3.4.

Tenta

python -m pip --version

 

10 REM Generation 48K!
20 INPUT "URL:", A$
30 IF A$(1 TO 4) = "HTTP" THEN PRINT "400 Bad Request": GOTO 50
40 PRINT "404 Not Found"
50 PRINT "./M6 @ Portugal a Programar."

 

Link to post
Share on other sites
@Andre Filipe

Olá,

   Desculpem só agora é que percebi o erro que cometi! Na instalação do Python 3.2, eu não instalei o pip nem inseri o python.exe no Harddrive PATH, ou seja abrir o prompt e digitar pip install nome do pacote.

   Então, fui instalar uma versão acima, instalei o Python 3.4 e configurei a instalação de modo a dar para digitar pip install

Obrigado na mesma :) 

Link to post
Share on other sites
@Andre Filipe
Posted (edited)

Olá,

  ás vezes não dá para instalar bibliotecas/libs, por exemplo: PyBluez ou PyAudio. Não sei porquê mas quando eu tento fazer pip install PyAudio ou pip install pybluez, nunca dá certo! O que tem acontecido é que só algumas libs dão para instalar, ás vezes consigo instalar outras vezes dá erro, a única que consegui instalar até agora foi SpeechRocognition, tentei instalar pandas, infelizmente não deu! Como posso resolver?

 

Edited by @Andre Filipe
Link to post
Share on other sites
thoga31

Quais os erros emitidos pelo pip? "Não dá certo" não nos dá grandes informações sobre qual possa ser a origem do problema.

Knowledge is free!

Link to post
Share on other sites
AshKetshup

Olá André,
Para encontrarmos o teu problema tenho umas questões a te fazer:

  • Qual a versão do python que estás a usar? (o que te aparece ao fazer o comando "python3" no teu cmd?)
  • Quais os packages que estás a tentar usar?


Espero que possa ajudar.

Mas façam o que fizerem nunca façam:

sudo apt remove python

 

Link to post
Share on other sites
@Andre Filipe
1 hora atrás, AshKetshup disse:

Olá André,
Para encontrarmos o teu problema tenho umas questões a te fazer:

  • Qual a versão do python que estás a usar? (o que te aparece ao fazer o comando "python3" no teu cmd?)
  • Quais os packages que estás a tentar usar?


Espero que possa ajudar.

   Olá,

   Então para começar o que me aparece quando eu digito python3 é:  não é reconhecido como um comando interno ou externo, programa operacional ou batch. Estou a tentar instalar o pandas, Pybluez, PyAudio e a versão do meu python é 3.4

 

Link to post
Share on other sites
1 hour ago, @Andre Filipe said:

   Olá,

   Então para começar o que me aparece quando eu digito python3 é:  não é reconhecido como um comando interno ou externo, programa operacional ou batch. Estou a tentar instalar o pandas, Pybluez, PyAudio e a versão do meu python é 3.4

 

A primeira das coisas é perceber se tens, ou não, o Python 3 instalado.
Se tens, então é só colocar o Python no path para poder ser acedido via shell/cmd.

10 REM Generation 48K!
20 INPUT "URL:", A$
30 IF A$(1 TO 4) = "HTTP" THEN PRINT "400 Bad Request": GOTO 50
40 PRINT "404 Not Found"
50 PRINT "./M6 @ Portugal a Programar."

 

Link to post
Share on other sites
AshKetshup

Porque não instalas o Python 3.9 (o mais recente)?

Mas façam o que fizerem nunca façam:

sudo apt remove python

 

Link to post
Share on other sites
@Andre Filipe
3 horas atrás, M6 disse:

A primeira das coisas é perceber se tens, ou não, o Python 3 instalado.
Se tens, então é só colocar o Python no path para poder ser acedido via shell/cmd.

   Continua com o mesmo erro de sempre: 

Command python setup.py egg_info failed with error code 1 in C:\DOCUME~1\Pc\LOCA
LS~1\Temp\pip_build_Pc\pandas
Storing debug log for failure in C:\Documents and Settings\Pc\pip\pip.log

 

Link to post
Share on other sites
Rui Carlos

Isso não é o mesmo erro de sempre.  Esse erro não parece ter nada a ver com o não é reconhecido como um comando interno ou externo, programa operacional ou batch.

 

Já viste o conteúdo do log C:\Documents and Settings\Pc\pip\pip.log?

Adicionalmente, convinha usares pelo menos o Python 3.8.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.