Jump to content

Compara as posições da linha da matriz


Recommended Posts

Joelson

 Procurar na linha da matriz, números  iguais em suas respectivas posições e remover da matriz
 

algoritmo "matriz"
// Função :
// Autor : joelson
// Data : 22/02/2021
// Seção de Declarações
var
vetA: vetor[1..3]de inteiro
vetBimpar: vetor[1..3]de inteiro
j,i,x,k,linha,coluna,repetido,contImpar,cont,total:inteiro
matriz: vetor[1..10,1..3]de inteiro

inicio
// Seção de Comandos

total:=0

enquanto total < 10 faca
   total:=total+1

   escreval("Digite o Vetor de um total de 10:,[",total,"]")
   para j de 1 ate 3 faca
     escreva("Vetor:[",j,"]")
     leia(vetA[j])
   fimpara
   escreval()

//achar numeros impares
  para i de 1 ate 3 faca
    se(vetA[i] mod 2 = 1)entao
      vetBimpar[i]:= vetA[i]
    fimse
  fimpara

 
  PARA k DE 1 ATE CONT FACA
   repetido:=0
    PARA linha DE 1 ATE 3 FACA
      PARA coluna DE 1 ATE 3 FACA
        SE(vetBimpar[linha] = matriz[K,coluna])ENTAO
           repetido:=repetido+1
        fimse
      FIMPARA
    FIMPARA 

fimenquanto

   //escrever a matriz depois dos cinco valores digitados
   escrevaL(" exibir Matriz")
   escrevaL("__________________")
   
   PARA linha DE 1 ATE 3 FACA
      PARA coluna DE 1 ATE 3 FACA
      escreva(matriz[linha,coluna])
   FIMPARA
      escreval()
   FIMPARA

  contImpar:=0
  vetBimpar[1]:=0
  vetBimpar[2]:=0
  vetBimpar[3]:=0



escreval("Total digitados: ", total)
fimalgoritmo

Edited by Joelson
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.