Jump to content
Chamuanza

Base Dados SQL como "Recovery Pending"

Recommended Posts

Chamuanza

Um Bem Aja a todos

Tenho uma aplicação pessoal em VB que funciona com uma BD SQL

Quando abro o SQL Server Management Studio 2014 e faço a conecção aparece-me:

D:\PROJECTOTOTOMILHOES\TOTOMILHÕES\BIN\DEBUG\GUARDARRESULTADOS.MDF (Recovery Pending)

A aplicação está a funcionar, no entanto não consigo chegar as tabelas no SQL Server Management.

Já desinstalei o SQL Server Management, voltei a instalar quando inicio a conecção fica bem sem a recuperação pendente, mas após utilizar a aplicação volta ao mesmo.

Já tentei reparar a BD mas não consigo.

Agradecia uma ajuda

Obrigado 

Edited by Chamuanza
Não Resolvido

Share this post


Link to post
Share on other sites
Chamuanza

Afinal está tudo na mesma.

Utilizei a aplicação para inserir novo registo  e ao abrir SQL Server Management, lá estava 

D:\PROJECTOTOTOMILHOES\TOTOMILHÕES\BIN\DEBUG\GUARDARRESULTADOS.MDF (Recovery Pending)

Share this post


Link to post
Share on other sites
M6

Podes tentar esta abordagem

ALTER DATABASE [DB_Name] SET  SINGLE_USER WITH NO_WAIT

ALTER DATABASE [DB_Name] SET EMERGENCY;

DBCC checkdb ([DB_Name], REPAIR_ALLOW_DATA_LOSS  )

ALTER DATABASE [DB_Name] SET online;

ALTER DATABASE [DB_Name] SET  Multi_USER WITH NO_WAIT

Se não funcionar, vais ter de ir mais afundo na questão, lê aqui:

https://community.spiceworks.com/how_to/157233-how-to-fix-recovery-pending-state-in-sql-server-database


10 REM Generation 48K!
20 INPUT "URL:", A$
30 IF A$(1 TO 4) = "HTTP" THEN PRINT "400 Bad Request": GOTO 50
40 PRINT "404 Not Found"
50 PRINT "./M6 @ Portugal a Programar."

 

Share this post


Link to post
Share on other sites
Chamuanza

M6

Obrigado pela atenção e dica. Executei as Query que enviaste e ao retornar ao SQL Server Management ficou bem

D:\PROJECTOTOTOMILHOES\TOTOMILHÕES\BIN\DEBUG\GUARDARRESULTADOS.MDF

Obrigado pela ajuda

Share this post


Link to post
Share on other sites
M6

De nada.


10 REM Generation 48K!
20 INPUT "URL:", A$
30 IF A$(1 TO 4) = "HTTP" THEN PRINT "400 Bad Request": GOTO 50
40 PRINT "404 Not Found"
50 PRINT "./M6 @ Portugal a Programar."

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.