Jump to content
Eduardo Oliveira

Ficheiro do inventário

Recommended Posts

Eduardo Oliveira

Muito boa tarde,

 

Não consigo enviar o inventário do ano passado.

Quando acedo à página, a opção enviar ficheiro está em "cinzento".

Carrego e o site da AT não reage. 

 

O que devo fazer?

 

Muito obrigado

Share this post


Link to post
Share on other sites
deepvyas

Verifique as configurações do seu inventário


PHP Expert Developer | S: deepvyas71 | E: deepvyas71@gmail.com

Share this post


Link to post
Share on other sites
americob

Para enviar o ficheiro de inventário para a AT é preciso usar um Browser com JAVA.

Isso só consegue correr em:

- Internet Explorer

- Google Chrome com o plug-in de IE

- versões mais antigas de browsers

 

Claro que a AT já devia ter arranjado soluções para isto já que a maioria das versões atuais de browsers, incluindo o Edge da Microsoft, não permitem correr JAVA por questões de segurança.

 

Share this post


Link to post
Share on other sites
Eduardo Oliveira

Muito obrigado

Já instalei o JAVA e usei o IE

Agora recebo a mensagem:

Erro:Ficheiro:STK504IV.xml;Linha: 3;Coluna: 11;cvc-elt.1:Cannot find the declaration of client 'STK504IV'

Como é que verifico as configurações do meu inventário?

 

Muitíssimo obrigado

 

Share this post


Link to post
Share on other sites
americob

Experimenta abrir o ficheiro com o Notepad++ e vê o que está na linha 3 coluna 11. Se calhar até percebes logo o que é.

 

Share this post


Link to post
Share on other sites
Eduardo Oliveira

Na linha 3 está <20191231> o que implica um espaço em branco na coluna 11

Mudei para <999999999> número de contribuinte e a mensagem mudou para: Linha 3 Coluna 2

 

Mudei para <INVENTARIO> e a mensagem mudou também para: Linha 3 Coluna 13

 

Sabes o que deve constar na linha 3? 

 

Desculpa-me. 

 

Obgd

Share this post


Link to post
Share on other sites
americob
Em 22/01/2020 às 18:58, Eduardo Oliveira disse:

Na linha 3 está <20191231> o que implica um espaço em branco na coluna 11

Mudei para <999999999> número de contribuinte e a mensagem mudou para: Linha 3 Coluna 2

 

Mudei para <INVENTARIO> e a mensagem mudou também para: Linha 3 Coluna 13

 

Sabes o que deve constar na linha 3? 

 

Desculpa-me. 

 

Obgd

Não estou a perceber como pode ter isso na linha 3.

De certeza que está a respeitar o XSD que a AT definiu em:

http://info.portaldasfinancas.gov.pt/pt/apoio_contribuinte/Comunicacao_inventarios_existências/Documents/Stock_1_2.xsd

Share this post


Link to post
Share on other sites
Eduardo Oliveira

Deve ser sim.

A AT já me respondeu e confirmou que o ficheiro não está de acordo com a norma.

Interpelei a software house e espero resposta. Não acredito que todos os Clientes deles estejam a passar pelo mesmo.

Vou esperar até segunda. Se não tiver uma resposta que resolva, por parte da software house, terei que construir um ficheiro csv, que me parece mais fácil.

 

Muito obrigado

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.