Jump to content
nandeseasy

registo.php script

Recommended Posts

nandeseasy

http://prntscr.com/mb703j

Eu quando coloco a pass á primeira bem e depois meto mal ele continua com o certo e com o texto todo descodificado e eu nao consigo descorribir o erro quem me puder ajudar agradecia!!


Bruno Fernandes

Share this post


Link to post
Share on other sites
coxosclassic

boas,

Sem código não vai dar para conseguir muita coisa.. Mas em princípio o problema há-de estar na validação dos inputs.

Tenta colocar aqui a validação que estás a fazer (em código js).

Cumps.


Cumps,

cc

Share this post


Link to post
Share on other sites
nandeseasy

jQuery.validator.setDefaults({

           success: function(label){

                label.attr('id','valid');

         },

        });

        $( "#myform" ).validate({

            rules: {

             password: "required",

             password1: {

               equalTo: "#password"

                },

                email: {

                    required: true,

                    email:true

                }

           },

           messages: {

               name: {

                   required: "Nome em falta"

               },

               name1: {

                   required: "Apelido em falta"

               },

               email: {

                   required: "Email em falta"

               },

               password: {

                   required: "Password em falta"

               },

               password1: {

                     required: "Password em falta",

                     equalTo: "Password Errada"

             },

                checkbox: {

                   required: "Tem que aceitar os termos"

               }

            }

});


Bruno Fernandes

Share this post


Link to post
Share on other sites
coxosclassic

Julgo que estejas a usar o plugin JQuery Validate.

Acho que o problema possa estar nas "rules" que estás a passar.

As propriedades "password" e "password1" parecem estar incompletas e pode ser isso que esteja a dar problemas.

Confirma também se tens algum erro na consola, e se os tiveres coloca aqui para podermos dar uma vista de olhos.

P.S- Tenta formatar esse código antes de postares! :) não se percebe nada! Nas opções da caixa de comentário tens um botão (<>) que permite formatar a parte de código.


Cumps,

cc

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.