Ir para o conteúdo
  • Revista PROGRAMAR: Já está disponível a edição #60 da revista programar. Faz já o download aqui!

aliceinformatica

Algoritmo Portugol

Mensagens Recomendadas

aliceinformatica

Galera , boa tarde , preciso fazer dois algoritmos , porem não estou conseguindo , alguem pode me ajudar? Linguagem de portugol , visualg

 

Primeiro O Campeonato Pindoramiano de Futebol de 2017 foi disputado em 12 jogos. A sua tarefa é escrever um algoritmo em PETEQS que imprima algumas estatísticas sobre os resultados de um dos times que disputou o campeonato. Os resultados que terão de ser impressos são os seguintes:

(a) Quantos pontos o time conseguiu no campeonato, sabendo que uma vitória vale três pontos e um empate um ponto. Uma derrota não conta nenhum ponto.

(b)  O saldo de gols do time. Isto é calcule a diferença entre os gols feitos e os gols sofridos.

(c)  Em quantos jogos o time não fez nenhum gol. (d) (1.25 ponto) A média de gols que o time fez por jogo. Os resultados dos jogos devem ser fornecidos no formato indicado abaixo. O primeiro valor inteiro é número de gols que o time fez e o segundo quantos ele sofreu.

Jogo 1?

3 1

Jogo 2?

1 3

Jogo 3?

2 2

Jogo 4?

1 1

Jogo 5?

0 2

Jogo 6?

2 1

Jogo 7?

0 0

Jogo 8?

2 0

Jogo 9?

2 0

Jogo 10?

1 0

Jogo 11?

0 3

Jogo 12?

3 0

Para os dados mostrados no exemplo acima os resultados impressos pelo algoritmo devem ser.

Pontos: 21

Saldo de gols: 4

Jogos sem fazer gols: 3

Media de gols por jogo: 1.417

 

Eu fiz assim no VisualG , mais tem erros e não consigo resolver..

 

algoritmo "trabalho"


   Var

   times : Vetor[1..2] de caracter
   jogo, vitoria, empate, saldo, pts : Vetor[1..5] de inteiro
   x, l, c, soma, jogos : inteiro
   vit, emp, der : inteiro
   campeao : caracter
   matriz : Vetor[1..5,1..5] de inteiro

Inicio

   para x de 1 ate 2 faca
        escreva("Digite o nome do ", x, "º time: ")
        leia(times[x])
   fimpara

   escreval
   Escreval("Informe o número de jogos: ")
   leia(jogos)

   escreval
   para x de 1 ate 2 faca
        escreva("Informe o número de vitórias do ", x, "º time: ")
        leia(vitoria[x])
   fimpara

   escreval
   para x de 1 ate 2 faca
        escreva("Informe o número de empates do ", x, "º time: ")
        leia(empate[x])
   fimpara

   escreval
   para x de 1 ate 2 faca
        escreva("Informe o saldo de gols do ", x, "º time: ")
        leia(saldo[x])
   fimpara

   vit <- 3
   emp <- 1
   der <- 0

   escreval
   para x de 1 ate 2 faca
        soma <- (vitoria[x] * 3) + (empate[x] * 1)
        pts[x] <- soma
   fimpara

   escreval
   escreval("A tabela do campeonato ficara de acordo como a apresentação a seguir: ")
   escreval
   escreval("TIMES JOGOS VITÓRIA EMPATE SALDO PONTOS")
   escreval
   para l de 1 ate 2 faca
        para c de 1 ate 2 faca
             para x de 1 ate 2 faca
                   matriz[l,1] <- jogo[x]
                   matriz[l,2] <- vitoria[x]
                   matriz[l,3] <- empate[x]
                   matriz[l,4] <- saldo[x]
                   matriz[l,5] <- pts[x]
             fimpara
        escreva(matriz[l,c])
        fimpara
        escreval
   fimpara


fimalgoritmo

 

Outra questão é ..

Em PETEQS uma string pode ser tratada como um vetor de caracteres. Observe por exemplo a função inverte(entradas: frase) a seguir que recebe uma string como parâmetro e retorna uma nova string que é o inverso da string original.

função inverte(entradas: frase)
início
 resultado ? frase
 para i ? 1 até tamanho(frase)/2 faça
 aux ? frase
 resultado ? frase[tamanho(frase)-i+1]
 resultado[tamanho(frase)-i+1] ? aux
 próximo i
fim

Na construção desse algoritmo, foi usada a função tamanho(entradas: frase) que retorna o número de caracteres em uma string.

Considere o seguinte exemplo de uso:

programa exemplo
início
 imprima inverte("exemplo")
 imprima inverte("reviver")
fim
A saída do programa seria:
olpmexe
reviver
 

Escreva o algoritmo da função trocaPares(entradas: frase) que recebe uma string como parâmetro e retorna uma nova string em que os pares de letras consecutivas na string original são invertidas. Se a string de entrada tiver um número ímpar de letras, a última letra deve permanecer inalterada. A seguir, você pode ver um exemplo de teste da função:

 

programa exemplo
início
 imprima trocaPares("exemplo")
 imprima trocaPares("decantador")
 imprima trocaPares("entre paredes")
fim
A saída do programa seria:
xemelpo
edactndaro
nert eapereds

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
M6

@aliceinformatica obrigado pela partilha do enunciado do teu trabalho.

Boa sorte para a sua resolução.

 


10 REM Generation 48K!
20 INPUT "URL:", A$
30 IF A$(1 TO 4) = "HTTP" THEN PRINT "400 Bad Request": GOTO 50
40 PRINT "404 Not Found"
50 PRINT "./M6 @ Portugal a Programar."

 

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!

Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.

Entrar Agora

×

Aviso Sobre Cookies

Ao usar este site você aceita os nossos Termos de Uso e Política de Privacidade. Este site usa cookies para disponibilizar funcionalidades personalizadas. Para mais informações visite esta página.