Jump to content
passarito

Erro em site local (Forbidden - permission access / on this server)

Recommended Posts

passarito

Boa tarde,

Venho pedir a vossa ajuda na resolução de um problema num site a correr localmente.

O site esteve a correr bem durante alguns anos mas por um descuido foi desinstalado o WAMP.

Quando se voltou a instalar o WAMP o programa começou a dar o erro abaixo
 

Citação

 

FORBIDDEN

you don't have permission to access /db/< on this server

 

 

Após se colocar o endereço http:\\localhost:8080\db ele faz qualquer coisa e reporta o erro.

O programa esta a correr numa pasta db dentro da pasta www na porta 8080 que já consegui no httpd.conf.

Consigo aceder à pagina phpadmin e ver a base de dados sem problemas

 

Já googlei bastante, alterei o httpd.conf várias vezes por causa das permissões mas nunca consegui chegar a nenhum resultado.

A minha área é mais para o IIS e ASP. Não estou nada à vontade neste assunto.

Será que há alguma alma caridosa que me queira ajudar? Obrigado.

 

Edit:

Anteriormente esqueci-me de dizer que no endereço fica o seguinte:

Citação

localhost:8080/db/<?=$endereco?>

Edited by passarito
Adicionar informação

Share this post


Link to post
Share on other sites
devgoncalo

olá,

a minha configuração:

C:\Windows\System32\drivers\etc\hosts

Citação

127.0.0.1 127.0.0.1
127.0.0.1 localhost
127.0.0.1 projecto1.localhost

C:\wamp64\bin\apache\apache2.4.18\conf\extra\httpd-vhosts.conf

Citação

<VirtualHost *:80>
    ServerName projecto1.localhost
    DocumentRoot C:/wamp64/www/projecto1/public
    <Directory  "C:/wamp64/www/projecto1/public/">
        Options Indexes FollowSymLinks MultiViews
        AllowOverride All
        Require local
    </Directory>
</VirtualHost>

C:\wamp64\bin\apache\apache2.4.18\conf\httpd.conf

Citação

Listen 0.0.0.0:80
Listen [::0]:80
ServerName localhost:80

estou a apontar para a porta 80, mas se fizeres o mesmo tens que ter atenção com a porta de comunicação do skype e verificar se o IIS não está a correr na mesma porta.

no browser tens apenas que colocar
projecto1.localhost

atenção que se quiseres
projecto1.dev
podes ter problemas com o chrome (porque acho que a google comprou o dominio)

cumps

Share this post


Link to post
Share on other sites
passarito

Testei essas alterações e mais algumas e nada. Sempre o mesmo erro.

O que me deixa intrigado é que quando faço http://localhost:8080/db o browser apresenta uma série de informação e limpa logo de seguida e bloquiea no erro Forbidden aparecendo na barra de endereço http://localhost:8080/db/

A informação pisca tão rapidamente ler o que quer que seja e muito menos pará-lo antes de desaparecer.

Estou a usar Firefox, Wamp 2.0, Apache 2.2

 

Edited by passarito

Share this post


Link to post
Share on other sites
HappyHippyHippo

Isso não é erro, é o servidor que não está a interpretar o ficheiro como php e está a servi-lo directamente. 

Solução? Só analisando as configuração do servidor. Podes as colocar aqui? 

  • Vote 1

IRC : sim, é algo que ainda existe >> #p@p

Share this post


Link to post
Share on other sites
passarito

Também me apercebi disso, mas não compreendo uma coisa ele processa o index.php que chama outros 2 php (config e classes)

Inicio do Index.php

<?php
session_start();
header("Cache-control: private"); //IE6 Form Refresh Fix

require_once('geral/config.php');
require_once('geral/classes.php');
?>

....

no config.php passa bem (mas também não tem nada de mais) e no classes.php é que não processa. (será por estar dentro da pasta geral?)

Inicio do classes.php

<?  
function ver_backups() 
{
include('config.php');
#$directory="/Applications/MAMP/htdocs/db/backups/";
$directory="C:/wamp/www/db/backups";
$dir=$directory; // Directory where files are stored
$i=0;
if ($dir_list = opendir($dir))
{
while(($filename = readdir($dir_list)) !== false)
{ 
	if($filename!=="." && $filename!=="..") { $i++;
	echo('&nbsp;&nbsp;'.$i.')&nbsp;<a href="'.$config['baseurl'].'backups/'.$filename.'" target="_blank">'.$filename.'</a><br>');
	}
}
closedir($dir_list);
}
if($i==0) echo('<span style="color:red;">Ainda n&atilde;o realizou nenhum backup.</span><br>');
}

function dbbackup(){
include('config.php');

$dbname = "db"; 
mysql_select_db($dbname) or die(mysql_error()); 

....

 

Quanto à configuração do servidor, é o httpd.conf que queres?

Coloco-o aqui ou ficará muito extenso?

Obrigado

Share this post


Link to post
Share on other sites
passarito

Ganhei uma batalha mas ele ainda continua a ganhar a guerra...

No PHP.INI mudei short_open_tag de Off para On e já dá qualquer coisa :) só que com muitos erros :(

Primeiro dá- erros destes de "Deprecated"

Citação

Deprecated: Function session_is_registered() is deprecated in C:\wamp\www\db\index.php on line 316

Depois salta para a porta 8888 e perde-se, mas se eu for ao endereço e lhe mudar para a porta para a 8080 então ele volta a funcionar com os tais erros Deprecated e os Notice

Citação

Notice: Undefined variable: PHP_SELF in C:\wamp\www\db\geral\classes.php on line 177

 

Pergunto eu, será que dá para colocar 2 Listens e ServerName localhost:? 1 para cada porta 8080 e 8888? Ou isto já serei eu a delirar?

 

Obrigado

Share this post


Link to post
Share on other sites
HappyHippyHippo

deves ter configuração de redireccionamento para a porta 8888

depois é problemas normais de quem actualiza a versão do PHP para uma versão mais recente ... actualiza o código

  • Vote 1

IRC : sim, é algo que ainda existe >> #p@p

Share this post


Link to post
Share on other sites
passarito

@HappyHippyHippo, não queria mexer no código pois PHP é algo que não domino, ainda assim costumo abri-lo e mais ou menos consigo percebê-lo

Além do mais, este mesmo código estava a funcionar sem problemas antes da desinstalação do Wamp, daí eu estar a "atacar" apenas em configurações e nunca no código.

Quando analisei o código de um ficheiro config.php algo me deixou muito intrigado que foi a porta 8888, daí a minha pergunta anterior relativamente às portas.

<?php

				$config = array();
				global $config;
				global $db_type;
				$db_type = "mysql";
//				$db_user = ------------
//				$db_password = -----------
				$db_database = "db";
				$db_server = "localhost";
				
				date_default_timezone_set('GMT');
				$currenttime = date("Y-m-d G:i:s");
				$currentdate = date("Y-m-d");
				
$con = mysql_connect($db_server, $db_user, $db_password) or die(mysql_error());
mysql_set_charset('UTF8',$con);
mysql_select_db($db_database) or die(mysql_error());

				$config['server'] = "localhost";
//É aqui que é configurado a porta 8888
				$config['baseurl'] = "http://".$config['server'].":8888/db/"; 
				$config['currenturl'] = 'http://'.$_SERVER['HTTP_HOST'].$_SERVER['REQUEST_URI'];
				$config['terminasessao'] = "<form action=\"/db/geral/logout.php\" method=\"post\" enctype=\"multipart/form-data\" name=\"terminarsessao\" class=\"niceform\"><button name=\"terminarsessao\" type=\"submit\"  id=\"terminarsessao\">Terminar Sessao</button></form>";
?>

Este ficheiro é sempre chamado no inicio dos outros todos (ou quase todos)

Será que havia um VHost configurado para a porta 8888, ou isto é uma grande barbaridade?

Share this post


Link to post
Share on other sites
HappyHippyHippo

desde a última vez que vi, podes configurar par aa porta que imaginares desde que seja entre o 1 e o 2^16-1 ... desde que não haja conflito

Edited by HappyHippyHippo
  • Vote 1

IRC : sim, é algo que ainda existe >> #p@p

Share this post


Link to post
Share on other sites
passarito

@devgoncalo

2 horas atrás, devgoncalo disse:

experimenta também comentar o htaccess

O programa que está dentro da pasta db não tem htaccess

 

@HappyHippyHippo

2 horas atrás, HappyHippyHippo disse:

desde a última vez que vi, podes configurar par aa porta que imaginares desde que seja entre o 1 e o 2^16-1 ... desde que não haja conflito

Esqueci-me de dizer no post anterior, o atalho original que está no ambiente de trabalho temo o endereço com a porta 8080: http://localhost:8080/db

É por isso é que não entendo porque é que no código aparece a porta 8888.

Edited by passarito

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.