Jump to content
Dr_Lion

ANSWERED Criar proxy SSL

Recommended Posts

Dr_Lion

Boas, estou aqui com umas dificuldades e à 2 dias que ando a bater com a cabeça.

O meu sistema ubnutu 15.04 anda um bocado confuso, então começando a contextualizar o problema. Isto tinha o xamp instalado, mas não entendi porquê o php não estava instalado, e instalei à posteriori. O meu objectivo é instalar o traccar (plataforma de localizaçã de veículos) e servir o mesmo sobre https!!! Que por defeito vem por http!

 

A questão começa por ser: tenho "vários" document roots

O que me parece ser o atual, é o:  /opt/lampp/htdocs  - e é onde está a página do xampp instalado!

Após instalar o php surgiu o: /var/www/   - que até aqui não existia; mas a página do xampp já se encontrava acessível antes desta instalação!!

Ao instalar o traccar, (que usa java não percebi bem para quê, acho que é para criar o servidor) que serve a página no porto 8082 por http! O que queria era servir por https!!! O conselho que dão é fazer um proxy (na própria máquina) para redirecionar um outro porto por exemplo 1234 com ligação ssh, para o porto original 8082 sem ssh, e assim consigo colocar o acesso à plataforma um pouco mais seguro.

O traccar usa a diretoria /opt/traccar/ e serve a sua página web na diretoria /opt/traccar/web/

Já vi tanta coisa que já estou um pouco confuso. Já activei o ssl no apache, já coloquei o certificado (para já só de testes, snake-oil) e consigo aceder à página do xampp por https!

No entanto com nenhuma configuração consigo redirecionar outro porto para a página do traccar!

Deixo abaixo algumas configurações que tentei sem sucesso:

/etc/apache2/ports.conf

<IfModule ssl_module>
  Listen 443
  Listen 4435
  Listen 4436
</IfModule>
<IfModule mod_gnutls.c>
  Listen 443
  Listen 4435
  Listen 4436
</IfModule>

/etc/apache2/sites-enabled/traccar.conf

<IfModule mod_ssl.c>
        <VirtualHost *:4435>

                ServerName 123.123.123.123	-este não é o ip real... mas tenho neste campo um ip na mesma formatação!
		#DocumentRoot /opt/lampp/htdocs/
                #DocumentRoot /var/www/html
		DocumentRoot /opt/traccar/web/

                ProxyPass / http://localhost:8082/
                ProxyPassReverse / http://localhost:8082/

                SSLEngine on
                SSLCertificateFile /etc/ssl/certs/ssl-cert-snakeoil.pem
                SSLCertificateKeyFile /etc/ssl/private/ssl-cert-snakeoil.key

        </VirtualHost>
</IfModule>

 Não percebo o que se passa, será que alguém consegue ajudar, ou tem alguma sugestão?

Desde já agradeço a todos.

Share this post


Link to post
Share on other sites
tcarreira
12 horas atrás, Dr_Lion disse:

<VirtualHost *:4435>

O proxy parece estar bem configurado, mas se é para aceder via https normal (eg: através do browser), o servidor tem de escutar o porto 443 (que já está) e o virtualhost tem de ficar associado a esse porto.
Basta trocar "<VirtualHost *:4435>" por "<VirtualHost *:443>"

Com essa configuração, também deve funcionar através do endereço https://123.123.123.123:4435/

Share this post


Link to post
Share on other sites
Dr_Lion

POis, já consegui configurar tudo corretamente, sim estava bem configurado mas os ficheiros não estavam no sítio certo, ou seja.

Uma instalação normal do lamp, coloca os ficheiros no /var/www/ creio, e neste caso como tenho o xamp instalado, o diretório base deixa de ser o habitual e passou a ser o /opt/lamp/

 

pelo que o ficheiro httpd-ssl.conf que se tem que editar está na pasta /opt/lamp/etc/extra/ e o ficheiro httpd.conf onde se colocam os portos em que se está à escuta, está na diretoria /opt/lamp/etc/.

E para reiniciar o serviço é preciso usar os comandos do xamp, "sudo /opt/lampp/lampp restart | strat | stop"! E não os comandos habituais...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.