Jump to content
Bernasjb888

Putty (Network error: connection refused)

Recommended Posts

Bernasjb888

Boas pessoal.

Tenho estado à alguns dias a tentar fazer ligação do meu raspberry pi 3 ao meu pc portátil, de modo pudesse usar o ecrã do portátil para trabalhar com o pi 3.

Segundo as minhas pesquisa, "Putty.exe" é a melhor opção para fazer tal ligação com a ajuda do Advance IP Scanner v2".

Ao por o ip do pi3 no "Putty.exe" aparece dá-me "Network error: connection refused". Tentei arranjar solução através da placa de rede, mas continua a dar o mesmo erro.

Não sei se terei de mexer nas pasta SSH através do terminal do qual ainda não tenho muitos conhecimentos sobre isso.

Alguém consegue-me ajudar?:cheesygrin:


Uma espécie de programador

Share this post


Link to post
Share on other sites
HappyHippyHippo

que tutorial seguiste para instalar o sistema operativo no pi3 ?

que tutorial estás a seguir para efectuar a ligação ssh ao pi3 ?


IRC : sim, é algo que ainda existe >> #p@p

Share this post


Link to post
Share on other sites
Bernasjb888

Boas!

Vou passar o seguinte link do youtube: 

Quanto à instalação do S.O., não precisei porque já estou prático nisso desde o pi2. Mas não descarto a possibilidade do erro do putty ser da instalação do S.O..

Já agora utilizo RASPBIAN JESSIE WITH DESKTOP.

https://www.youtube.com/embed/RnfukbLaQvY?feature=oembed

 


Uma espécie de programador

Share this post


Link to post
Share on other sites
Dr_Lion

Tens a porta definida corretamente no pi? Caso não estejas a usar a porta default 22 no pi3, tens que colocar a porta no putty! Confirma se estás a inserir o utilizador e palavra pass corretos!

Lembra-te que ambas as máquinas têm que estar na mesma gama de IPs, com ips compatíveis, confirma a máscara de rede... Verifica se a firewall do Windows está activa ou não e experimenta desactivar. 

Confirma se tens no pi3 na config de ssh, para aceitar utilizador/password, ou apenas certificados...

 

Para que usas o advance ip scanner v2??? Eu faço isso com o putty e a consola do Windows. Uma forma de despistares muitos problemas, é na consola do portátil, fazeres:

 ping ip_do_pi3

Vês logo se as duas máquinas estão acessíveis pela rede, se houver resposta, então o problema é configuração do ssh no pi3, ou utilizador/password errados.

Esse processo costuma ser trivial, portanto se te está a ocorrer um erro, ou tens algo mal configurado do lado do pi3, ou é uma dessas coisas básicas que se esquece com facilidade. 

Share this post


Link to post
Share on other sites
Bernasjb888

Tive a ver e acho que o problema aqui tem a ver com as permissões user/password.

 

Já alterei usando o comando:

sudo su
nano /etc/ssh/sshd_config

Depois alterei:

#PermitRootLogin yes

Quanto a password não vejo onde está para se poder alterar, mas se calhar acrescento #Password yes. Não sei se funcionará.


Uma espécie de programador

Share this post


Link to post
Share on other sites
Bernasjb888

Boas n3phIlIm. Sim, foi das primeiras coisas que eu fiz. Já resolvi o problema.

Vi que o problema era o nome de user para fazer login. Por defeito o nome de user é pi, e eu tentei entrar com "pi@nomeUser" ou "IP".

Obrigado a todos.

 

Nota: se houver dúvidas para quem estiver a começar a utilizar ssh, putty e vnc, ficarei atento para explicar os métodos.


Uma espécie de programador

Share this post


Link to post
Share on other sites
Dr_Lion

Só em nota de rodapé por teres falado acima, existe nas configurações do SSH, uma flag qualquer para permitir/bloquear root login. OU seja se isso estiver bloqueado não consegues ligar com root, tens que ligar como teu user e depois usar o sudo! E percebe-se porquê... Logar com root é muito má política...

Essa questão que já alteraste do permitir logar com password também é algo que passa bastante por esquecimento, mas sim se queres logar com pwd tens que activar. Ou então crias um certificado e não te chateias mais... Se bem que para logares de máquinas diferentes um certificado pode ser um entrave ;)

Mas nada te proíbe de teres as duas formas de autenticação. Certificado para as máquinas habituais que se ligam, e pwd para uma urgência.

Share this post


Link to post
Share on other sites
Bernasjb888

Obrigado Dr_Lion. Não cheguei a fazer permissão fazer login pelo o root, mas vi essa opção. E sim concordo que não seja boa politica.


Uma espécie de programador

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.