Jump to content

excel Copiar célula se sob condição


Recommended Posts

Boa noite,

Já nao aparecia por cá a algum tempo XD

Preciso de ajuda, pois lembrei de fazer algo mas nao sei como fazer.

Analisemos o seguinte caso dentro do mesmo livro excel:

Folha1

Coluna A   -----   Coluna B

Maria        -----       5

Manuel      ----        8

Joaquim   -----        10

 

Folha2

Coluna A   -----   Coluna B

Manuel      ----        ?

Joaquim   -----        ?

Francisco  ------      ?

 

O que eu quero é o seguinte, se o nome da colunaA da folha1 estiver na folha2 ele copia o valor da coluna B da folha1 para a da folha 2.

 

Fui clara? Como faço??

Obrigda

Link to post
Share on other sites
MarcilioLobao

ladytf, Boa tarde.

"...Fui clara?..."

A sua explicação está perfeita.

 

"...Como faço?..."

A função PROCV foi criada especialmente para este tipo de pesquisa.

Supondo:

Folha1 tem dados de A1:B3

Folha2 tem dados de A1:B3

 

Experimente fazer:

Folha2 --> B1 --> FÓRMULA

B1 --> =PROCV(A1; folha1!$A$1:$B$3; 2; FALSO)

 

Lembre-se de travar as células do intervalo de pesquisa com o sinal $ na fórmula para quandoa você puxá-la para baixo ela não alterar o local da tabela.

 

Era isso o que você queria?

Eu espero ter ajudado.

-------------------------------------------------------

Belo Horizonte, MG - Brasil

Marcílio Lobão

............................................
Belo Horizonte, MG - Brasil
Marcílio Lobão

Link to post
Share on other sites

Obrigada peça ajuda,

estava a experimentar para ver se o resultado é o que pretendo, mas, uma vez que as colunas que eu quero trabalhar sao a A e a F apenas quando as selecciono da a mensagem de erro (#Valor).

Link to post
Share on other sites
MarcilioLobao

ladytf, Bom dia.

A fórmula que eu sugerí faz exatamente o que você pediu baseando-me no layout da planilha que você descreveu.

Se ao invés de serem as colunas A e B que que você descreveu, são na verdade as colunas A e F, tente usar:

Folha2 --> F1 --> FÓRMULA

F1 --> =PROCV(A1; folha1!$A$1:$F$3; 2; FALSO)

 

Se ainda não resolver a sua dúvida, salve a sua planilha em algum site gratuito e coloque o link aqui para podermos entender qual é o real problema na sua planilha.

Exemplos de sites gratuitos: www.sendspace.com ; dropbox.com ; ge.tt

Ficamos aguardando a sua resposta.

 

............................................
Belo Horizonte, MG - Brasil
Marcílio Lobão

Link to post
Share on other sites
Ana Paula

Pessoal, queria saber se tem como fazer algo parecido na minha planilha. 

 

Coloquei no we transfer e expliquei dentro dela o que preciso fazer.

 

Seria copiar uma ou várias informações, se a data que estiver em uma planilha for igual a da outra. 

 

Segue link https://we.tl/t-P6MR2i7h0Y

 

Obrigada!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.