Jump to content
sEnte

excel Fórmula errada

Recommended Posts

sEnte

Estou aqui a testar uma coisa.

Tenho a seguinte formula

=SE(N7>=5000;"A";SE(N7>=4000;"B";SE(N7>=3000;"C";SE(N7>=2000;"E";SE(N7>=1000;"F";SE(E(N7>10;N7<=1000);"F-"))))))

 

A formula como está funciona perfeitamente e os N7 aparecem marcados, no entanto se a alterar por exemplo assim

=SE(N7>=5000;"A";SE(N7>=4000;"B";SE(N7>=3000;"C";SE(N7>=2000;"D";SE(N7>=1000;"E";SE(E(N7>=0; N7<=10);"F";SE(E(N7>10; N7<=15);"0+";SE(E(N7<10; N7>5);"G"))))))))

vai-me dar este erro

http://i.imgur.com/0qOSj4N.png

 

Quando clico em vai-me selecionar o último E.

 

Qual será o problema e como o resolver?


"If It Ain't Broke, Break it and build something Cooler!" Unknown

Share this post


Link to post
Share on other sites
HappyHippyHippo

acho que existe um limite de 7

o que poderás fazer é ter uma tabela de limites e fazeres um vlookup (isto se a minha memória não me engana)


IRC : sim, é algo que ainda existe >> #p@p

Share this post


Link to post
Share on other sites
MarcilioLobao

sEnte, Boa tarde.

A sua fórmula não está errada. Ela só está fora das especificações de quantidade de SE disponível para a sua versão de Excel.

Pela sua mensagem, possivelmente você está utilizando o Excel 2003 que permite até 7 funções SE aninhadas.

A partir do Excel 2007 em diante são permitidas até 64 níveis de Função SE. Isso não quer dizer que utilizar esta possibilidade é eficiente ou facilita o trabalho na planilha.

Neste caso o usuário HappyHippyHippo tem toda razão. A Função PROCV (vlookup em inglês) é a mais indicada.

Verifique a lógica dos últimos SE da sua fórmula. Tem algo errado na lógica e nos intervalos.

Minha sugestão:

Suponhamos:

    A       B       C     ...
  +--------------------------
1 |    0       5    F
2 |    6       9    G
3 |   10      15    0+
4 |   16     999    (Branco = Espaço)
5 | 1000    1999    E
6 | 2000    2999    D
7 | 3000    3999    C
8 | 4000    4999    B
9 | 5000            A
  | ...

N7 --> VALOR A SER PESQUISADO

O7 --> FÓRMULA --> =PROCV(N7; $A$1:$C$9; 3; VERDADEIRO)

Faça este teste e nos diga se era isso o que você queria?
Eu espero ter ajudado.

-------------------------------------------------------------------------------------------

Marcílio Lobão

Belo horizonte, MG - Brasil

  • Vote 2

............................................
Belo Horizonte, MG - Brasil
Marcílio Lobão

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.