Jump to content
Adegas

forticlientsslvpn mata as outras conecções

Recommended Posts

Adegas

Olá pessoal,

Estou com um problema, tenho um servidor ubuntu que preciso de ligar via VPN a outro servidor para fazer downloads periódicos de dados.

Mas quando ligo o tunel via forticlientsslvpn o servidor deixa de responder aos pedidos que lhe fazem fora do tunel (HTTP, SSH, etc)

E como é um servidor remoto depois fico sem acesso a ele e tenho que forçar um reboot pelo painel da OVH, para que o tunel caia (juntamente com o servidor). Por este motivo também não consigo ver o que se passa com as configs de rede, pois fico logo sem acesso.

O que queria era ter o tunel aberto, mas que o servidor se mantivesse à escuta no seu ip normal das portas que estão previamente configuradas.

Alguém sabe como configurar isto? Obrigado.

Share this post


Link to post
Share on other sites
apocsantos

Boa noite,

Estás a usar Split tunneling na configuração do forticlientsslvpn ? Creio que seja por aí o problema dado que pelo que percebo do comentário todo o tráfego de dados de incoming e outgoing está a ser encaminhado par ao túnel e tudo o resto a ser descartado.

Cordiais cumprimentos,

Apocsantos


"A paciência é uma das coisas que se aprendeu na era do 48k" O respeito é como a escrita de código, uma vez perdido, dificilmente se retoma o habito"

Share this post


Link to post
Share on other sites
Adegas

Obrigado pela resposta.

 

Ok pelo que percebi tenho de definir um split com o endereço da rede com a qual quero que o tráfego passe pelo túnel.

 

O meu problema é que é a primeira vez que uso forticlientsslvpn e não estou a encontrar documentação onde fazer isso.

 

Estou a usar linha de comandos e tenho um script que arranca o tunel com o comando forticlientsslvpn_cli --server IP_FORTIGATE:PORT_FORTIGATE --vpnuser VPN_USERNAME

Existe algum parametro adicional ou é noutro sitio? Obrigado.

Share this post


Link to post
Share on other sites
Adegas

Estou a perder a cabeça com isto :(

Encontrei várias pessoas a dizer que tinha de dar o visto no wizard das conexão "Use this connection only for resources on its network command line"

Mas eu só tenho acesso à linha de comandos e não sei como reproduzir esse visto na mesma.

Também já experimentei criar um script em /etc/ppp/ip-up.d/rulevpncsm

# Check for specific interface if desired
    [ "$IFACE" != "ppp0" ] || exit 0
    # trigger vpn connection
    ip route add default dev eth1
    ip route add 192.168.3.0/24 dev ppp0
    ip route add 0.0.0.0/0 dev eth1

Mas de nada me serve, mal ligo a VPN deixo de ter acesso ao servidor.

Estou a usar a eth1 pois é a interface do meu ip publico.

Já experimentei também algumas regras iptables mas sem sucesso... à horas nisto...

Help please

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.