Jump to content
sEnte

Instalação PHP manual

Recommended Posts

sEnte

Bom dia pessoal,

Como não gosto muito dos packages tipo XAMPP ou LAMPP decidi instalar, tal como fiz em Linux, Apache, PHP e MySQL à mão em Windows.

Comecei por instalar o apache e não tive qualquer problema.

 

Criei uma pasta em c:/ que lhe dei o nome de "Webserver", extraí o conteúdo do zip descarregado daqui https://www.apachelounge.com/download/VC14/binaries/httpd-2.4.23-win64-VC14.zip 

No ficheiro httpd.conf apenas editei as seguintes "variáveis" 

ServerRoot "c:/Webserver/Apache24"

DocumentRoot "c:/Webserver/Apache24/htdocs/html"

e
<Directory "c:/Webserver/Apache24/htdocs/html">
    #
    # Possible values for the Options directive are "None", "All",
    # or any combination of:
    #   Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
...

Indo aos Serviços do Windows, ou usando o Apache Service Monitor reiniciei o Apache e ficou tudo a funcionar corretamente.

 

Para instalar o PHP

descarreguei daqui http://windows.php.net/downloads/releases/php-7.0.10-Win32-VC14-x64.zip (VC14 x64 Thread Safe (2016-Aug-18 20:13:35)), criei outra pasta dentro da paste Webserver e dei-lhe o nome de PHP7, em seguida extraí o conteúdo do zip para a pasta.

Para que o apache reconheça o PHP fui novamente editar o httpd.conf e alterei o seguinte, No inicio do ficheiro coloquei o seguinte

AddHandler application/x-httpd-php .php
AddType application/x-httpd-php .html .htm
LoadModule php7_module "C:/Webserver/PHP7/php7apache2_4.dll"
PHPIniDir "C:/Webserver/PHP7"

em seguida procurei o extension_dir = "ext" e retirei o ;. Nas Dynamic Exntensions retirei também o comentário a extension=php_curl.dll.

Após reiniciar o apache e indo ao info.php (que criei) ele reconhece o php.ini

6TsamY9.jpg

 

No entanto o cURL não me aparece mais nada de cURL, ou seja, não me aparece a dizer que está ativo....

 

Podem dar uma ajuda?


"If It Ain't Broke, Break it and build something Cooler!" Unknown

Share this post


Link to post
Share on other sites
sEnte

Por acaso vinha marcar este tópico como resolvido. Consegui resolver este problema hoje de manhã. Tive de alterar as variáveis de sistema e adicionar a localização do PHP. O que tinha errado era a / em vez de \

 

De qualquer modo obrigado

 

Já agora como é que se marca como resolvido?

Edited by sEnte

"If It Ain't Broke, Break it and build something Cooler!" Unknown

Share this post


Link to post
Share on other sites
sEnte
3 hours ago, Rui Carlos said:

O CURL não precisa de ser instalado à parte, antes de activares a DLL no PHP?

sim apaguei o ;


"If It Ain't Broke, Break it and build something Cooler!" Unknown

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.