Jump to content
sEnte

session_start

Recommended Posts

sEnte

Num trabalho que comecei está a dar-me este erro

Warning: session_start(): open(/var/lib/php/session/sess_uopc4rsqfo3g1ardfik77t0sl1, O_RDWR) failed: Permission denied (13) in/var/www/html/cart/bootstrap/app.php on line 6

Fatal error: Uncaught exception 'RuntimeException' with message 'Unexpected data in output buffer. Maybe you have characters before an opening <?php tag?' in /var/www/html/cart/vendor/slim/slim/Slim/App.php:552 Stack trace: #0 /var/www/html/cart/vendor/slim/slim/Slim/App.php(344): Slim\App->finalize(Object(Slim\Http\Response)) #1 /var/www/html/cart/vendor/slim/slim/Slim/App.php(298): Slim\App->process(Object(Slim\Http\Request), Object(Slim\Http\Response)) #2 /var/www/html/cart/public/index.php(5): Slim\App->run() #3 {main} thrown in /var/www/html/cart/vendor/slim/slim/Slim/App.phpon line 552

Warning: Unknown: open(/var/lib/php/session/sess_uopc4rsqfo3g1ardfik77t0sl1, O_RDWR) failed: Permission denied (13) in Unknown on line 0

Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/var/lib/php/session) in Unknown on line 0

isto tem a ver com permissões?

Edited by pwseo
removida formatação que impedia uma leitura correcta

"If It Ain't Broke, Break it and build something Cooler!" Unknown

Share this post


Link to post
Share on other sites
HappyHippyHippo

não consigo ler essas letras ... tira a formação dessa fonte


IRC : sim, é algo que ainda existe >> #p@p

Share this post


Link to post
Share on other sites
chbcl

Isso deve ser um problema relacionado com a pasta tmp.

experimenta fazer um phpinfo(); o que tem em 'session.save_path'.

Caso já esteja apontado para a pasta tmp

experimenta alterar as permissões dela para 755.

O servidor que estás a utilizar é linux certo?


developer @ filipealves.net

filipealvesbcl [a] gmail.com

github.com/filipealvesbcl

Share this post


Link to post
Share on other sites
sEnte

@HappyHippyHippo

Não reparei que iso ficou com uma formatação má. De qualquer maneira agradecço ao pwseo por ter alterado a formatação

@chbcl

no info.php está

session.save_path /var/lib/php/session no value

Vou experimentar mudar as permissões

Sim, é um privado que estou a usar e é Fedora 24

Atualização:

Experimentei o simples sudo chmod 775 /var/lib/php/session ou o sudo find /var/lib/php/session/ -type d -exec chmod 775 {} + e nenhum dos dois funcionou. Continuo com o mesmo erro

Edited by sEnte

"If It Ain't Broke, Break it and build something Cooler!" Unknown

Share this post


Link to post
Share on other sites
chbcl

Experimenta:

ini_set('session.save_path',realpath(dirname($_SERVER['DOCUMENT_ROOT']) . '/../session'));
session_start();

se não resultar:

ini_set('session.save_path','/var/www/session'));
session_start();

No caso da segunda opção ser a utilizada, não te esqueças de criar de facto o directorio session e de lhe dar as permissões de dar 0755.

  • Vote 1

developer @ filipealves.net

filipealvesbcl [a] gmail.com

github.com/filipealvesbcl

Share this post


Link to post
Share on other sites
sEnte

Não sei ao certo o que se passou mas experimentei ir à pasta e tentar apagar o ficheiro que lá estava. Como é obvio não consegui. Experimentei dar permissões máximas 777 e aí já consegui apagar o ficheiro. experimentei várias permissões 005, 706, 755 e nesta agora última deixou de dar erro...

estranho...


"If It Ain't Broke, Break it and build something Cooler!" Unknown

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.