Jump to content
N3lson

[Resolvido] Xammp

Recommended Posts

N3lson

Boa tarde, tenho o xammp instalado no pc onde foi desenvolvido a aplicação no visual Studio, foi feito o Build da aplicação mas agora gostaria que me ajudassem no seguinte.

Antes do rebuild eu coloquei nos dados de conexao o servidor "Localhost" mas para o instalador noutro pc coloquei o nome do meu pc (que se encontra na mesma rede) mas acontece que a aplicação nao abre e da erro de ligação.

Portas na Firewall encontram-se abertas mas continua a não dar, no meu pc dá (mas servidor localhost) se colocar nome do pc não da


You can't do it, kid. But don't worry, my boy. You're not the only one. No one else can do it.

Share this post


Link to post
Share on other sites
AJBM

Boas!

Consegues aceder ao xammp, pelo browser do pc onde ele não está instalado?

Já tentaste pelo ip?

Share this post


Link to post
Share on other sites
apocsantos

Boa tarde,

Duas possibilidades, ou a resolução de nomes não está a ser feita correctamente ou o XAMPP não está a aceitar conecções de outras maquinas que não localhost.

Se for resolução de nomes, basta editares o ficheiro hosts, nas maquinas onde queres executar a aplicação e acrescentar uma entrada com o nome do computador com o XAMPP e o respectivo endereço IP. Caso seja o XAMPP a não aceitar conecções, tens de alterar as configurações do XAMPP.

Cordiais cumprimentos,

Apocsantos


"A paciência é uma das coisas que se aprendeu na era do 48k" O respeito é como a escrita de código, uma vez perdido, dificilmente se retoma o habito"

Share this post


Link to post
Share on other sites
N3lson

Boas!

Consegues aceder ao xammp, pelo browser do pc onde ele não está instalado?

Já tentaste pelo ip?

Sim

Boa tarde,

Duas possibilidades, ou a resolução de nomes não está a ser feita correctamente ou o XAMPP não está a aceitar conecções de outras maquinas que não localhost.

Se for resolução de nomes, basta editares o ficheiro hosts, nas maquinas onde queres executar a aplicação e acrescentar uma entrada com o nome do computador com o XAMPP e o respectivo endereço IP. Caso seja o XAMPP a não aceitar conecções, tens de alterar as configurações do XAMPP.

Cordiais cumprimentos,

Apocsantos

Vou tentar


You can't do it, kid. But don't worry, my boy. You're not the only one. No one else can do it.

Share this post


Link to post
Share on other sites
N3lson

Resolvido

Mudado no PhpMyAdmin > Utilizadores > Selecionar <User> -> Alterar Privilégios e na Informação de Login na opção onde diz Máquina alterar de LOCAL para QUALQUER MÁQUINA


You can't do it, kid. But don't worry, my boy. You're not the only one. No one else can do it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.