Ir para o conteúdo
  • Revista PROGRAMAR: Já está disponível a edição #59 da revista programar. Faz já o download aqui!

Lau13

excel Fórmula

Mensagens Recomendadas

Lau13    0
Lau13

Boa tarde,

Não sei se é o melhor local para colocar esta questão mas como não encontrei um tópico sobre EXCEL por isso coloquei aqui, em outras linguagens.

Já fiz uma busca no Google mas não consegui encontrar algo em concreto que solucionasse a minha questão.

Eu tenho duas matrizes de números não ordenados (matriz A e matriz B) em que a matriz A é estática e encontrasse totalmente preenchida e a matriz B vai ser preenchida ao longo do ano. O que eu queria fazer era cada vez que um número inserido na matriz B fosse encontrado um igual na matriz A essa célula/s na matriz A ficasse com uma cor de fundo diferente. Já tentei fazer isto com formatação condicional com o PROC, PROCV, e não consegui que funcionasse a 100%. Alguém conhece alguma formula ou terei mesmo de recorrer a programação VB?

Obrigado.

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
MarcilioLobao    4
MarcilioLobao

Lau13, Boa tarde.

É possível fazer o que você deseja sem recorrer a programação VB.

Talvez ao invés de PROCURAR pelo número, você possa CONTAR quantas vezes o número está na tabela fixa.

Se a quantidade for maior que ZERO, mude a cor.

Para mudar a cor use Formatação Condicional igual você já pretendida fazer mesmo.

Estava no caminho certo.

Exemplo:

Tabela Fixa --> A1:E9

Tabela a ser preenchida --> I1:M9

Preencha A1:E9

Selecione A1:E9

MENU --> Formatação Condicional --> Usando fórmulas

Fórmula --> =CONT.SE($I$1:$M$9;A1)>=1

Coloque a cor que deseja na formatação e OK

Agora experimente colocar qualquer número na matriz I1:M9

Se ele estiver dentro da matriz A1:E9 a célula mudará de cor.

Salvei este pequeno exemplo para facilitar para você.

http://speedy.sh/5Xyac/13-06-2016-PaPrga-Localiza-Numeros-em-Matriz.xlsx

Era isso o que você queria?

Eu espero ter ajudado.

---------------------------------------------------

Belo Horizonte, Brasil

Marcílio Lobão


............................................
Belo Horizonte, MG - Brasil
Marcílio Lobão

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
Lau13    0
Lau13

Bom dia,

MarcilioLobao desde já obrigado pela sua atenção.

Fiz o que me explicou e de facto está a funcionar corretamente, ajudou-me bastante.

Só uma questão, existe a possibilidade de contar os números que estão na tabela A1:E9 (pegando no seu exemplo) que existem na tabela I1:M9? eu tentei usar o CONT.SE mas ele devolve VERDADEIRO ou FALSO e eu queria o número de ocorrências.

Continuação de um bom dia, e mais uma vez obrigado.

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!

Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.

Entrar Agora

×

Aviso Sobre Cookies

Ao usar este site você aceita os nossos Termos de Uso e Política de Privacidade. Este site usa cookies para disponibilizar funcionalidades personalizadas. Para mais informações visite esta página.