Ir para o conteúdo
  • Revista PROGRAMAR: Já está disponível a edição #59 da revista programar. Faz já o download aqui!

MSousa14

[Resolvido] <a> tag não aparece

Mensagens Recomendadas

MSousa14    0
MSousa14

Boa noite

Estou neste momento a criar um site pessoal usando as linguagens mais usadas para o efeito, no entanto deparo-me com a seguinte situação. Quero introduzir uma imagem, que servirá de link, e gostaria que a passar com o rato por cima que a mesma ficasse mais transparente.

Logo introduzi este código

No Ficheiro HTML

<div id="bigpic">
  <a href="google.pt">
  <img src="images/night1.jpg" alt="night" width="747" height="550"></img>
  </a>
</div>

No Ficheiro CSS

div#bigpic {
 height: 550px;
 width: 747px;
 position: absolute;
}

div#bigpic:hover {
 height: 550px;
 width: 747px;
 position: absolute;
 opacity: 0.7;
 transition: 1s;
}

O problema é que <a> tag não está a funcionar, e ao passar o cursor por cima da imagem, a mesma mantém-se igual.

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
MSousa14    0
MSousa14

Obrigado pela ajuda

Já detectei o problema.

O que acontece é que na folha de estilos é que a div#bigpic está inserida noutra div, que por sua vez tinha-lhe atribuído um z-index: -2.

Limitei-me apenas a retirar essa característica e já funcionou.

Mas agradeço as sugestões.

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!

Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.

Entrar Agora

×

Aviso Sobre Cookies

Ao usar este site você aceita os nossos Termos de Uso e Política de Privacidade. Este site usa cookies para disponibilizar funcionalidades personalizadas. Para mais informações visite esta página.