Jump to content

excel Fórmula pesquisa número em várias células (separador diferente)


Hitpack
 Share

Recommended Posts

Boa tarde, estou a usar a seguinte formula para fazer um mapa mensal com base numa escala diária =SE(E('01'!A1=1);"AT";"")), em que '01'! é o separador onde quero recolher os dados, A1=1 será o número que pretendo naquela célula e AT o tipo de serviço que quero que apareça no mapa mensal, até aqui tudo bem resulta na perfeição, mas se tento fazer esta formula com várias células dá-me o erro #VALOR, exemplo =SE(E('01'!A1:A9=1);"AT";"")), ou seja célula a célula funciona na perfeição mas não me serve pois daria um conjugar de funções que excedem o aceitavél pelo excel, mas se tento com seleção de várias células dá-me erro, alguém me sabe explicar o que estou a fazer mal. Abraço

Link to comment
Share on other sites

https://meocloud.pt/link/f3b611a0-1dee-4c28-a6c1-45d5704dd699/mapa%20mensal.xls/

Neste link já coloquei com a formula que pretendo, a que está no funcionário 1 é a que funciona, mas não me serve, teria de escrever uma formula gigante e que o excel não aceitaria, a que está no funcionário 2 é a que pretendo, mas que me dá erro e não percebo porquê...

Edited by Hitpack
Link to comment
Share on other sites

Acho que o que queres é isto:

https://dl.dropboxusercontent.com/u/6551/mapa%20mensal.xls

Notas:

- as folhas de cada dia devem ter os nomes 1, 2, 3, etc e não com zeros à esquerda

- Na folha '1' acrescentei uma coluna para calcular as horas (saida - entrada). Está sempre a 8 horas mas podes eventualmente ter outros cenários.

Vê lá

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.