Jump to content

Somar divisores de um número


Sandi
 Share

Recommended Posts

não consigo fazer a soma dos divisores do segundo número em diante, este programa está com erro

algoritmo "somadivisores"

// Função :
// Autor :
// Data : 13/10/2014
// Seção de Declarações
var
cont, num, divnum: inteiro
somadiv, total: real
inicio
// Seção de Comandos
cont<-1
enquanto cont<=5 faca
 escreva("Digite um número inteiro e positivo: ")
 leia (num)
 para divnum de 1 ate num passo 1 faca
   se num mod divnum = 0 entao
     escreval ("O seu divisor é: ", divnum)
     somadiv<-(somadiv+divnum)
     total<-somadiv-num
   fimse
 fimpara
 cont<-cont+1
 escreval ("A soma dos seus divisores é:", total)
 escreval()
fimenquanto
fimalgoritmo
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.