Jump to content

O SQL Server não existe ou o acesso foi recusado


Lfscoutinho
 Share

Recommended Posts

Bom dia,

Estou desde segunda-feira com um problema que não consigo resolver, nem encontrar solução.

Tenho uma pequena aplicação em PHP que conecta com um servidor MSSQL via PDO.

Esta aplicação está a funcionar em várias máquinas com o Easyphp, mas na Segunda-feira instalei-a num PC em que não consigo aceder ao servidor através do PHP. Isto é, se abrir o SQL Server Management Studio, consigo-me ligar à instância, tanto por Windows Authentication como por SQL Server Authentication, mas no PHP retorna-me sempre o mesmo erro: SQLSTATE[08001] SQLDriverConnect: 17 [Microsoft][ODBC SQL Server Driver][DBNETLIB]O SQL Server não existe ou o acesso foi recusado.

  • Já desinstalei e voltei a instalar o SQL.
  • No SQL Server Configuration Manager
    • SQL Server Services: SQL Server e SQL Server Browser estão iniciados
    • SQL Server Network Protocols -> Protocols for SQLEXPRESS: Shared Memory, Named Pipes, TCP/IP e VIA estão ligados
    • SQL NATIVE Client 10.0 Configuration -> Client Protocols: Shared Memory, Named Pipes, TCP/IP e VIA estão ligados

    [*]No services.msc

    • SQL Server (SQLEXPRESS) está iniciado
    • SQL Server Browser está iniciado

Estou a utilizar o utilizador sa e tem todas as permissões. Estive a comparar todas as configurações com as do meu PC onde está tudo a funcionar direito e está tudo igual, não sei o que possa ser. Estou farto de googlar desde segunda-feira e encontrei algumas pessoas com o mesmo problema que eu, mas nenhuma das soluções funcionou comigo. Se já aconteceu a alguém ou alguém sabe como resolver este problema, agradeço a vossa ajuda.

Obrigado.

Link to comment
Share on other sites

Sim, ODBC via PDO.

define('DBDSN', 'odbc:Driver={SQL Server};Server=NOME-PC\SQLEXPRESS;Database=mydb;');
define('DBUSERNAME', 'sa');
define('DBPASSWD', '');

new PDO(DBDSN, DBUSERNAME, DBPASSWD, array(PDO::ATTR_ERRMODE => PDO::ERRMODE_EXCEPTION, PDO::ODBC_ATTR_ASSUME_UTF8 => TRUE) );

Não penso que o problema esteja aqui, isto está a funcionar em várias máquinas sem nenhum problema.

Daí eu pensar que deve ser alguma configuração no SQL.

Link to comment
Share on other sites

Cria um ficheiro .udl com o notepad e verifica se estás a parametrizar correctamente as propriedades de ligação de dados.

Se estás a usar Autenticação Windows, poderás ter de criar um novo login/user para aceder a essa base de dados (nem que seja "Convidado").

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.