Jump to content
acao

set_time_limit()

Recommended Posts

acao

boas

estou com um Warning, no sccript de fazer upload de ficheiros,

só estou a conseguir o envio de 1 ficheiro e mesma assim da este erro:

Warning: set_time_limit() has been disabled for security reasons in /home/xxxxxxx/public_html/ClassGlobls/ClassUploadImage.php on line 44

se enviar 4 ficheiros não envia e não da o erro.

cod:

blic function uploadImage($IdUser,$intTamanhoMaiorImagem){
    set_time_limit(0);
}

tenho o set_time_lomit(0)

logo a seguir á função.

cumps

acao

Share this post


Link to post
Share on other sites
acao

boas

obrigado pela ajuda.

não resolveu.

neste momento tenho este erro:

Request Entity Too Large

The requested resource /xxxxxxxxxx.php

  1. does not allow request data with POST requests, or the amount of data provided in the request exceeds the capacity limit.

o meu htaccess tem esta configuração:

# alterar upload para ficheiros
php_value upload_max_filesize 10M
php_value post_max_size 30M
php_value max_execution_time 3000
php_value max_input_time 3000

cumps

acao

edit:

já tentei varias varias opções.

necessito de aumentar o tempo de execução do sript. par 5, 10 minutos,

e so executa cerca de minuto e meio.

se alguém tiver alternativa ou solução agradeço.

já tentei também:

@ini_set('upload_max_size' , '32M');
	@ini_set('post_max_size', '32M');
	@ini_set('max_execution_time', '3000');

cumps

acao

Edited by acao

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.