Ir para o conteúdo
sEnte

Problema instalação MariaDB

Mensagens Recomendadas

sEnte

Há certas coisas que me tiram do sério :S

Estou a tentar instalar o MariaDB e segui estes passos

https://downloads.mariadb.org/mariadb/repositories/#mirror=fe_up_pt&distro=Ubuntu&distro_release=precise&version=5.5

Adicionei o repositório e pronto, tudo a andar. Quando vou fazer sudo apt-get install mariadb-server mariadb-client

aparece-me isto

fidbeck@fidbeck-S510-X-CP20P:~$ sudo apt-get install mariadb-server mariadb-client

Reading package lists... Done

Building dependency tree

Reading state information... Done

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming.

The following information may help to resolve the situation:

The following packages have unmet dependencies:

mariadb-client : Depends: mariadb-client-5.5 (= 5.5.33a+maria-1~precise) but it is not going to be installed

mariadb-server : Depends: mariadb-server-5.5 (= 5.5.33a+maria-1~precise) but it is not going to be installed

E: Unable to correct problems, you have held broken packages.

fidbeck@fidbeck-S510-X-CP20P:~$ sudo apt-get install mariadb-server-5.5 mariadb-clien-5.5t

Reading package lists... Done

Building dependency tree

Reading state information... Done

E: Unable to locate package mariadb-clien-5.5t

E: Couldn't find any package by regex 'mariadb-clien-5.5t'

fidbeck@fidbeck-S510-X-CP20P:~$ sudo apt-get install mariadb-server-5.5 mariadb-clien-5.5

Reading package lists... Done

Building dependency tree

Reading state information... Done

E: Unable to locate package mariadb-clien-5.5

E: Couldn't find any package by regex 'mariadb-clien-5.5'

fidbeck@fidbeck-S510-X-CP20P:~$ sudo apt-get install mariadb-server-5.5 mariadb-client-5.5

Reading package lists... Done

Building dependency tree

Reading state information... Done

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming.

The following information may help to resolve the situation:

The following packages have unmet dependencies:

mariadb-client-5.5 : Depends: libdbd-mysql-perl (>= 1.2202) but it is not going to be installed

Depends: mariadb-common but it is not going to be installed

Depends: libmariadbclient18 (>= 5.5.33a+maria-1~precise) but it is not going to be installed

Depends: mariadb-client-core-5.5 (>= 5.5.33a+maria-1~precise) but it is not going to be installed

mariadb-server-5.5 : Depends: mariadb-server-core-5.5 (>= 5.5.33a+maria-1~precise) but it is not going to be installed

PreDepends: mariadb-common but it is not going to be installed

E: Unable to correct problems, you have held broken packages.

fidbeck@fidbeck-S510-X-CP20P:~$ sudo apt-get install -f mariadb-server-5.5 mariadb-client-5.5

Reading package lists... Done

Building dependency tree

Reading state information... Done

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming.

The following information may help to resolve the situation:

The following packages have unmet dependencies:

mariadb-client-5.5 : Depends: libdbd-mysql-perl (>= 1.2202) but it is not going to be installed

Depends: mariadb-common but it is not going to be installed

Depends: libmariadbclient18 (>= 5.5.33a+maria-1~precise) but it is not going to be installed

Depends: mariadb-client-core-5.5 (>= 5.5.33a+maria-1~precise) but it is not going to be installed

mariadb-server-5.5 : Depends: mariadb-server-core-5.5 (>= 5.5.33a+maria-1~precise) but it is not going to be installed

PreDepends: mariadb-common but it is not going to be installed

E: Unable to correct problems, you have held broken packages.

fidbeck@fidbeck-S510-X-CP20P:~$ sudo nano /etc/apt/sources.list


"If It Ain't Broke, Break it and build something Cooler!" Unknown

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
sEnte

Já não é a primeira vez que tenho problemas com isto :S Da outra vez instalei a versão 10 e tive problemas com o update, agora isto :S

para que não fiquem dúvidas...

fidbeck@fidbeck-S510-X-CP20P:~$ sudo apt-get install mariadb-server mariadb-client

Reading package lists... Done

Building dependency tree

Reading state information... Done

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming.

The following information may help to resolve the situation:

The following packages have unmet dependencies:

mariadb-client : Depends: mariadb-client-5.5 (= 5.5.33a+maria-1~precise) but it is not going to be installed

mariadb-server : Depends: mariadb-server-5.5 (= 5.5.33a+maria-1~precise) but it is not going to be installed

E: Unable to correct problems, you have held broken packages.

fidbeck@fidbeck-S510-X-CP20P:~$ sudo apt-get install mariadb-client-5.5 mariadb-server-5.5

Reading package lists... Done

Building dependency tree

Reading state information... Done

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming.

The following information may help to resolve the situation:

The following packages have unmet dependencies:

mariadb-client-5.5 : Depends: libdbd-mysql-perl (>= 1.2202) but it is not going to be installed

Depends: mariadb-common but it is not going to be installed

Depends: libmariadbclient18 (>= 5.5.33a+maria-1~precise) but it is not going to be installed

Depends: mariadb-client-core-5.5 (>= 5.5.33a+maria-1~precise) but it is not going to be installed

mariadb-server-5.5 : Depends: mariadb-server-core-5.5 (>= 5.5.33a+maria-1~precise) but it is not going to be installed

PreDepends: mariadb-common but it is not going to be installed

E: Unable to correct problems, you have held broken packages.

fidbeck@fidbeck-S510-X-CP20P:~$


"If It Ain't Broke, Break it and build something Cooler!" Unknown

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
sEnte

@Devexz

Agora estou a experimentar o elementaryOS Luna que é derivado do Ubuntu 12.04 LTS

@Rui Carlos

Fiz uma instalação de raiz por conseguinte...

fidbeck@fidbeck-S510-X-CP20P:~$ mysql --version

The program 'mysql' is currently not installed. You can install it by typing:

sudo apt-get install mysql-client-core-5.5

fidbeck@fidbeck-S510-X-CP20P:~$

Por conseguinte não está instalado :S


"If It Ain't Broke, Break it and build something Cooler!" Unknown

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
sEnte

Esta semana estive fora mas mais logo vou experimentar esse medicamento :)

Obrigado


"If It Ain't Broke, Break it and build something Cooler!" Unknown

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!

Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.

Entrar Agora

×

Aviso Sobre Cookies

Ao usar este site você aceita os nossos Termos de Uso e Política de Privacidade. Este site usa cookies para disponibilizar funcionalidades personalizadas. Para mais informações visite esta página.