Jump to content
zukinha

[Resolvido] phpMyAdmin Problema

Recommended Posts

zukinha

Boa tarde,

No phpadmin deixei de conseguir "escrever" nas BD, acontece que se for pelo o localhost fazer a buscar da database funciona sem problema, mas, quando tento aceder phpadmin funciona tudo bem ate ir à parte para adicionar/escrever na BD.

Fica foto em anexo como aparece.

601095_545792545500539_2095490130_n.jpg

Alguém sabe como posso contornar este erro? Não consigo fazer backup porque quando faço exporta o ecrã fica também em branco.

Cumprimentos,

Share this post


Link to post
Share on other sites
acao

boas

em ultimo recurso penso que podes desinstalar o xamp sem eliminares a base de dados, e provavelmente ao instalar resolverá o erro.

eu disse ultimo recurso!

ou então reinstalar por cima.

cumps

acao

Share this post


Link to post
Share on other sites
Pivot

Já agora, utiliza o mysql workbench se o erro persistir.

Isso nunca me aconteceu, portanto só te posso aconselhar a limpar cache e cookies...

Link do mysql workbench:

http://dev.mysql.com/downloads/tools/workbench/

Às vezes utilizo o phpmyadmin, outras o mysql workbench.

É uma boa ferramenta, portanto aconselho-te a explorares.

É fácil! :)

PS: Também consegues fazer exports neste programa!

Abraço,

Rafael.

Share this post


Link to post
Share on other sites
zukinha

Boas,

existem coisas do diabo... Carreguei no Alt para abrir o separador de ferramentas e puf apareceu tudo como devia. :O estranho...

Aproveito este tópico, para pedir uma ajuda mesmo de Rookie, tenho o xampp instalado no meu pc e tenho as pastas colocadas no htdocs como deve ser, ou seja, os links são sempre começados por: "http://localhost".

Gostaria de partilhar as base de dados com o meu pc da sala, ou seja, o pc da sala conseguir navegar pelas paginas do htdocs como se de um site se tratasse.

Pois se eu partilhar a pasta htdocs não funciona, porque o links tao todos começados por: "http://localhost".

Edited by zukinha

Share this post


Link to post
Share on other sites
zukinha

Estive a tentar essa solução mas não abre, fica a pensar/loading e não sai dali.

Tenho que partilhar a pasta htdocks ou outra?

Testei no, chrome, e no explorer.

Share this post


Link to post
Share on other sites
HappyHippyHippo

nada de partilha

qual o IP da máquina que tem o xampp instalado ?

ps : já agora o IP da máquina que quer aceder ao xampp

Edited by HappyHippyHippo

IRC : sim, é algo que ainda existe >> #p@p

Share this post


Link to post
Share on other sites
zukinha

o ping funciona, estamos na mesma rede/grupo de trabalho ate porque tenho varias pastas partilhadas entre os pc's.

O IP do quarto onde tenho o xamp instalado é 192.168.0.15

O IP do pc da sala é 192.168.0.17

desde já obrigado pelas respostas. :D

Share this post


Link to post
Share on other sites
zukinha

BINGO...

Era a firewall a bloquear o acesso.

Agora reparei numa situação.. :S

As imagens estão todas a dar erro, e as paginas tenho que estar sempre a substituir o localhost pelo o 192.168.0.15. Existe maneira de contornar esse problema ou tenho que alterar mesmo tudo?

Share this post


Link to post
Share on other sites
zukinha

Caminhos relativos? como assim? utilizar o IP em vez do localhost? desculpa a ignorância.

Share this post


Link to post
Share on other sites
HappyHippyHippo

deverás ter no teu HTML algo do género:

<img src="http://localhost/imagem.png" alt="image" />

isso está em caminho absoluto

devirias escrever em relativo:

<img src="imagem.png" alt="image" />


IRC : sim, é algo que ainda existe >> #p@p

Share this post


Link to post
Share on other sites
brunoais

Tens que saber o teu ip local.

Abre o cmd

escreve:

ipconfig

dever poder ver um ipv4 do tipo:

192.168.1.X

O que interessa é o nº do X.

depois, no outro computador, escreves o url do tipo:

http://192.168.1.X

(em que o X é o numero que apareceu no cmd)


Este aqui nem me avisou que já havia resposta neste tópico!!!!!!!

[desabafo]Pq razão é que um sistema pago é pior que um grátis nestas coisas tão simples!??!!?[/desabafo]

Edited by brunoais

"[Os jovens da actual geração]não lêem porque não envolve um telecomando que dê para mirar e atirar, não falam porque a trapalhice é rainha e o calão é rei" autor: thoga31

Life is a genetically transmitted disease, induced by sex, with death rate of 100%.

Share this post


Link to post
Share on other sites
I-NOZex

ou, sem saber se defacto funciona(!), podes ir na maqina que nao tem o xampp a C:\Windows\System32\drivers\etc\ e editas o ficheiro hosts e defines o localhost a apontar para o IP do pc que tem o XAMPP

como disse, eu nao sei se isto funciona sequer, mas acho que é suposto funcionar :thumbsup: so testando

ainda assim ,para nao teres problemas mesmo, usa sempre relativos, se por algum motivo nao puderes, tenta isto e usa quando precisares de caminhos absolutos


B2R » Beat2Revolution v3.0b | Regista e divulga-nos

beat2revolution.net

Share this post


Link to post
Share on other sites
fil79

ou, sem saber se defacto funciona(!), podes ir na maqina que nao tem o xampp a C:\Windows\System32\drivers\etc\ e editas o ficheiro hosts e defines o localhost a apontar para o IP do pc que tem o XAMPP

como disse, eu nao sei se isto funciona sequer, mas acho que é suposto funcionar :thumbsup: so testando

ainda assim ,para nao teres problemas mesmo, usa sempre relativos, se por algum motivo nao puderes, tenta isto e usa quando precisares de caminhos absolutos

Assim deverá funcionar, de facto


MCITP-MCTS-MCP

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.