Ir para o conteúdo
RitaAndrade

[Resolvido] .RTF com acentos

Mensagens Recomendadas

RitaAndrade

Boa tarde pessoal...

Ando com um problema, tenho uma RichTextBox, já guarda texto formatado (italico, negrito e sublinhado), mas quando tento guardar texto com acentos ou Ç dá erro, pois ele tenta guardar por exemplo 'e11 para representar o á.

depois dá erro pois diz que falta fechar uma '...

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
RitaAndrade

Desde já agradeço a ajuda...

Em lado nenhum eu especifíco qual o RichTextBoxStreamType, talvez o problema é mesmo esse, eu guardo da seguinte maneira:

ExecutarNonQuerySQL("EXEC sp_guardar_RELATORIOANALISE " &
					    "@id=" & idRELATORIO & "', @notas='" & notasRichTextBox.Rtf & "', @foto='" & foto & "', @datasaida='" & dataSaidaMaskedTextBox.Text & "', @assinatura='" & assinaturaTextBox.Text & "'")

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
nelsonr

O problema está que estás a delimitar o conteúdo da richtextbox com plicas, o que é problematico quando o proprio conteúdo tem plicas.

Experimenta assim:

ExecutarNonQuerySQL("EXEC sp_guardar_RELATORIOANALISE " & "@id=" & idRELATORIO & "', @notas='" & notasRichTextBox.Rtf.Replace("'", "''") & "', @foto='" & foto & "', @datasaida='" & dataSaidaMaskedTextBox.Text & "', @assinatura='" & assinaturaTextBox.Text & "'")

Caso funcione bem, convem fazer o mesmo para todos os campos delimitados por plicas

  • Voto 1

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!

Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.

Entrar Agora

×

Aviso Sobre Cookies

Ao usar este site você aceita os nossos Termos de Uso e Política de Privacidade. Este site usa cookies para disponibilizar funcionalidades personalizadas. Para mais informações visite esta página.