Jump to content
thoga31

[Resolvido] Processos task* consomem Internet a taxas astronómicas

Recommended Posts

thoga31

Olá, pessoal.

Ando aqui num dilema com o meu computador e a Internet.

Estou neste momento em férias e ando com a minha internet móvel (uma pen), e desde o início de Agosto, mais coisa menos coisa, que reparei que tem havido um gasto astronómico de Internet. Não me teria apercebido não fossem os registos dos primeiros 7 dias do mês dizerem-me que já tinha gasto quase 50% do plafond mensal.

Tenho andado a investigar o assunto, e sempre que me conecto à Internet inicia-se uma taxa de download altíssima que é até incomum para esta pen - recorrendo ao netstat fui ver que processos estavam a exigir conexões à rede e fui desligando os processos ou alterar-lhes as propriedades - desactivei a sincronização automática da Dropbox, desactivei a actualização automática das definições do antivírus, entre outros. E ainda assim o gasto era o mesmo.

Tive de me virar para os processos aos quais não pensaria serem os responsáveis: taskeng, taskhost e taskhostex (e uma vez o WWAHost). Portanto, quando me ligo à Internet estes três processos iniciam e, quando os forço a terminar, o download termina e volta tudo ao normal.

Segundo investiguei há vírus que simulam estes nomes, mas a origem destes processos todos está na System32 e não noutro directório qualquer.

E é aqui que chego ao ponto em que não consegui ainda encontrar informação útil acerca deste problema que estou a ter por esses cantos da Internet.

Como poderei eu detectar o porquê destes gastos incríveis de Internet e como poderei resolver esta situação? É que, parecendo que não, enquanto tento terminar os processos (de vez em quando eles reiniciam) acabo por gastar 30 MB em nada, e 30*30=900 MB num mês para esta brincadeira. O meu plafond é de 2GB, e era suposto eu usar os 2 GB para mim, e não metade deles em algo que nem sequer sei o que é nem porque é.

Cumprimentos,

thoga31 ;)


Knowledge is free!

Share this post


Link to post
Share on other sites
Rui Carlos

Acho um pouco suspeito que esses serviços iniciem quando ligas a net.

Experimenta seguir as indicações disponíveis aqui para desactivar o taskeng, e vê se ele continua a usar net depois.

Share this post


Link to post
Share on other sites
thoga31

@Rui Carlos, agradeço-te as dicas, mas por alguma razão as definições estão bloqueadas e não consigo de maneira nenhuma alterar as definições. Nem sequer tenho permissão para parar o serviço, mesmo em modo de administrador.

Também acho estranho os processos consumirem tanta net - hoje gastou à partida cerca de 49 MB, e depois parou. Houve um dia que foi 200 MB. Sinceramente não entendo, é a primeira vez que estes processos estão a ter este comportamento.


Knowledge is free!

Share this post


Link to post
Share on other sites
Rui Carlos

Tendo em conta a função desse processo, acho que não faz sentido gastar net.

Podes também tentar encerrar o processo no gestor de tarefas, e ver o que é que acontece (convém é que não estejas a fazer nada crítico na altura).

Share this post


Link to post
Share on other sites
thoga31

Eu costumo encerrar de imediato os processos mal ligo à net, já me habituei a abrir o Gestor de Tarefas antes de ligar o modem :D

Aliás, foi desta forma que descobri que eram estes os processos a consumir. E de facto é estranho, supostamente eles não deviam consumir net... :confused:


Knowledge is free!

Share this post


Link to post
Share on other sites
pwseo

Já experimentaste correr algum software anti-malware e outros bichos do género? (e não apenas um mero antivírus).

Share this post


Link to post
Share on other sites
nelsonr

Não dá para entrar em safe mode com rede?

Ou então corre o msconfig e verifica o que está a ser executado no arranque, ver se há alguma coisa suspeita

Share this post


Link to post
Share on other sites
thoga31

Já corri o Avast, o Windows Defender e o Spybot, nenhum deles encontrou o que quer que fosse.

No msconfig não encontro nada de suspeito, apenas uma tonelada de serviços da Microsoft e meia dúzia de outros serviços perfeitamente normais, excepto um que suspeito saber o que é - "UI Assistant Service", penso que seja da banda larga, mas não tenho a certeza. O programa que gere a banda larga é o "UImain.exe", portanto estou a fazer esta associação.

Isto é mesmo muito estranho... agora venho a um café da terra que tem wi-fi, e constato que há sempre um gasto inicial de Internet - hoje foi de cerca de 90MB.


Knowledge is free!

Share this post


Link to post
Share on other sites
Rui Carlos

Se é um gasto inicial, isso pode estar relacionado com os updates do sistema e do anti-vírus ou outro software que tenha updates automáticos (se bem que 90MB me parece um pouco exagerado).

Share this post


Link to post
Share on other sites
thoga31

Se é um gasto inicial, isso pode estar relacionado com os updates do sistema e do anti-vírus ou outro software que tenha updates automáticos (se bem que 90MB me parece um pouco exagerado).

desactivei a sincronização automática da Dropbox, desactivei a actualização automática das definições do antivírus, entre outros. E ainda assim o gasto era o mesmo.

Além disso, o Windows Update não tem as actualizações automática ligadas, ele apenas me avisa de novas actualizações e eu escolho quais instalo e quando instalo. E sim, isto não consome 90MB.

Não são actualizações nem nada que se pareça. Até os tiles do ecrã Iniciar estão desligados (excepto o Correio).

O que comprova que são estes processos task* é simplesmente isto: quando me ligo à Internet há a tal taxa de download, e quando termino estes processos este download termina de imediato. Se encerrar os processos logo a seguir a ligar à net, este download só ocorre por uns 5~10 segundos (o tempo de confirmar os pedidos de encerramento dos processos). Mais, se desligar a net e voltar a ligar, estes processos arrancam mal a conexão é feita.

Edited by thoga31

Knowledge is free!

Share this post


Link to post
Share on other sites
programadorvb6

Olá thoga31.

O que descreves tem todo o aspecto de sere vitima de um programa RAT ( Server).

Nota: Não adianta correres software anti-malware etc.. visto serem desenhados sobre arquitetura FUD.

Edited by programadorvb6

______________________________________________________________________________

Que minha coragem seja maior que meu medo e que minha força seja tão grande quanto minha fé.
 

Share this post


Link to post
Share on other sites
thoga31

Supostamente esses programas deveriam estar em contacto constante com o PC, suponho? Mas se eu termino os processos task*, o contacto termina. E se eu deixar correr os processos, eles acabam por deixar de consumir Internet passado algum tempo e tudo volta ao normal (podem gastar 40, 90 ou 150 MB, mas lá param - eu é que não tenho plafond para isto todos os dias, gastava tudo numa semana e meia).

Um programa RAD não deveria estar sempre a comunicar, mesmo com taxas baixas de upload/download, em vez de parar por completo e só fazer a conexão quando arranco?


Knowledge is free!

Share this post


Link to post
Share on other sites
programadorvb6

Olá thoga31

Dependendo do server (RAT) instalado e a configuração efetuada por quem criou.

Edited by programadorvb6

______________________________________________________________________________

Que minha coragem seja maior que meu medo e que minha força seja tão grande quanto minha fé.
 

Share this post


Link to post
Share on other sites
thoga31

Eu de qualquer das formas vou formatar o PC em breve. Depois digo se a sede por internet normalizou ;)

Obrigado a todos.


Knowledge is free!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.