Jump to content
startuga

[Resolvido] IIS System

Recommended Posts

startuga

Boas pessoal,

Alguém aqui têm algumas luzes de como funciona o IIS7?

Estou à horas a tentar por uma WebApp a correr por lá e não consigo :x

Share this post


Link to post
Share on other sites
nelsonr

Boas,

o que pretendes saber exatamente?

Normalmente será apenas necessário adicionar lá uma aplicação ou directoria virtual e apontas para a pasta da tua aplicação.

Depois acedes pelo browser colocando o endereço do servidor/alias da aplicação

Que erro tens?

Share this post


Link to post
Share on other sites
cdaniel.marques

Dependendo das alterções que já fizestes, por defeito, após instalares o IIS através do Adicionar ou remover funcionalidades do Windows, basta colocares os ficheiros html em: c:\inetpub\wwwroot\, e podes aceder no teu browser usando: http://localhost/.

Exemplo: colocas uma pasta chamda website1 em wwwroot com a página inicial index.html e acedes no browser usando o seguinte endereço:

http://localhost/website1/index.html

Share this post


Link to post
Share on other sites
cdaniel.marques

No Painel de Controlo, Ferramentas Administrativas, Gestor de Serviços Informação de Internet, em Sites, Podes ver os sites e os caminhos.

Por defeito tens um site "Default Web Site" em %Systemdrive%\inetpub\wwwroot, na porta 80 (=http://localhost:80/website1/index.html)

Verifica no estado se está iniciado.

Edited by cdaniel.marques

Share this post


Link to post
Share on other sites
startuga

O que pretendo é por uma WebApp a disponivel para toda a rede web de uma empresa.

Share this post


Link to post
Share on other sites
nelsonr

O que pretendo é por uma WebApp a disponivel para toda a rede web de uma empresa.

Basta colocares a funcionar numa máquina, abrir a porta 80 de entrada na firewall (se tiver bloqueada).

Para acederes de outro computador na rede, colocas no browser o nome da máquina/alias.

Share this post


Link to post
Share on other sites
startuga

Obrigado pessoal.

Descobri à pouco que o problema derivava de uma incompatibilidade entre a .net do programa e a que estava a usar no IIS, e na forma como estava a executar a connection string:

Integrated Security=True

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.