Jump to content
Flinger

Problemas DNS no Windows 7 + ZON

Recommended Posts

Flinger

Bom dia.

Estou com um berbicacho lá por casa. O meu PC, com Windows 7 ultimate, anda-me a moer o juízo para conseguir aceder à net.

Quando ligo o PC, e arranco o browser, ele carrega as home pages (Google + iGoogle). às vezes carrega-as por inteiro outras vez apenas parcialmente. Logo a seguir, qualquer outra página que tente abrir, quase que dá. Volta e meia lá carrega alguma parcialmente, mas ao voltar a fazer refresh, já era. O que acusa é um problema de DNS.

Tenho de esperar 15 ou 20 minutos, e passado esse tempo, começa a dar tudo bem.

Este PC está assim já à bastante tempo. Pensei que fosse algum stress da instalação do Windows, formatei-o, e ficou na mesma. Troquei a placa Wireless, e continua na mesma, enfim, passei a considerar não defeito, mas feitio. Houve mesmo uma altura que tentei forçar os endereços DNS, e coloquei os do Google, mas continuou com problemas.

Para ajudar à festa, apercebi-me à pouco tempo que o portátil da miúda, também com windows 7, tem o mesmo problema. Depois de arrancar, antes que consiga abrir uma página, é um 31.

Esta semana, levei para casa um novo portátil, da empresa, também com Windows 7, e voilá, mais do mesmo :S

Mas mais ridículo ainda, não consigo abrir uma página, mas consigo ligar à VPN da minha empresa, e a partir daí abrir páginas à vontade... deito a ligação à VPN abaixo e volto ao mesmo :S.

Na empresa, sem estar ligado à VPN, não tenho stress nenhum, mesmo quando ligado à rede wifi.

OK, poderá ser problema da ligação lá de casa (ZON), router, ou qq coisa... Mas para me baralhar ainda mais, tenho telemóvel com Android, e um outro portátil com windows XP, e ambos funcionam perfeitamente, sem stress nenhum...

Alguém tem alguma luz sobre isto?

Share this post


Link to post
Share on other sites
Rui Carlos

Eu já tive problemas semelhantes, que resolvi usando o DNS do google com segunda opção de DNS no router.

A única ideia que me vem à cabeça é experimentares outros serviços de DNS (como o OpenDNS).

Já agora, se fizeres queries de DNS directamente (na consola, por exemplo) notas algum problema?

Share this post


Link to post
Share on other sites
Flinger

Noto. Não responde. Mas se usar o IP dá perfeitamente. Acho que vou mesmo tentar mudar os endereços no router. Se bem que acho que já tentei (fui lá ver e embora tenha os settings para usar os DNS automáticos, ainda lá estão os endereços dos da google.

O mais estranho para mim é isto só acontecer nas máquinas com Windows 7.

Share this post


Link to post
Share on other sites
HappyHippyHippo

com a solução do rui carlos, tenta manipular o timeout do dns para tornar isso ainda mais rápido :

http://technet.microsoft.com/en-us/library/ff807396%28v=WS.10%29.aspx

dessa forma, se falhar o primeiro DNS (zon) o da google entra mais rapidamente em acção

Edited by HappyHippyHippo

IRC : sim, é algo que ainda existe >> #p@p

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.