Jump to content
kabadax

Registo de utilizadores

Recommended Posts

kabadax

Boa tarde!

Tenho este código para fazer o registo de um novo utilizador para o LOGIN.

If TextBox2.Text <> TextBox3.Text Then
		MsgBox("As password's não conferem!", MsgBoxStyle.Information)
		TextBox1.Clear()
		TextBox2.Clear()
		TextBox3.Clear()
	Else
		Me.Validate()
		Me.LOGINBindingSource.EndEdit()
		Me.TableAdapterManager.UpdateAll(Me.RegistoDataSet)
		MsgBox("Utilizador criado com sucesso", MsgBoxStyle.Information)
		Me.Close()
		LoginForm1.Show()
	End If

O Login com os que estão inseridos na base de dados funciona.

Se tentar inserir novos utilizadores por um formulário chamado "Registo" não grava na base de dados Registo.mdf.

O código que lhe enviei posteriormente é o que tenho no botão "OK" .

Eu clico "Adicionar Utilizador" e ele coloca as textbox como enable=true para poder registar. Mas depois ao clicar OK aparece a mensagem que o utilizador foi criado com sucesso mas isso não aconteceu.

Share this post


Link to post
Share on other sites
cdaniel.marques

Reparaste, se quando guardas, algum registo da base de dados altera, ou continuam todos iguais?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.