Jump to content
tiko165

Inputs files excede limite

Recommended Posts

tiko165

Quando faço upload de varias imagens num form (5 inputs files), por vezes, aparece-me este erro.

Provavelmente por testar imagens com muita capacidade, pois em imagens de baixa resolução, funciona correctamente.

Alguma forma de o contornar e de o resolver?

Warning: POST Content-Length of 25594458 bytes exceeds the limit of 8388608 bytes in Unknown on line 0


collectioneuro300px.png

Share this post


Link to post
Share on other sites
HappyHippyHippo

tens o limite máximo de posts com 8Mb (configuração do PHP)

terás de aumentar esse limite (editar o php.ini) e reiniciar o servidor web ...


IRC : sim, é algo que ainda existe >> #p@p

Share this post


Link to post
Share on other sites
tiko165

tens o limite máximo de posts com 8Mb (configuração do PHP)

terás de aumentar esse limite (editar o php.ini) e reiniciar o servidor web ...

Neste momento ainda estou a usar um servidor local.

Onde e como posso editar o "php.ini"?

Edited by tiko165

collectioneuro300px.png

Share this post


Link to post
Share on other sites
HappyHippyHippo

editando o php.ini (como disse acima)

aonde está esse ficheiro ? sem saber o que usas (window, linux, xampp, etc ...) é impossivel dizer


IRC : sim, é algo que ainda existe >> #p@p

Share this post


Link to post
Share on other sites
tiko165

editando o php.ini (como disse acima)

aonde está esse ficheiro ? sem saber o que usas (window, linux, xampp, etc ...) é impossivel dizer

Uso windows com EasyPHP


collectioneuro300px.png

Share this post


Link to post
Share on other sites
pikax

faz uma pesquisa no explorador por php.ini


Por muito mais que que estude só aprendo uma coisa, que ainda tenho muita coisa para aprender.

A beleza de um código está em decompor problemas complexos em pequenos blocos simples.

"learn how to do it manually first, then use the wizzy tool to save time."

"Kill the baby, don't be afraid of starting all over again. Fail soon, learn fast."

Share this post


Link to post
Share on other sites
tiko165

Encontrei-o, e alterei os dados de:

post_max_size = 8M

upload_max_filesize = 2M

para

post_max_size = 100M

upload_max_filesize = 100M

E na primeira tentativa de upload ainda envio, na segunda tentativa, deu o mesmo erro dizendo na mesma que o upload tinha excedido, daqueles supostos 8M

Edited by tiko165

collectioneuro300px.png

Share this post


Link to post
Share on other sites
HappyHippyHippo

terás de aumentar esse limite (editar o php.ini) e reiniciar o servidor web ...


IRC : sim, é algo que ainda existe >> #p@p

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.