Jump to content
FQueiros

[Resolvido] Resposta de erro xml

Recommended Posts

FQueiros

Boas,

eu estou a enviar uma mensagem SAML para um portal e este devolve-me outra mensagem em que dá o seguinte erro:

<StatusCode Value="urn:oasis:names:tc:SAML:2.0:status:Requester">
		<StatusCode Value="urn:oasis:names:tc:SAML:2.0:status:RequestDenied" />
	</StatusCode>
	<StatusMessage>urn:oasis:names:tc:SAML:2.0:status:RequestDenied
(urn:oasis:names:tc:SAML:2.0:status:InvalidAttrNameOrValue)</StatusMessage>

A minha mensagem é:

<samlp:LogoutRequest xmlns:saml="urn:oasis:names:tc:SAML:2.0:assertion"
				 xmlns:samlp="urn:oasis:names:tc:SAML:2.0:protocol"
				 Consent="urn:oasis:names:tc:SAML:2.0:logout:user"
				 Destination="site destino"
				 ID="_09aee7ce288a1098759c97f309416fd631b396c5"
				 IssueInstant="2013-04-30T16:23:45"
				 Version="2.0"
				 >
<saml:Issuer xmlns:saml="urn:oasis:names:tc:SAML:2.0:assertion">issuer convinado</saml:Issuer>
<Signature xmlns="http://www.w3.org/2000/09/xmldsig#">
	<SignedInfo>
		<CanonicalizationMethod Algorithm="http://www.w3.org/TR/2001/REC-xml-c14n-20010315" />
		<SignatureMethod Algorithm="http://www.w3.org/2000/09/xmldsig#rsa-sha1" />
		<Reference URI="#_09aee7ce288a1098759c97f309416fd631b396c5">
			<Transforms>
				<Transform Algorithm="http://www.w3.org/2000/09/xmldsig#enveloped-signature" />
				<Transform Algorithm="http://www.w3.org/2001/10/xml-exc-c14n#">
					<InclusiveNamespaces xmlns="http://www.w3.org/2001/10/xml-exc-c14n#"
										 PrefixList="#default samlp saml ds xs xsi"
										 />
				</Transform>
			</Transforms>
			<DigestMethod Algorithm="http://www.w3.org/2000/09/xmldsig#sha1" />
			<DigestValue>I8Q8151FOHeyi1hB+Gfs0YrfCaA=</DigestValue>
		</Reference>
	</SignedInfo>
	<SignatureValue>.......</SignatureValue>
	<KeyInfo>
		<X509Data>
			<X509Certificate>.........</X509Certificate>
		</X509Data>
	</KeyInfo>
</Signature>
<saml:NameID Format="urn:oasis:names:tc:SAML:1.1:nameid-format:unspecified"
			 xmlns:saml="urn:oasis:names:tc:SAML:2.0:assertion"
			 >urn:oasis:names:tc:SAML:1.1:nameid-format:unspecified</saml:NameID>
</samlp:LogoutRequest>

Agradeço alguma resposta sobre o que possa ser o problema com o meu pedido de logout, pois já fiz o pedido de autenticação com portal e já me autentiquei mas a mensagem de logout está a falhar alguma coisa.

Edited by Rui Carlos
Formatação do código.

Share this post


Link to post
Share on other sites
FQueiros

podem fechar este tópico, a mensagem está bem construída o que estava mal era o http que eu estava a enviar a mensagem.

Share this post


Link to post
Share on other sites
foopo

não sei se o teu pedido de autentificação era para o FA (para o cartão de cidadão), mas se foi podes dizer-me como o fizeste?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.