Jump to content
fil79

[Resolvido] dúvida excel

Recommended Posts

fil79

Boas

tenho uma coluna com 12 células, cada uma delas representa 1 mês, sendo o A1 Janeiro e o A12 Dezembro. O que quero é simples, mas não estou a conseguir fazer no excel.

Numa 13ª celula queria que somasse as celulas até ao corrente mês.

como estamos em Abril a função seria SOMA(A1:A4);

tentei =SOMA(A1:A(MÊS(HOJE()))), mas o excel não aceita.

Qual a forma de fazer isto?

Desde já agradeço

Edited by fil79

MCITP-MCTS-MCP

Share this post


Link to post
Share on other sites
acao

boas

Private Sub CommandButton1_Click()
Dim vmes As Byte
Dim vLinha As Byte
vmes = Month(Now)
For vLinha = 1 To vmes
Range("A13").Value = Range("A13").Value + Val(Range("A" & vLinha).Value)
Next
End Sub

cumps

acao

Share this post


Link to post
Share on other sites
jpaulino

Pode usar:

=SUM(INDIRECT("A1:A" & MONTH(NOW())))

Em Português não sei bem, mas deve ser algo como:

=SOMA(INDIRETO("A1:A" & MÊS(HOJE())))

Share this post


Link to post
Share on other sites
fil79

Pode usar:

=SUM(INDIRECT("A1:A" & MONTH(NOW())))

Em Português não sei bem, mas deve ser algo como:

=SOMA(INDIRETO("A1:A" & MÊS(HOJE())))

assim funcionou perfeitamente e sem recurso a script que era o pretendido!! Obrigado


MCITP-MCTS-MCP

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.