Jump to content
fil79

[Resolvido] dúvida excel

Recommended Posts

fil79

Boas

tenho uma coluna com 12 células, cada uma delas representa 1 mês, sendo o A1 Janeiro e o A12 Dezembro. O que quero é simples, mas não estou a conseguir fazer no excel.

Numa 13ª celula queria que somasse as celulas até ao corrente mês.

como estamos em Abril a função seria SOMA(A1:A4);

tentei =SOMA(A1:A(MÊS(HOJE()))), mas o excel não aceita.

Qual a forma de fazer isto?

Desde já agradeço

Edited by fil79

MCITP-MCTS-MCP

Share this post


Link to post
Share on other sites
acao

boas

Private Sub CommandButton1_Click()
Dim vmes As Byte
Dim vLinha As Byte
vmes = Month(Now)
For vLinha = 1 To vmes
Range("A13").Value = Range("A13").Value + Val(Range("A" & vLinha).Value)
Next
End Sub

cumps

acao

Share this post


Link to post
Share on other sites
jpaulino

Pode usar:

=SUM(INDIRECT("A1:A" & MONTH(NOW())))

Em Português não sei bem, mas deve ser algo como:

=SOMA(INDIRETO("A1:A" & MÊS(HOJE())))

Share this post


Link to post
Share on other sites
fil79

Pode usar:

=SUM(INDIRECT("A1:A" & MONTH(NOW())))

Em Português não sei bem, mas deve ser algo como:

=SOMA(INDIRETO("A1:A" & MÊS(HOJE())))

assim funcionou perfeitamente e sem recurso a script que era o pretendido!! Obrigado


MCITP-MCTS-MCP

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.