Ir para o conteúdo
  • Revista PROGRAMAR: Já está disponível a edição #60 da revista programar. Faz já o download aqui!

fil79

[Resolvido] dúvida excel

Mensagens Recomendadas

fil79

Boas

tenho uma coluna com 12 células, cada uma delas representa 1 mês, sendo o A1 Janeiro e o A12 Dezembro. O que quero é simples, mas não estou a conseguir fazer no excel.

Numa 13ª celula queria que somasse as celulas até ao corrente mês.

como estamos em Abril a função seria SOMA(A1:A4);

tentei =SOMA(A1:A(MÊS(HOJE()))), mas o excel não aceita.

Qual a forma de fazer isto?

Desde já agradeço

Editado por fil79

MCITP-MCTS-MCP

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
acao

boas

Private Sub CommandButton1_Click()
Dim vmes As Byte
Dim vLinha As Byte
vmes = Month(Now)
For vLinha = 1 To vmes
Range("A13").Value = Range("A13").Value + Val(Range("A" & vLinha).Value)
Next
End Sub

cumps

acao

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
jpaulino

Pode usar:

=SUM(INDIRECT("A1:A" & MONTH(NOW())))

Em Português não sei bem, mas deve ser algo como:

=SOMA(INDIRETO("A1:A" & MÊS(HOJE())))

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
fil79

Pode usar:

=SUM(INDIRECT("A1:A" & MONTH(NOW())))

Em Português não sei bem, mas deve ser algo como:

=SOMA(INDIRETO("A1:A" & MÊS(HOJE())))

assim funcionou perfeitamente e sem recurso a script que era o pretendido!! Obrigado


MCITP-MCTS-MCP

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!

Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.

Entrar Agora

×

Aviso Sobre Cookies

Ao usar este site você aceita os nossos Termos de Uso e Política de Privacidade. Este site usa cookies para disponibilizar funcionalidades personalizadas. Para mais informações visite esta página.