Ir para o conteúdo
  • Revista PROGRAMAR: Já está disponível a edição #60 da revista programar. Faz já o download aqui!

theediting4fun

Excel: Melhor Aluno Sabendo as Notas

Mensagens Recomendadas

theediting4fun

Eu tenho uma tabela em Excel com vários valores de notas de vários alunos de um teste de Português e temos os nomes dos alunos correspondentes às suas notas nos testes na mesma tabela. Pretendo com alguma formula ou calculo determinar o melhor aluno que tem a melhor nota. A minha tabela é a seguinte: http://gyazo.com/63c3be627d9533975c42633e32af7606

Como posso fazer esta formula?

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
jpaulino

Podes usar a formula LARGE()

=LARGE(array;posição)

Para o primeiro lugar da lista podes usar

=LARGE(tabela;1)

Depois, se for necessário, usas o VLOOKUP() para ir buscar o nome de acordo com o valor obtido pela formula LARGE()

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
theediting4fun

o meu excel esta em portugues ou seja as funcoes e nao estou a perceber como e que eu faco para ele escolhe o aluno que tem a coluna correspondente da nota a melhor nota

ja descobri que a funcao large é maior em portugues .. ja calculei o maior mas agora como faco o resto?

Editado por theediting4fun

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
theediting4fun

Ja tentei usar isto mas acho que estou a confundir tudo

vc pode me ajudar?

=PROCV(MAIOR(I8:I14;1);B8:I14;1;FALSO)

Editado por theediting4fun

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
jpaulino

O "problema" é que tens os valores à direita (notas) e os nomes dos alunos numa coluna à esquerda.

Podes resolver isso com algumas formulas, por exemplo:

=LARGE(B1:B5;1)

Onde B1:B5 é onde estão as notas e depois:

=INDIRECT(ADDRESS(MATCH(C8;B1:B5;0);1))

Onde B1:B5 é onde estão as notas, 1 é o número da coluna onde estão os nome e C8 é o resultado da formula LARGE()

PS: Não sei as formulas em PT mas procura aqui

Ou então usando VBA para criação de uma formula personalizada (UDF):

http://www.excel-user.com/2011/07/negative-vlookupreturn-value-to-left-of.html

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
theediting4fun

nao deu certo

o que significa ou melhor o que faz a funcao indirect e a match?

olhe nao funciona ..

vc tem que me ajudar melhor sff

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
jpaulino

nao deu certo

o que significa ou melhor o que faz a funcao indirect e a match?

olhe nao funciona ..

vc tem que me ajudar melhor sff

Só mostrando um exemplo (ficheiro)

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!

Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.

Entrar Agora

×

Aviso Sobre Cookies

Ao usar este site você aceita os nossos Termos de Uso e Política de Privacidade. Este site usa cookies para disponibilizar funcionalidades personalizadas. Para mais informações visite esta página.