Jump to content
theediting4fun

Excel: Melhor Aluno Sabendo as Notas

Recommended Posts

theediting4fun

Eu tenho uma tabela em Excel com vários valores de notas de vários alunos de um teste de Português e temos os nomes dos alunos correspondentes às suas notas nos testes na mesma tabela. Pretendo com alguma formula ou calculo determinar o melhor aluno que tem a melhor nota. A minha tabela é a seguinte: http://gyazo.com/63c3be627d9533975c42633e32af7606

Como posso fazer esta formula?

Share this post


Link to post
Share on other sites
jpaulino

Podes usar a formula LARGE()

=LARGE(array;posição)

Para o primeiro lugar da lista podes usar

=LARGE(tabela;1)

Depois, se for necessário, usas o VLOOKUP() para ir buscar o nome de acordo com o valor obtido pela formula LARGE()

Share this post


Link to post
Share on other sites
theediting4fun

o meu excel esta em portugues ou seja as funcoes e nao estou a perceber como e que eu faco para ele escolhe o aluno que tem a coluna correspondente da nota a melhor nota

ja descobri que a funcao large é maior em portugues .. ja calculei o maior mas agora como faco o resto?

Edited by theediting4fun

Share this post


Link to post
Share on other sites
theediting4fun

Ja tentei usar isto mas acho que estou a confundir tudo

vc pode me ajudar?

=PROCV(MAIOR(I8:I14;1);B8:I14;1;FALSO)

Edited by theediting4fun

Share this post


Link to post
Share on other sites
jpaulino

O "problema" é que tens os valores à direita (notas) e os nomes dos alunos numa coluna à esquerda.

Podes resolver isso com algumas formulas, por exemplo:

=LARGE(B1:B5;1)

Onde B1:B5 é onde estão as notas e depois:

=INDIRECT(ADDRESS(MATCH(C8;B1:B5;0);1))

Onde B1:B5 é onde estão as notas, 1 é o número da coluna onde estão os nome e C8 é o resultado da formula LARGE()

PS: Não sei as formulas em PT mas procura aqui

Ou então usando VBA para criação de uma formula personalizada (UDF):

http://www.excel-user.com/2011/07/negative-vlookupreturn-value-to-left-of.html

Share this post


Link to post
Share on other sites
theediting4fun

nao deu certo

o que significa ou melhor o que faz a funcao indirect e a match?

olhe nao funciona ..

vc tem que me ajudar melhor sff

Share this post


Link to post
Share on other sites
jpaulino

nao deu certo

o que significa ou melhor o que faz a funcao indirect e a match?

olhe nao funciona ..

vc tem que me ajudar melhor sff

Só mostrando um exemplo (ficheiro)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.