Jump to content

PostgreSQL/Postgis - instalação do DBI-Link


itg00022289

Recommended Posts

Olá

Eu pretendo instalar o DBI-Link no PostgreSQL / PostGIS.

É numa máquina com Windows 64-bit. (não posso mudar isso).

Como eu entendo, preciso para instalar Active Perl primeiro na minha máquina, o que fiz.

No entanto, quando vou criar uma nova extensão (plperlu ou plperl) no PostgreSQL dá-me um erro como

"Não é possível carregar biblioteca: c: \ Program Files \ PostgreSQL \ 9,2 \ lib plperl.dll \".

Eu verifiquei e o ficheiro plperl.dll existe naquela localização exata.

Investiguei e o problema poderia estar relacionado com a versão do Active Perl instalado (que era a mais recente) e recomendaram-me a instalação da versão 5.10, o que eu fiz. No entanto só encontrei a versão para 32 bits, que instalei.

1 - Parece-vos que o erro indicado pode ter a ver com o facto de estar a usar a versão de 32 bits do Active Perl?

2 - Se sim, alguém sabe onde eu posso obter a versão do Active Perl 5.10 64 bits?

Eu não tenho muitos conhecimentos de informática por isso posso estar a fazer algum um erro básico que está impedindo a instalação da DBI-Link no PostgreSQL.

Gostaria muito da vossa ajuda, porque estou preso à vários dias com este problema e não sei como resolvê-lo ...

obrigado,

Pedro

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.