Jump to content

[Resolvido] Problema na inserção de caracteres na BD


NunoDinis

Recommended Posts

Boa tarde,

Estou com um problema na inserção na base de dados de alguns caracteres, como por exemplo o ">". Na BD insere como NULL.

String urlGet3="http://192.168.205.33:82/appLabTec/InserirValores/inserir2.phpvalor=%22+Valor=armazenadorAtividade2[i].trim().toString();+"&codigo="+codigoCaixaTexto+"&cod_relatorio="+etCodigo.getText().toString();

Esta é a forma que utilizo para inserir. Já verifiquei a codificação da rotina de inserção, e até alterei, e sem resultados.

Se por acaso fizer diretamente, insere normalmente:

http://192.168.205.33:82/appLabTec/InserirValores/inserir2.php?valor=>3&codigo=15&cod_relatorio=18913

Obrigado.

Edited by NunoDinis

Estranha forma de vida que tem a capacidade de transformar comandos em mensagens de erro.

ndsotware.org

Link to comment
Share on other sites

A string q tens aí contém erro de sintaxe.

Mostra a que estás a usar (pelo que parece, a que usas não provoca erro de sintaxe).

"[Os jovens da actual geração]não lêem porque não envolve um telecomando que dê para mirar e atirar, não falam porque a trapalhice é rainha e o calão é rei" autor: thoga31

Life is a genetically transmitted disease, induced by sex, with death rate of 100%.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.