Ir para o conteúdo
  • Revista PROGRAMAR: Já está disponível a edição #60 da revista programar. Faz já o download aqui!

bluedark

Ajuda pseudocódigo (português estruturado)

Mensagens Recomendadas

bluedark

Boa tarde,

Precisava de ajuda para resolver os seguintes exercícios em pseudocódigo (português estruturado) utilizando vetores (arrays):

  • Exercício 1: Algoritmo que leia 10 números e informe quais são pares e impares .

  • Exercício 2: Algoritmo que solicite ao usuário 10 números inteiros e, ao final, informe a quantidade de números ímpares e pares lidos. Calcule também a soma dos números pares e ímpares.

  • Exercício 3: Algoritmo que carregue um vector de seis elementos numéricos inteiros, calcule e mostre:
    ¨ A quantidade de números pares e ímpares;
    ¨ Quais os números pares;
    ¨ A quantidade de números ímpares;
    ¨ Quais os números ímpares.

  • Exercício 4: Algoritmo que solicite ao utilizador um número par e um número ímpar até 10. E depois efectue a soma entre eles.

Desde já o meu obrigado,

bluedark

Editado por bluedark

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
pikax

quais sao mesmo as tuas duvidas?? nao consigo ver nenhuma duvida...


Por muito mais que que estude só aprendo uma coisa, que ainda tenho muita coisa para aprender.

A beleza de um código está em decompor problemas complexos em pequenos blocos simples.

"learn how to do it manually first, then use the wizzy tool to save time."

"Kill the baby, don't be afraid of starting all over again. Fail soon, learn fast."

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
bluedark

A minha dúvida é mesmo na resolução dos exercícios. Como se fazem..... Vou ter exame e tenho de saber isso.

Podem ajudar pff...

Obrigado

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
HappyHippyHippo

- tentas perceber o que é para fazer (enunciado)

- tentas descobrir problemas elementares do problema geral (separação dos problemas)

- para cada problema elementar, tentas arranjar uma forma simples de o resolver (resolução do problema)

- descobrir e listar as ferramentas que te podem auxiliar para a resolução de cada problema elementar (declaração)

- juntar tudo (combinação das soluções)

- listar passo-a-passo a resolução dos problemas elementares (construção do algoritmo)

resultado : algoritmo


IRC : sim, é algo que ainda existe >> #p@p

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
bluedark

Mas o problema é que eu não sei como fazer isso.... :(

Por favor malta ajudem-me apresentando uma solução possível para cada exercício.

Cumps,

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
HappyHippyHippo

Por favor malta ajudem-me apresentando uma solução possível para cada exercício.

eu não apresentarei solução para nenhum dos problemas, e dou-te as minhas razões

1º - acho nada ético estar a resolver um problema de outra pessoa

2º - sei que é o melhor para ti estudares e perceberes

3º - já te dei a orientação possível a quem não apresenta uma dúvida específica

4º - é contra as regras do fórum resolver problemas :

http://www.portugal-a-programar.pt/guidelines/

Não é permitida a criação de tópicos ou colocação de mensagens a pedir que se façam trabalhos. Pedir ajuda é diferente de pedir trabalhos feitos. Em caso de incumprimento o staff pode bloquear, ou mesmo apagar, o tópico/mensagem.


IRC : sim, é algo que ainda existe >> #p@p

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
bluedark

Bom dia,

Tenho aqui um exercício que tentei resolver mas não sei se está bem podem ajudar-me sff:

Exercício:

Armazenar 15 números inteiros num vetor NUM e imprimir uma listagem contendo o número e uma das mensagens: par ou ímpar.

Resolução:

var

NUM: vetor [1..15] de inteiro

i: inteiro

Inicio

Se i <- 1 ate 15 faca

escreval ("Digite um numero para ser armazenado no Vetor")

leia (NUM)

fimpara

para i <- 1 ate 15 faca

escreva (NUM)

fimpara

Isto está bem pessoal? Agora como eu coloco para dizer se é par ou ímpar?

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
HappyHippyHippo

tens de começar a aprender a indentar o que escreves ...

var
NUM: vetor [1..15] de inteiro
i: inteiro

inicio
 // chama os teus ciclos como devem ser : a palavra "se" não indica um ciclo
 para i de 1 ate 15 fazer
   escrever("Digite um numero para ser armazenado no Vetor")
   ler(NUM[i])
 fimpara

 para i de 1 ate 15 fazer
   // tu nao queres escrever, mas sim verificar se é par ou impar ... como achas que se verifica isso ?
   escrever(NUM[i])
 fimpara
fim


IRC : sim, é algo que ainda existe >> #p@p

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
bluedark

tens de começar a aprender a indentar o que escreves ...

var
NUM: vetor [1..15] de inteiro
i: inteiro

inicio
// chama os teus ciclos como devem ser : a palavra "se" não indica um ciclo
para i de 1 ate 15 fazer
escrever("Digite um numero para ser armazenado no Vetor")
ler(NUM[i])
fimpara

para i de 1 ate 15 fazer
// tu nao queres escrever, mas sim verificar se é par ou impar ... como achas que se verifica isso ?
escrever(NUM[i])
fimpara
fim

Será assim:

se numero MOD 2 = 0

entao inicio

par=par+1

Fim

senao inicio

impar=impar+1

Fim

mostrar "Numero de impares: ", impar

mostrar "Numero de pares: ", par

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
bluedark

Pois talvez não.....

Vamos esquecer este exercício.

Tenho outro:

Faça um algoritmo para ler 20 números, gardá-los num vetor, e somar os pares.

Resolução:

Var

CONT: inteiro;

NUM: vetor [1..20] de inteiro

SOMA: inteiro;

Inicio

CONT<- 1;

SOMA<- 0;

enquanto (CONT<= 20) faca

escreva ("Digite o número desejado:");

leia (NUM); // é aqui que devo colocar a função do vetor?

se (MUM mod 2= 0) então

SOMA <- SOMA+NUM;

fimse

CON<- CON+1;

fimenquanto;

escreva ("Soma dos números pares digitados:", SOMA);

fim.

Está bem? Agora como é que eu guardo no vetor? a declaração do vetor está bem?

Outra dúvida qual é a condição para números ímpares?

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
HappyHippyHippo

Está bem?

não

- não guardas num vector

- não és coerente com os nomes das variáveis

- seria ideia do execício leres para um vector e depois processares o vector, e não estás a fazer isso

Agora como é que eu guardo no vetor?

var

NUM: vetor [1..15] de inteiro

...

leia (NUM)

...

a declaração do vetor está bem?

é pseudo-código, desde que seja se consiga perceber que é um vector, então está bem :D

Outra dúvida qual é a condição para números ímpares?

se pares tens : <condição> == 0, então para ímpares é <condição> != 0 (diferente)


IRC : sim, é algo que ainda existe >> #p@p

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!

Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.

Entrar Agora

×

Aviso Sobre Cookies

Ao usar este site você aceita os nossos Termos de Uso e Política de Privacidade. Este site usa cookies para disponibilizar funcionalidades personalizadas. Para mais informações visite esta página.