Jump to content
ricduarte

[Resolvido] problemas com dados

Recommended Posts

ricduarte

Boas!

Eu tou a fazer uma PAP e tou com um problema com a base de dados.

eu tenho duas tabelas, entre outras com os seguintes dados:

tabela clientes:

IDclientes

nome

morada

código postal

localidade

telefone

telemovel

nº contribuinte

tabela orçamentos

IDorçamento

IDclientes

dataemissão

valortotal

eu preenchi a tabela clientes com 4 registos e a tabela orçamentos tambem tem o msm numero de registo. na tabela clientes, cliquei no sinal mais que está antes do primeiro registo e pediu para colocar um numero cliente e depois apareceu os dados mas com a coluna IDcliente sem dados.

ja ando à algum tempo a mexer nisto e nao consegui encontrar solução. que problema será este?

Share this post


Link to post
Share on other sites
acao

boas

se for ao abrir a tabela clientes nada disso deveria acontecer, mas se for ao abrir a tabela orçamentos pode informar que o campo idclientes não está preenchido, e isso deve acontecer porque se está relacionado com outra tabela deve de ser de preenchimento obrigatório.

o que não percebi foi o aparecimento de outra coluna IdCliente.

coloca aqui um ficheiro simples e sem dados pessoais ou confidenciais que tenha esse problema para verificar.

cumps

acao

Share this post


Link to post
Share on other sites
ricduarte

tenho um cliente com o ID 0001 e tenho dados de um orçamento, por exemplo no valor de 50€ e guardo as tabelas. depois quando vou a tabela clientes clico no sinal mais e pede-me para inserir um nº cliente e coloco 1 e aparece-me o orçamento nº 1 com todos os campos preenchidos menos a coluna onde deveria estar o nº de cliente

Share this post


Link to post
Share on other sites
progster

tenho um cliente com o ID 0001 e tenho dados de um orçamento, por exemplo no valor de 50€ e guardo as tabelas. depois quando vou a tabela clientes clico no sinal mais e pede-me para inserir um nº cliente e coloco 1 e aparece-me o orçamento nº 1 com todos os campos preenchidos menos a coluna onde deveria estar o nº de cliente

Assumindo que percebi a tua dúvida, na consulta colocas-te lá a coluna "nº de cliente"?


Não resolvo dúvidas por PM.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.