Jump to content

Utilizar Webservices da AT


Recommended Posts

Em 13/05/2024 às 17:34, josalm disse:

Boa tarde,

No envio da declaração de iva vem sempre este resultado -13 Versão da declaração inválida. Versões permitidas: 2016(XML).

Estou a enviar na tag versaoDeclaracao 2016.

Alguém sabe o que pode ser?

 

 

Em 14/05/2024 às 09:19, lmfsilva disse:

Se o ficheiro apesar de estruturalmente estiver correto mas o seu conteúdo estiver errado recebes sempre esse erro. Esse problema acontece principalmente na existência de pedidos de reembolso do IVA. Se for o caso remove do ficheiro as tags <clientes id="..."> e <fornecedores id="..."> e experimenta a validação.

 

 

O mais fácil é pegar num ficheiro que já tenha sido validado no Portal para ter a certeza que não é problema do ficheiro.
Começa pela opção "validar" em vez de "submeter" porque se conseguires validar, tambem vais conseguir submeter.
Verifica se estás a usar a versão correta em vigor dentro do ficheiro:

<?xml version="1.0" encoding="utf-8" standalone="yes"?>
<dpiva xmlns="http://www.at.gov.pt/schemas/dpiva" version="06">

 

Link to comment
Share on other sites

Em 16/05/2024 às 12:39, americob disse:

Site do Observatório Astronómico de Lisboa está em baixo!?!?!

 

Em 16/05/2024 às 17:15, pjmvc disse:

Confirmo.

Já voltou, por mais uns tempos ... mas, um dia destes vai de vez.

Felizmente, os servidores NTP: ntp02.oal.ul.pt e ntp04.oal.ul.pt, não foram desligados nem desacertados, desta vez.

A AT continua a incentivar nos Manuais de Implementação o seu uso, se calhar nem sabe da situação precária existente.

Se querem acabar com ele, que indiquem o novo a tempo de evitarmos constrangimentos.

Link to comment
Share on other sites

On 5/20/2024 at 5:01 PM, americob said:

Já voltou, por mais uns tempos ... mas, um dia destes vai de vez.

Felizmente, os servidores NTP: ntp02.oal.ul.pt e ntp04.oal.ul.pt, não foram desligados nem desacertados, desta vez.

A AT continua a incentivar nos Manuais de Implementação o seu uso, se calhar nem sabe da situação precária existente.

Se querem acabar com ele, que indiquem o novo a tempo de evitarmos constrangimentos.

Não é bem da competência da AT...

Existem outros servidores bem melhores (já implementei diversos "fail-safe" mas ainda não fiz o "deploy")

  • Vote 1

The simplest explanation is usually the correct one

JAVA Utilities: https://github.com/marcolopes/dma

Link to comment
Share on other sites

Em 17/05/2024 às 22:36, kalin disse:

Alguém está a conseguir usar a app e-fatura no android 14?

Já em 2 telemóveis que instalei e aparece um aviso "Utilização não permitida" "Por questões de segurança, esta aplicação não pode ser executada neste dispositivo" e fecha sem deixar fazer nada.

Viva, no meu corre sem problemas (Galaxy A52, Android 14, OneUI 6.0).

Link to comment
Share on other sites

Em 17/05/2024 às 22:36, kalin disse:

Alguém está a conseguir usar a app e-fatura no android 14?

Já em 2 telemóveis que instalei e aparece um aviso "Utilização não permitida" "Por questões de segurança, esta aplicação não pode ser executada neste dispositivo" e fecha sem deixar fazer nada.

A este propósito, recebi a seguinte explicação da AT:

Citação

As aplicações para smartphones desenvolvidas pela Autoridade Tributária e Aduaneira têm um mecanismo de proteção que valida a não existência de alterações ao sistema operativo dos equipamentos, com o objetivo de o proteger de eventuais vulnerabilidades dos referidos equipamentos, com foco na segurança da informação e na confidencialidade dos dados. Para poder utilizar as aplicações da AT deverá assegurar que o sistema operativo que está a utilizar não apresenta quaisquer alterações face à versão original.
 

Já os questionei sobre o facto do Android ter atualizações de quando em quando ( ficando diferente da versão original ), mas ainda não obtive resposta.

  • Vote 1
Link to comment
Share on other sites

On 5/27/2024 at 5:11 PM, CCoutinho said:

A este propósito, recebi a seguinte explicação da AT:

Já os questionei sobre o facto do Android ter atualizações de quando em quando ( ficando diferente da versão original ), mas ainda não obtive resposta.

Que grande treta!

Não é da responsabilidade da AT fazer validações ao Sistema Operativo! Essa agora...

Então se eu tiver feito "root" ao meu android a aplicação da AT embirra?

Era o que faltava... Nem acredito que isso seja verdade.

The simplest explanation is usually the correct one

JAVA Utilities: https://github.com/marcolopes/dma

Link to comment
Share on other sites

Em 27/05/2024 às 17:11, CCoutinho disse:

A este propósito, recebi a seguinte explicação da AT:

Já os questionei sobre o facto do Android ter atualizações de quando em quando ( ficando diferente da versão original ), mas ainda não obtive resposta.

Que eles estão a fazer validações estão, mas não me parece que as estejam a fazer bem.

Num dos equipamentos que testei era novo, acabado de sair da caixa, testei a app e não funcionava.

No outro é um equipamento mais antigo e tinha root e uma custom rom para estar atualizado, o que achei estranho foi que a app funcionou com versões mais antigas da rom, só quando atualizei para a 14 que começou a dar problemas.

Se alguém quiser fazer alguma, vai tentar com o apk e ver o que lá está.

Link to comment
Share on other sites

Em 02/06/2024 às 12:26, ccue2003 disse:

Boa tarde,

Alguém tem a estrutura em xml que permita comunicar via webservice a não existência de faturação num mês?

Ou alguma instrução em PHP que o consiga fazer?

Obrigado desde já

De momento não existe qualquer serviço que permita fazer essa comunicação, tem de ser feita manualmente no portal (ou através de um Bot ...).

Essa comunicação é das coisas mais estúpidas dos últimos tempos: ou comunicou o SAFT e tem faturas (ou outros documentos), ou não comunicou e não tem.
Já li algures que, se se comunicar a não existência de faturação e depois entregar um SAFT, prevalece o SAFT entregue e é desconsiderada comunicação de não existência.
Dá vontade de comunicar a não existência de faturação para todas as empresas (com um Bot) e depois entregar SAFT das que realmente tiveram.
Gabinetes de Contabilidade que fazem a faturação de dezenas de pequenos empresários, que fazem uma ou duas faturas por mês nos meses em que fazem: agricultores, trolhas, picheleiros, eletricistas, etc., ficaram com mais uma obrigação em mãos.
Até os microprodutores de eletricidade passaram a ter que ter o cuidado de, quando a empresa de eletricidade não lhes passar a autofatura, ir ao site colocar o visto.

Cheira a pura caça à multa, sem quaisquer efeitos práticos.

 

Link to comment
Share on other sites

boa tarde,

hoje fiz o pedido do certificado, como costume pedir todos os anos,

responderam-me o seguinte:

From: ASI - Certificados Digitais <asi-cd@at.gov.pt>
Sent: Tuesday, June 4, 2024 12:26:34 PM
To: ????????<??????@???.pt>
Subject: Re: Pedido de emissão de certificado digital de produtor de software - NIF 5?????????

Ficheiro Bloqueado.
Foi aplicada uma regra de filtragem de conteúdos de acordo com a politica em vigor.
Deleted files: 5??????????.zip
MIMETypes: application/zip,application/x-x509-ca-cert

Exmos. Senhores,

De acordo com o pedido infra, e após validação do CSR enviado, foi emitido o respetivo Certificado Digital.

Informamos que o Certificado Digital "ChaveCifraPublicaAT2025.cer" deverá ser utilizado na cifra da password de acesso.

O pedido de emissão de novo Certificado Digital deve ser efetuado no mínimo, UM MÊS (trinta dias) antes do fim de validade do atual Certificado Digital.

-----BEGIN CERTIFICATE-----

Gostaria de receber o vosso apoiode e saber se esta situação já aconteceu a alguém ?

cps,

F.Dias

 

Link to comment
Share on other sites

Em 04/06/2024 às 14:42, fcdias disse:

boa tarde,

hoje fiz o pedido do certificado, como costume pedir todos os anos,

responderam-me o seguinte:

From: ASI - Certificados Digitais <asi-cd@at.gov.pt>
Sent: Tuesday, June 4, 2024 12:26:34 PM
To: ????????<??????@???.pt>
Subject: Re: Pedido de emissão de certificado digital de produtor de software - NIF 5?????????

Ficheiro Bloqueado.
Foi aplicada uma regra de filtragem de conteúdos de acordo com a politica em vigor.
Deleted files: 5??????????.zip
MIMETypes: application/zip,application/x-x509-ca-cert

Exmos. Senhores,

De acordo com o pedido infra, e após validação do CSR enviado, foi emitido o respetivo Certificado Digital.

Informamos que o Certificado Digital "ChaveCifraPublicaAT2025.cer" deverá ser utilizado na cifra da password de acesso.

O pedido de emissão de novo Certificado Digital deve ser efetuado no mínimo, UM MÊS (trinta dias) antes do fim de validade do atual Certificado Digital.

-----BEGIN CERTIFICATE-----

Gostaria de receber o vosso apoiode e saber se esta situação já aconteceu a alguém ?

cps,

F.Dias

 

 

Boa tarde,

comigo aconteceu exatamente a mesma coisa e resolvi da seguinte forma:

com um editor de texto criei o ficheiro 5????????.cer

No email enviado pela ASI - Certificados Digitais  copiei o texto que está entre -----BEGIN CERTIFICATE-----   e  -----END CERTIFICATE-----

Copiei para o ficheiro 5????????.cer e já está.

Espero ter ajudado.

 

Saudações

Célina Marques

  • Vote 1
Link to comment
Share on other sites

Em 04/06/2024 às 16:02, Célina Marques disse:

 

Boa tarde,

comigo aconteceu exatamente a mesma coisa e resolvi da seguinte forma:

com um editor de texto criei o ficheiro 5????????.cer

No email enviado pela ASI - Certificados Digitais  copiei o texto que está entre -----BEGIN CERTIFICATE-----   e  -----END CERTIFICATE-----

Copiei para o ficheiro 5????????.cer e já está.

Espero ter ajudado.

 

Saudações

Célina Marques

Boa tarde Célia,

obrigado pelo seu feedback .

diga-me uma só mais uma coisa, isto tem haver de eu estar com uma uma versão OpenSSL 1.0.2, certo ?

se eu atualizar para a nova versão, posso pedir um novo certificado ? 

Saudações

Fernando Dias

Link to comment
Share on other sites

Em 04/06/2024 às 17:04, fcdias disse:

Boa tarde Célia,

obrigado pelo seu feedback .

diga-me uma só mais uma coisa, isto tem haver de eu estar com uma uma versão OpenSSL 1.0.2, certo ?

se eu atualizar para a nova versão, posso pedir um novo certificado ? 

Saudações

Fernando Dias

Bom dia Fernando,

O email que lhe foi enviado, já tem o novo certificado, por isso não precisa de pedir um novo.

O problema é que a firewall lhe bloqueou o ficheiro zip com o certificado e nada tem a ver com o OpenSSL, e isso aconteceu também comigo, mas o conteúdo do cerificado vem no texto do email a seguir a -----BEGIN CERTIFICATE----- e por isso só tem que copiar esse texto e colar para o ficheiro 5????????.cer.

Não sei se me estou a saber explicar, mas se não entender envie-me o seu email que depois falamos melhor.

 

Saudações

Célina Marques

Link to comment
Share on other sites

Em 05/06/2024 às 09:37, Célina Marques disse:

Bom dia Fernando,

O email que lhe foi enviado, já tem o novo certificado, por isso não precisa de pedir um novo.

O problema é que a firewall lhe bloqueou o ficheiro zip com o certificado e nada tem a ver com o OpenSSL, e isso aconteceu também comigo, mas o conteúdo do cerificado vem no texto do email a seguir a -----BEGIN CERTIFICATE----- e por isso só tem que copiar esse texto e colar para o ficheiro 5????????.cer.

Não sei se me estou a saber explicar, mas se não entender envie-me o seu email que depois falamos melhor.

 

Saudações

Célina Marques

Boa tarde Célina,

sim a sua explicação foi perfeita já tinha reparado que era bloqueio do firewall, mais uma vez muito obrigado.

 

saudações,

Fernando Dias

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.