Jump to content
cjulio

Utilizar Webservices da AT

Recommended Posts

albertosilva

Bons dias,

Não querendo questionar a boa vontade de quem tem disponibilizado os certificados para instalação, regra geral tenham muito cuidado em instalar nas V/ máquinas e nas dos V/ clientes certificados descarregados de origens não controladas, principalmente quando estão a ser adicionadas novas CA como fidedignas.

Os certificados "DIGITA Issuing CA2" e "DIGITA Root CA" são extraídos do ficheiro "PublicChainCA2.p7b" que vem dentro do ficheiro zip (protegido) que tem como nome o NIF da empresa (ex: 506123456.zip) enviado por email pela ASI quando fazem o pedido do certificado inicial ou de renovação para a V/ empresa.

 

Share this post


Link to post
Share on other sites
pacpintob
22 minutos atrás, George De Luca disse:

Se está a se referir a chave pública (chavepublicaat.cer), meti no mesmo link.

https://www.evernote.com/l/APA7nr2u729EWJmsnGqvQAjZtbq-6zlbBks/

 

George

Obrigado!

Entretanto atualizei tudo e nada... vários testes e nada...

Agora... do nada... está a funcionar sem problemas, e o mais giro... mesmo em clientes aonde não fiz rigorosamente nada!!!

Isto é realmente brincar com o pessoal... os srs da AT deviam disponibilizar no site informação sobre o estado destes serviços. No mínimo.

Share this post


Link to post
Share on other sites
chesser

Os meus clientes já estão a comunicar. Não fizemos nenhuma alteração.

Não obstante, segue mensagem para o e-balcao e para o email da ASI que isso de andarem a deitar culpas para cima das software houses não tem sentido nenhum. Que assumam a responsabilidade pelo que fazem!

Share this post


Link to post
Share on other sites
MAbrantes

Bom dia,

Já está a funcionar, sem ter alterado rigorosamente nada.

Share this post


Link to post
Share on other sites
PinheiroC

As guias voltaram a funcionar! Não fizemos alterações nenhumas.😵

Share this post


Link to post
Share on other sites
Sergio.
1 minuto atrás, albertosilva disse:

Bons dias,

Não querendo questionar a boa vontade de quem tem disponibilizado os certificados para instalação, regra geral tenham muito cuidado em instalar nas V/ máquinas e nas dos V/ clientes certificados descarregados de origens não controladas, principalmente quando estão a ser adicionadas novas CA como fidedignas.

Os certificados "DIGITA Issuing CA2" e "DIGITA Root CA" são extraídos do ficheiro "PublicChainCA2.p7b" que vem dentro do ficheiro zip (protegido) que tem como nome o NIF da empresa (ex: 506123456.zip) enviado por email pela ASI quando fazem o pedido do certificado inicial ou de renovação para a V/ empresa.

 

albertosilva não é totalmente correta a sua afirmação.

Esse contribuinte não sei de quem é.

No entanto é verdade que o ficheiro vem em zip protegido pelo numero de contribuinte do produtor de software, mas isto é igual para todos.

No entanto o certificado PublicChainCA2.p7b é igual para todos, por alguma razão vem com o nome Public.....

Share this post


Link to post
Share on other sites
Nuno Silva

Parece que a AT finalmente acordou, bem ppl Toca a carregar baterias até á próxima asneira.

Hasta

Share this post


Link to post
Share on other sites
rolando_rocha
1 minuto atrás, jncevcosta disse:

Mas esse DGITA também é preciso para os ws de teste?

Pelos vistos sim. Eles deram alguns dias antes para testarmos. Por isso acho que sim. Eu não cheguei a usar o WS de testes porque como toda a gente ficou surpreendido com a situação quando passamos a não obter código AT para os documentos. Passei a resolver a situação diretamente no ambiente de produção.

Share this post


Link to post
Share on other sites
Miguel Andrade

Bom dia,

em .net consegui comunicar acrescentando o seguinte código ao request existente:

string pCertifPathAT = HttpContext.Current.Server.MapPath("~/portaldasfinancasgovpt.crt");
X509Certificate certAT = X509Certificate.CreateFromCertFile(pCertifPathAT);
request.ClientCertificates.Add(certAT);

cumprimentos

Share this post


Link to post
Share on other sites
Manuel Quelhas

O teste de ligação ao WebService está a dar erro também (https://faturas.portaldasfinancas.gov.pt/testarLigacaoWebService.action)

 

">>>STACKTRACE<<<
com.sun.xml.ws.client.ClientTransportException: HTTP transport error: javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target..."

Share this post


Link to post
Share on other sites
Hugo Simões

Boas,

Não é preciso fazer alterações ao que estava antes para funcionar, já está a funcionar corretamente. A AT fez alterações do lado deles.

Share this post


Link to post
Share on other sites
desconfiado

Só posso dizer uma coisa, FDP! 

Peço desculpa pelo desabafo mas é vergonhoso isto. Afinal o problema era mesmo deles.

Share this post


Link to post
Share on other sites
CCoutinho

A comunicação já está a funcionar sem erros, sem ter feito qualquer alteração da minha parte.

Quanto à AT, nem me apetece comentar...

Share this post


Link to post
Share on other sites
nunopicado

Não quero estar a sugerir que eu sou responsável por isto tudo ter começado a funcionar normalmente, mas a verdade é que hoje que me chamou a atenção que havia problemas e meia hora depois estava tudo a funcionar. 🙄

Posso ceder o meu IBAN por PM para quem quiser mostrar o seu reconhecimento...

:cheesygrin::cheesygrin::cheesygrin:

  • Vote 1

"A humanidade está a perder os seus génios... Aristóteles morreu, Newton já lá está, Einstein finou-se, e eu hoje não me estou a sentir bem!"

> Não esclareço dúvidas por PM: Indica a tua dúvida no quadro correcto do forum.

Share this post


Link to post
Share on other sites
pedrocerqueira22

Pa isto é uma vergonha. Do nada começou a funcionar.

Nao fiz rigorosamente nada, apenas alterei o certificado que expirou no dia 20.

Share this post


Link to post
Share on other sites
ccorreia
Agora, pedrocerqueira22 disse:

Pa isto é uma vergonha. Do nada começou a funcionar.

Nao fiz rigorosamente nada, apenas alterei o certificado que expirou no dia 20. 

Qual certificado?

 

Obrigada

Share this post


Link to post
Share on other sites
pacpintob
Agora, pedrocerqueira22 disse:

Pa isto é uma vergonha. Do nada começou a funcionar.

Nao fiz rigorosamente nada, apenas alterei o certificado que expirou no dia 20.

Nem sequer isso é necessário. Todos os meus clientes estão a comunicar com ZERO alterações.

É uma vergonha isto.

Share this post


Link to post
Share on other sites
samuquinha
2 minutos atrás, nunopicado disse:

Não quero estar a sugerir que eu sou responsável por isto tudo ter começado a funcionar normalmente, mas a verdade é que hoje que me chamou a atenção que havia problemas e meia hora depois estava tudo a funcionar. 🙄

Posso ceder o meu IBAN por PM para quem quiser mostrar o seu reconhecimento...

:cheesygrin::cheesygrin::cheesygrin:

Valha-nos o bom humor...

Share this post


Link to post
Share on other sites
pedrocerqueira22
7 horas atrás, ccorreia disse:

Qual certificado?

 

Obrigada

O que ia expirar era este:

 

Alias name: portaldasfinancas_at

Creation date: Aug 9, 2018

Entry type: trustedCertEntry

 

Owner: CN=*.portaldasfinancas.gov.pt, OU=Enterprise SSL Pro Wildcard, OU=Autoridade Tributária e Aduaneira, O=Centro de Gestão da Rede Informática do Governo - CEGER, STREET=Rua Almeida Brandão n7, L=Lisboa, ST=Lisboa, OID.2.5.4.17=1200-602, C=PT

Issuer: CN=COMODO RSA Organization Validation Secure Server CA, O=COMODO CA Limited, L=Salford, ST=Greater Manchester, C=GB

Serial number: ca93feede24a70e7469b2e7bfc49e726

Valid from: Thu Jul 19 01:00:00 WEST 2018 until: Sat Jul 20 00:59:59 WEST 2019

Certificate fingerprints:

         MD5:  F4:73:43:E9:51:C6:A8:A6:D9:1D:DA:C7:BB:50:D8:3C

         SHA1: 62:E4:0B:28:06:6E:05:A7:FF:59:F7:3A:FC:1C:F8:0D:92:38:85:52

         SHA256: 47:42:5D:57:23:3A:47:B9:84:93:85:90:7C:5F:45:56:FF:BC:33:8D:EA:BE:22:A3:95:A8:57:89:73:50:C8:C2

Signature algorithm name: SHA256withRSA

Subject Public Key Algorithm: 2048-bit RSA key

Version: 3

 

Apenas era necessario alterar este pelo novo que foi disponiblizado pela AT.

Agora ficou o fim de semana todo parado e eu achava que o problema era nosso, mas derrepente passou tudo a funcionar e nao fiz rigorosamente nada.

Apenas deixar a nota que nao mudei mais nada nao adicionei qualquer certificado da DGITA

  • Vote 1

Share this post


Link to post
Share on other sites
Nuno Bagulho Marques

Funciona

Alívio.

Queria agradecer a todos o esforço que fizeram, neste fim de semana de angústia. Angústia porque, como sabem, a culpa é sempre dos programadores.

A minha intuição era nada fazer e estava certo.

é lamentável, mais uma vez o Estado se isentar das suas responsabilidades. Isentar-se da responsabilidade de ter causado um transtorno a dezenas de pessoas que (essas pelo menos) aqui passaram, preocupados fundamentadamente.

um bem haja a todos

Share this post


Link to post
Share on other sites
Bruno_2sp

A AT fez aquilo que qualquer bom informático faz, reiniciou o servidor :P

Share this post


Link to post
Share on other sites
Manuel Quelhas

Confirmo, começou a funcionar exactamente como estava antes de se mexer nos certificados. O problema era deles e andamos nós aqui a perder tempo com certificados para trás e para a frente. Só ainda não percebi estas comunicações deles a enviar novos certificados, se tudo continua a funcionar normalmente com os anteriores (pelo menos no envio dos documentos de transporte). Não percebo.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.