Jump to content
  • Revista PROGRAMAR: Já está disponível a edição #60 da revista programar. Faz já o download aqui!

cjulio

Utilizar Webservices da AT

Recommended Posts

Guest
39 minutos atrás, Hugo Simões disse:

Não consigo chegar ao valor.

Este cliente especificamente só tem Faturas Recibo, Notas de Crédito e não tem documentos anulados. O total de valor em notas de crédito é de mais ou menos 2 mil euros.

Na AT está mais de 30 mil euros que no meu sistema. A menos seria mais fácil porque podia chegar á conclusão que não foram comunicados alguns documentos. Olho para o contador de documentos presentes na AT e diz-me que tenho os mesmos que o meu sistema, tiro uma amostra (manual) de documentos e estão ok.

Experimentei validar noutra empresa que tem menos volume de documentos, mas com mais tipos de de documento e anula documentos. Também não bate acerto, o número de documentos comunicado sim, mas o valor não bate.

Alguém consegue fazer esse teste? (Era tão mais facil se desse para tirar uma listagem logo da AT...enfim...)

Obrigado

 

Boas,

Mas é difícil, isolar um dia ou uma semana e comparar documento a documento? (com excel, claro)

Não arranjas uma aplicação que te saque todos os documentos, com anulados a zero e notas de crédito a negativo?

Fica a dica.

 

Share this post


Link to post
Share on other sites
dikx
Em 09/08/2018 às 14:55, RikFonseca disse:

Boa tarde,

Como já foi referido acima, a AT alterou o certificado do lado do servidor, que foi emitido pela COMODO. O certificado raiz da Comodo  não está instalado por defeito nos PCs, mas pode ser instalado manualmente (mas obrigaria a instalar em todos os postos onde tenhas a aplicação instalada...).

Há outra hipótese, sugerida acima pelo hobbit, que é a de  ignorar a validação do certificado remoto ao abrir a ligação ao servidor da AT.

Não consegui implementar daquela forma, mas encontrei na net outro método, que consiste em utilizar o TLS12 e implementar um callback para validar o certificado. Como me encontro de férias, a rotina de validação passou a retornar sempre True... Quando retornar, implemento validação pelo certificado raiz para não deixar isto tão vulnerável...

 

O que alterei foi (VB.net):


'------ Na rotina de comunicação:
ServicePointManager.SecurityProtocol = SecurityProtocolType.TLS12 'A constante só existe na framework 4.5, mas o valor = 3072
ServicePointManager.ServerCertificateValidationCallback = New RemoteCertificateValidationCallback(AddressOf ValidateCertificate)
'--------------------------------

'Callback de validação (para já aceita tudo, mais tarde implemento a validação):
Private Shared Function ValidateCertificate(ByVal sender As Object, ByVal certificate As X509Certificate, ByVal chain As X509Chain, ByVal sslPolicyErrors As SslPolicyErrors) As Boolean
  Dim validationResult As Boolean
  validationResult = True
  '
  ' policy code here ...
  '
  Return validationResult
End Function


Entretanto, hoje já responderam do suporte, onde enviaram o certificado, sem responder às restantes questões, nomeadamente a comprovativo de comunicação destas alterações, do facto de estarem a fazer isto num mês tradicionalmente de férias, da falta de apoio/conhecimentos da parte das linhas de apoio, etc...

Bom dia @RikFonseca, para onde enviaste as questões que tinhas? Algum email ou via e-balcão? 

Aproveito para questionar, alguém já usou a nova funcionalidade da Pesquisa de Pedidos de Autorização Prévia?

Obrigado

Share this post


Link to post
Share on other sites
Hugo Simões
36 minutos atrás, derrerter disse:

Boas,

Mas é difícil, isolar um dia ou uma semana e comparar documento a documento? (com excel, claro)

Não arranjas uma aplicação que te saque todos os documentos, com anulados a zero e notas de crédito a negativo?

Fica a dica.

 

Obrigado,

Mas não está fácil de encontrar alguma coisa/ferramenta que possa extrair documentos da AT para encontrar a falha ou podermos dizer que é um bug visual da AT. Alguém que esteja a ver este post já ajuda se me conseguir fazer um teste em que verifique se o total que tira do seu sistema é o mesmo que está na AT num determinado mês. 

Se for igual, percebo que há um problema do meu lado, agora se estiver também diferente posso associar que não sou o unico nesta situação e a AT tem mesmo um problema.

Obrigado.

Share this post


Link to post
Share on other sites
RikFonseca
6 minutos atrás, dikx disse:

Bom dia @RikFonseca, para onde enviaste as questões que tinhas? Algum email ou via e-balcão? 

Aproveito para questionar, alguém já usou a nova funcionalidade da Pesquisa de Pedidos de Autorização Prévia?

Obrigado

Bom dia @dikx,

Quem passou o dia a tentar obter respostas foi o meu chefe... Eu estava de férias e concentrei-me em tentar arranjar solução no código enquanto ele tentava obter mais respostas...

Penso que ligou várias vezes para o CAT e deixou pedido no e-balcão, mas entretanto enviou um email para o departamento «SDG - Sistemas de Informação» (sdg-si@at.gov.pt) com diversas questões, nomeadamente a pedir prova de que tinham enviado o certificado, onde obter o certificado, a que departamento se pode recorrer no futuro se acontecer algo semelhante, além de referir que é inadmissível não haver suporte consistente/coerente da parte deles...

O email foi reencaminhado para o departamento «ASI - Certificados Digitais» (asi-cd@at.gov.pt) e limitaram-se e enviar o certificado, sem responder a nenhuma das questões.

Uns dias mais tarde chegou novo email com o certificado (presumo que tenha sido enviado para todos), indicando que o anterior ficou retido, bla, bla, bla...

Ou seja, continuamos sem saber a quem nos podemos dirigir em casos semelhantes, apesar de sermos obrigados a comunicar com a plataforma deles...

Share this post


Link to post
Share on other sites
dikx
Em 14/06/2018 às 16:34, Antonio Valladares disse:

Olá especialistas,

@StadaExp: Muito obrigado pela ajuda.

No final, o problema de env: Client - Internal Error foi colocar um / no final do URL.
Eu tinha posição: https://servicos.portaldasfinancas.gov.pt:700/fews/faturas/

O bom é: https://servicos.portaldasfinancas.gov.pt:700/fews/faturas

Agora, depois de resolver mais algum erro, você está me dando o seguinte problema.


<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
   <SOAP-ENV:Header/>
   <SOAP-ENV:Body>
      <SOAP-ENV:Fault>
         <faultcode>33</faultcode>
         <faultstring>mismatched tag, expected hr at offset 241 of</faultstring>
         <detail>fews.gdcontfsimpostosqua</detail>
      </SOAP-ENV:Fault>
   </SOAP-ENV:Body>
</SOAP-ENV:Envelope>

A mensagem que estou enviando é a seguinte:


<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<S:Envelope xmlns:S="http://schemas.xmlsoap.org/soap/envelope/">
<S:Header>
<wss:Security xmlns:wss="http://schemas.xmlsoap.org/ws/2002/12/secext/">
<wss:UsernameToken>
<wss:Username>599999993/37</wss:Username>
<wss:Password>vr+fxAksaRrOPtbJRNFhFg==</wss:Password>
<wss:Nonce>h81uCVwZCKNicu4gUx9odp9dYKpFTRklvCtlqiBbyS301kuhSvBx1qBKAnHExZELMCte3GSqzyaKoMPTKbyQxoyGyvkoxym9R/EIW2+hsfMvN4bI+nWSNJIEQjTvc5Oxd1mQNXdILA17xZibiuGPm33bqOj8Cdcxff43LHO1r40+EXwXsUr2n4Oorw3OBzpBWfVrbTvXj/EyzHFBpixIwQherlOFP3Qxyed63fnD28T9jmOe3dcEGzgb7F+4iSfASYWx+RK6u+hpQ9D5lRrDUzEEMymo6X/xqlLEnIpXm0NB2BpwUS8feo6KGkUbZJBgrY+6tcechd4CkvtoBTY3CQ==</wss:Nonce>
<wss:Created>Gtd3WU3KUVo6ty/HlqA7LHAWpp6pBeGMCr8vHx9XqSU=</wss:Created>
</wss:UsernameToken>
</wss:Security>
</S:Header>
<S:Body>
<ns0:RegisterInvoiceElem xmlns:ns0="http://servicos.portaldasfinancas.gov.pt/faturas/">
<TaxRegistrationNumber>599999993</TaxRegistrationNumber>
<ns0:InvoiceNo>DR 2019/1800000008</ns0:InvoiceNo>
<ns0:InvoiceDate>2018-05-16</ns0:InvoiceDate>
<ns0:InvoiceType>FT</ns0:InvoiceType>
<ns0:InvoiceStatus>N</ns0:InvoiceStatus>
<CustomerTaxID>599999994</CustomerTaxID>
<Line>
<ns0:CreditAmount>100.00</ns0:CreditAmount>
<ns0:Tax>
<ns0:TaxType>IVA</ns0:TaxType>
<ns0:TaxCountryRegion>PT</ns0:TaxCountryRegion>
<ns0:TaxPercentage>0</ns0:TaxPercentage>
</ns0:Tax>
<ns0:TaxExemptionReason>M08</ns0:TaxExemptionReason>
</Line>
<Line>
<ns0:CreditAmount>100.00</ns0:CreditAmount>
<ns0:Tax>
<ns0:TaxType>IVA</ns0:TaxType>
<ns0:TaxCountryRegion>PT</ns0:TaxCountryRegion>
<ns0:TaxPercentage>0</ns0:TaxPercentage>
</ns0:Tax>
<ns0:TaxExemptionReason>M08</ns0:TaxExemptionReason>
</Line>
<DocumentTotals>
<ns0:TaxPayable>0.00</ns0:TaxPayable>
<ns0:NetTotal>200.00</ns0:NetTotal>
<ns0:GrossTotal>200.00</ns0:GrossTotal>
</DocumentTotals>
</ns0:RegisterInvoiceElem>
</S:Body>
</S:Envelope>


Muito obrigado
Uma saudação.

Olá @Antonio Valladares,

Estou a configurar o SoapUI, mas não estou a conseguir colocar o header tal e qual como necessário na documentação. É possível partilhares a configuração que tens no WS-A?

Ou se mais alguém conseguir ajudar, agradecia.

Obrigado desde já.

Cumprimentos

Share this post


Link to post
Share on other sites
dikx
Em 27/08/2018 às 12:22, RikFonseca disse:

Bom dia @dikx,

Quem passou o dia a tentar obter respostas foi o meu chefe... Eu estava de férias e concentrei-me em tentar arranjar solução no código enquanto ele tentava obter mais respostas...

Penso que ligou várias vezes para o CAT e deixou pedido no e-balcão, mas entretanto enviou um email para o departamento «SDG - Sistemas de Informação» (sdg-si@at.gov.pt) com diversas questões, nomeadamente a pedir prova de que tinham enviado o certificado, onde obter o certificado, a que departamento se pode recorrer no futuro se acontecer algo semelhante, além de referir que é inadmissível não haver suporte consistente/coerente da parte deles...

O email foi reencaminhado para o departamento «ASI - Certificados Digitais» (asi-cd@at.gov.pt) e limitaram-se e enviar o certificado, sem responder a nenhuma das questões.

Uns dias mais tarde chegou novo email com o certificado (presumo que tenha sido enviado para todos), indicando que o anterior ficou retido, bla, bla, bla...

Ou seja, continuamos sem saber a quem nos podemos dirigir em casos semelhantes, apesar de sermos obrigados a comunicar com a plataforma deles...

Já enviei email para mais de 3 emails diferentes e 0 respostas. Além do mais, o email sdg-si@at.gov.pt não permite emails com encoding UTF-8... impressionante...

Falta mesmo um serviço de suporte como deve de ser. Efetivamente, é como disseste, somos obrigados a utilizar os Webservices, mas não existe qualquer apoio.

Cumprimentos

Share this post


Link to post
Share on other sites
MCAST76
Em 11/04/2018 às 11:48, hulkman disse:

Entretanto percebi o meu erro... A ServiceAction não leva uma / no fim... nas guias de transporte precisa...

Viva!

Relativamente ao webservice e-TaxFree, gostaria de saber se alguém consegue algum resultado, pois é-me sempre devolvido o erro: "Pedido do Cliente Rejeitado: Credenciais Inválidas".

Os restantes webservices funcionam devidamente, tanto em ambiente de testes como de produção.

Agradeço desde já.

Share this post


Link to post
Share on other sites
Guest
Em 27/08/2018 às 12:16, Hugo Simões disse:

Obrigado,

Mas não está fácil de encontrar alguma coisa/ferramenta que possa extrair documentos da AT para encontrar a falha ou podermos dizer que é um bug visual da AT. Alguém que esteja a ver este post já ajuda se me conseguir fazer um teste em que verifique se o total que tira do seu sistema é o mesmo que está na AT num determinado mês. 

Se for igual, percebo que há um problema do meu lado, agora se estiver também diferente posso associar que não sou o unico nesta situação e a AT tem mesmo um problema.

Obrigado.

Boas,

Há pouco tempo deixei aqui uma dica, mas não me tinha apercebido do facto de poder ter mais de 300 documentos do mesmo tipo por dia, e isso, sim é um problema, que eu saiba, pois não consegue listar os documentos todos de um dia.

Por acaso conseguiram ultrapassar este constrangimento?

Share this post


Link to post
Share on other sites
PSeg

Boa tarde.
Continuo com problemas nos webservices de teste, em produção funciona, mas em testes não.
Tenho uma duvida, no caso dos testes, deve-se usar Chave Cifra Publica AT de produção ?
È que não tenho outra...
Obrigado pela ajuda.

Share this post


Link to post
Share on other sites
RikFonseca
1 hora atrás, PSeg disse:

Boa tarde.
Continuo com problemas nos webservices de teste, em produção funciona, mas em testes não.
Tenho uma duvida, no caso dos testes, deve-se usar Chave Cifra Publica AT de produção ?
È que não tenho outra...
Obrigado pela ajuda.

Boa tarde,

O webservice de teste só funciona com a chave de testes... a de produção não funciona...

As chaves estão disponíveis no site da AT:

https://faturas.portaldasfinancas.gov.pt/testarLigacaoWebService.action

 

Share this post


Link to post
Share on other sites
PSeg
1 hora atrás, RikFonseca disse:

Boa tarde,

O webservice de teste só funciona com a chave de testes... a de produção não funciona...

As chaves estão disponíveis no site da AT:

https://faturas.portaldasfinancas.gov.pt/testarLigacaoWebService.action

 

Obrigado pela resposta.
No site da AT, o zip com o novo certificado de testes apenas tem a chave publica de produção com o nome de "Chave Cifra Publica AT (Produção).cer"
Podes ajudar ?
Obrigado.

Share this post


Link to post
Share on other sites
RikFonseca
18 minutos atrás, PSeg disse:

Obrigado pela resposta.
No site da AT, o zip com o novo certificado de testes apenas tem a chave publica de produção com o nome de "Chave Cifra Publica AT (Produção).cer"
Podes ajudar ?
Obrigado.

Peço desculpa mas expliquei mal...

A chave publica AT que indicas é para utilizar também nos testes.

O que muda no ambiente de testes é que passas a utilizar o TesteWebservices.pfx (incluído no zip!) em vez do teu certificado privado... A password é TESTEwebservice

 

 

Share this post


Link to post
Share on other sites
PSeg
1 hora atrás, RikFonseca disse:

Peço desculpa mas expliquei mal...

A chave publica AT que indicas é para utilizar também nos testes.

O que muda no ambiente de testes é que passas a utilizar o TesteWebservices.pfx (incluído no zip!) em vez do teu certificado privado... A password é TESTEwebservice

 

 

Agradeço a resposta.
Estou a fazer isso mesmo, a usar esse pfx com essa password, e nada... sempre retorna que não consegue estabelecer a ligação.
Também já verifiquei que uso a porta correcta ( https://servicos.portaldasfinancas.gov.pt:701/sgdtws/documentosTransporte )
Estou encravado.. dá sempre erro na ligação em testes...
Em produção funciona perfeitamente.

Share this post


Link to post
Share on other sites
RikFonseca
25 minutos atrás, PSeg disse:

Agradeço a resposta.
Estou a fazer isso mesmo, a usar esse pfx com essa password, e nada... sempre retorna que não consegue estabelecer a ligação.
Também já verifiquei que uso a porta correcta ( https://servicos.portaldasfinancas.gov.pt:701/sgdtws/documentosTransporte )
Estou encravado.. dá sempre erro na ligação em testes...
Em produção funciona perfeitamente.

Confirma se o certificado está a ser carregado corretamente... a password é case-sensitive...

 

Share this post


Link to post
Share on other sites
PSeg
Em 05/09/2018 às 17:53, RikFonseca disse:

Confirma se o certificado está a ser carregado corretamente... a password é case-sensitive...

 

Confirmado e com password correcta... e continua sem funcionar...

Share this post


Link to post
Share on other sites
rukako
Em 05/09/2018 às 17:17, PSeg disse:

Agradeço a resposta.
Estou a fazer isso mesmo, a usar esse pfx com essa password, e nada... sempre retorna que não consegue estabelecer a ligação.
Também já verifiquei que uso a porta correcta ( https://servicos.portaldasfinancas.gov.pt:701/sgdtws/documentosTransporte )
Estou encravado.. dá sempre erro na ligação em testes...
Em produção funciona perfeitamente.

Pois eu tenho exactamente o mesmo problema....

Share this post


Link to post
Share on other sites
Carlos Pais
9 horas atrás, rukako disse:

Pois eu tenho exactamente o mesmo problema....

 foi emitido um novo certificado de teste à uns dias ...

Email enviado pela AT

Exmos Senhores
 O certificado digital "ChavePublicaAT.cer” que é utilizado no processo de cifra da password enviada no Header do pedido SOAP que é efectuado via Web Service na comunicação de Documentos de Transporte, Faturas, Declarações de IRC e Contratos de Arrendamento para a AT por parte dos operadores económicos vossos clientes expira no próximo dia 18 de Novembro de 2017
 Para substituir o certificado digital "ChavePublicaAT.cer” que irá expirar, foi emitido um novo certificado digital “ChaveCifraPublicaAT2020.cer” que pode ser obtido no Portal das Finanças em Faturas -> Produtor Software -> Apoio ao desenvolvimento -> Testar Webservice.

Para que cada produtor de software possa testar a continuidade do funcionamento dos seus produtos, a AT já actualizou os seus sistemas para que passem a aceitar as passwords que já utilizem, no processo de cifra da mesma, o novo certificado digital “ChaveCifraPublicaAT2020.cer”

O ficheiro agora enviado contém no seu interior o certificado digital com a nova chave pública, “ChaveCifraPublicaAT2020.cer”

Esclarecemos ainda o seguinte:
 - O certificado digital que solicitaram à AT, via adesão ao serviço no e-fatura, mantém-se até ao fim da sua validade.
 Os pedidos de esclarecimento deverão ser colocados ao e-balcão através do site do portal das finanças.
 Na esperança de poder contribuir para o seu esclarecimento, enviamos-lhes os melhores cumprimentos,

Share this post


Link to post
Share on other sites
rukako
14 minutos atrás, Carlos Pais disse:

 foi emitido um novo certificado de teste à uns dias ...

Email enviado pela AT

Exmos Senhores
 O certificado digital "ChavePublicaAT.cer” que é utilizado no processo de cifra da password enviada no Header do pedido SOAP que é efectuado via Web Service na comunicação de Documentos de Transporte, Faturas, Declarações de IRC e Contratos de Arrendamento para a AT por parte dos operadores económicos vossos clientes expira no próximo dia 18 de Novembro de 2017
 Para substituir o certificado digital "ChavePublicaAT.cer” que irá expirar, foi emitido um novo certificado digital “ChaveCifraPublicaAT2020.cer” que pode ser obtido no Portal das Finanças em Faturas -> Produtor Software -> Apoio ao desenvolvimento -> Testar Webservice.

Para que cada produtor de software possa testar a continuidade do funcionamento dos seus produtos, a AT já actualizou os seus sistemas para que passem a aceitar as passwords que já utilizem, no processo de cifra da mesma, o novo certificado digital “ChaveCifraPublicaAT2020.cer”

O ficheiro agora enviado contém no seu interior o certificado digital com a nova chave pública, “ChaveCifraPublicaAT2020.cer”

Esclarecemos ainda o seguinte:
 - O certificado digital que solicitaram à AT, via adesão ao serviço no e-fatura, mantém-se até ao fim da sua validade.
 Os pedidos de esclarecimento deverão ser colocados ao e-balcão através do site do portal das finanças.
 Na esperança de poder contribuir para o seu esclarecimento, enviamos-lhes os melhores cumprimentos,

Mas eu ja estou a usar o novo certificado ....

Share this post


Link to post
Share on other sites
Carlos Pais
1 minuto atrás, rukako disse:

Mas eu ja estou a usar o novo certificado ....

a password que está a utilizar é "TESTEwebservice" correcto ???

Share this post


Link to post
Share on other sites
Carlos Pais

email recebido da AT em 9-8-2018, vinha em anexo "portaldasfinancasgovpt.crt" e "portaldasfinancasgovpt.pen"
 

Citação

 

Exmos Senhores

Tendo constatado que a mensagem anterior sobre este este assunto ficou retida e não chegou aos seus destinatários, procedemos ao envio de outra com o mesmo teor.

O certificado digital de SSL do sítio servicos.portaldasfinancas.gov.pt foi alterado no dia 07 de Agosto de 2018 por exigência da entidade certificadora.

Nesta alteração foram substituídos o certificado digital de SSL e respetiva cadeia de certificação.

Esta informação não dispensa a necessidade de testarem nos vossos produtos para que não haja problemas na comunicação de Documentos de Transporte, Faturas, Declarações de IRC e Contratos de Arrendamento para a AT por parte dos operadores económicos vossos clientes.

Para tal a AT já alterou o certificado digital de SSL nos portos de testes (700, 701,702,705 e 709 ) para que cada produtor de software possa testar a continuidade do funcionamento dos seus produtos, contendo já estes endereços o novo certificado SSL.

Recomendamos que se valide a cadeia de certificação, conforme o exemplo indicado no “Código Fonte da aplicação em Java Applet”, o qual pode ser obtido através da ligação:

https://faturas.portaldasfinancas.gov.pt/testarLigacaoWebService.action

O ficheiro ".zip" agora enviado contém no seu interior a chave pública do novo certificado digital de SSL com as chaves públicas da cadeia de certificação, em dois formatos “.crt” e formato “.pem”. Estas chaves públicas são apenas utilizadas no estabelecimento da ligação SSL entre os sistemas dos clientes dos WebServices e a AT.

Esclarecemos ainda o seguinte:

- O certificado digital " Chave Cifra Publica AT 2020.cer" não é alterado e deve continuar a ser utilizado na função definida no respetivo manual, até novas indicações

- O certificado digital que solicitaram à AT, via adesão ao serviço no e-fatura, mantém-se até ao fim da sua validade.

Os pedidos de esclarecimento deverão ser colocados ao e-balcão através do site do portal das finanças.

 

 

Share this post


Link to post
Share on other sites
rukako
10 minutos atrás, Carlos Pais disse:

email recebido da AT em 9-8-2018, vinha em anexo "portaldasfinancasgovpt.crt" e "portaldasfinancasgovpt.pen"
 

 

da para partilhar os que recebeste? e que os que estao no site sao de 24-07-2017

Obrigado

Share this post


Link to post
Share on other sites
Carlos Pais
18 minutos atrás, rukako disse:

da para partilhar os que recebeste? e que os que estao no site sao de 24-07-2017

Obrigado

já vai a caminho para o teu email

Share this post


Link to post
Share on other sites
rukako
18 horas atrás, Carlos Pais disse:

a password que está a utilizar é "TESTEwebservice" correcto ???

sim estou a usar a password "TESTEwebservice" no entanto ja descobri 🙂

instalei o certificado (TESTEwebservice.pfx )no computador e já funciona depois desinstalei-o fiz restart voltei a testar e continua a funcionar mas o que é isto....

Share this post


Link to post
Share on other sites
marcolopes
On 8/29/2018 at 12:11 PM, MCAST76 said:

Viva!

Relativamente ao webservice e-TaxFree, gostaria de saber se alguém consegue algum resultado, pois é-me sempre devolvido o erro: "Pedido do Cliente Rejeitado: Credenciais Inválidas".

Os restantes webservices funcionam devidamente, tanto em ambiente de testes como de produção.

Agradeço desde já.

Por acaso não tens o "xml" da SOAP message que esteja perfeitamente validado? Estou a comparar com o XML do FILE UPLOAD, mas são coisas distintas... este serviço é, como sempre, um puzzle! Fizeram uma estrutura para o WEBSERVICE, e uma distinta para o XML a enviar manualmente...

No webservice (testes) estou a obter Conteúdo mal formado: Erro de validação de schema (Pedido do Cliente ) [Request reference: 7833110:7147f1ae5ba7d80d01e45481]

Não consigo validar manualmente o Schema, porque o meu validador dá erro ao interpretar o XSD!

EDIT: Resolvido!

Edited by marcolopes

The simplest explanation is usually the correct one

JAVA Utilities: https://github.com/marcolopes/dma

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.