Jump to content

excel Formula ProcV


zykon
 Share

Go to solution Solved by pmg,

Recommended Posts

Viva,

precisava de ajuda com uma formula, penso que o mais adequado seja uma proc...

vou tentar explicar:

Tenho 2 células com informações necessárias para obter um preço.

Como é que obtenho esse preço com a informação das duas células?

Tabelas para me explicar melhor:

Tenho a seguinte tabela auxiliar (exemplo)

tabelaauxiliar.png

E depois noutra folha, necessito de obter o preço com base nas 2 informações (Destino e tamanho)

calculo.png

Dou preferência a formulas

Link to comment
Share on other sites

Faz outra tabela que relacione o tamanho com a coluna onde está o preço correcto

tam | col
20 |   2
40 |   3

Depois fazes a pesquisa do tamanho nessa tabela e com o resultado fazes a pesquisa na tua tabela auxiliar original

=VLOOKUP("Dubai", TABELA_AUXILIAR, VLOOKUP(20, TABELA_TAMANHOS, 2, false), false)

What have you tried?

Não respondo a dúvidas por PM

A minha bola de cristal está para compor; deve ficar pronta para a semana.

Torna os teus tópicos mais atractivos e legíveis usando a tag CODE para colorir o código!

Link to comment
Share on other sites

Viva,

Obrigado pela ajuda, mas está ai qualquer coisa que me está a escapar... a formula está a dar erro

Tens que adaptar à tua situação.

No Excel em português o nome da função é PROCV; as TABELA_AUXILIAR e TABELA_TAMANHOS tem que ser escritas de acordo com as sheets e posicao dentro da sheet que ocupam no teu livro.

Além disso eu não testei a função. Escrevi-a directamente no editor mais ou menos como escreveria no meu Excel juntamente com a lógica usada para a escrever.

Aplica essa lógica à tua situação independentemente dos erros presentes no código apresentado por mim.

A ainda ... se fores mais explicito quanto à tua versão da formula e erros que ela dá, é mais fácil ajudar-te.

What have you tried?

Não respondo a dúvidas por PM

A minha bola de cristal está para compor; deve ficar pronta para a semana.

Torna os teus tópicos mais atractivos e legíveis usando a tag CODE para colorir o código!

Link to comment
Share on other sites

Tens que adaptar à tua situação.

No Excel em português o nome da função é PROCV; as TABELA_AUXILIAR e TABELA_TAMANHOS tem que ser escritas de acordo com as sheets e posicao dentro da sheet que ocupam no teu livro.

Além disso eu não testei a função. Escrevi-a directamente no editor mais ou menos como escreveria no meu Excel juntamente com a lógica usada para a escrever.

Aplica essa lógica à tua situação independentemente dos erros presentes no código apresentado por mim.

A ainda ... se fores mais explicito quanto à tua versão da formula e erros que ela dá, é mais fácil ajudar-te.

Viva,

Sou bronco, mas nem tanto 😄

Sei que tenho que adaptar as minhas células, no entanto, do um erro, o REF!

=PROCV(D26;tabelas!J2:J13;PROCV(D27;tabelas!N2:O4;2;FALSO);FALSO)

Sendo J2:J13 a tabela principal e N2:O4 a tabela que sugeriste.

jpaulino, vou tentar perceber a tua sugestão situação

Link to comment
Share on other sites

  • Solution

O teu codigo:

=PROCV(D26;tabelas!J2:J13;PROCV(D27;tabelas!N2:O4;2;FALSO);FALSO)

Aparentemente a tua primeira tabela é composta apenas por uma única coluna. A tabela deve ter várias colunas: uma para a cidade e mais muitas, uma para cada valor

=PROCV(D26;tabelas!J2:L13;PROCV(D27;tabelas!N2:O4;2;FALSO);FALSO)

Além disso, se vais precisar de copiar a formula para células abaixo, usa $ para fizar as tabelas de referencia

=PROCV(D26;tabelas!$J$2:$L$13;PROCV(D27;tabelas!$N$2:$O$4;2;FALSO);FALSO)

What have you tried?

Não respondo a dúvidas por PM

A minha bola de cristal está para compor; deve ficar pronta para a semana.

Torna os teus tópicos mais atractivos e legíveis usando a tag CODE para colorir o código!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.