Jump to content
Gonka

Duvida sobre como colocar layout horizontal no blog

Recommended Posts

Gonka

Boa noite. Estou aqui com um pequeno problema que me está a dar cabo da cabeça...

Estou a implementar um blog e quero que os posts apareçam da seguinte maneira:

scaled.php?server=3&filename=draftx.png&res=landing

Tenho isto no meu css, mas não está a resultar...


.blog-container
{
    display:inline;
    border: 10px white;
    width:600px;
    height:400px;
    margin-left:600px;
    margin-top:40px;
}

.blog-column
{
    color:White;
    font-size:22px;
    float:left;
    margin-top:20px;
margin-left:40px;
}

.blog-content
{
    float:left;
    width:500px;
    margin-top:40px;
    margin-left:20px;
    text-align:justify;
    word-wrap: break-word;
}

No HTML tenho isto:

<div class="blog-container">
                        <div class="blog-column">@Html.DisplayFor(modelItem => item.POST_TITLE)</div>        
                        <div class="blog-content">@Html.Raw(item.POST_CONTENT)</div> 
</div> 

Agradeço desde já!

Share this post


Link to post
Share on other sites
HappyHippyHippo

por não dizeres o que acontece e o que deveria acontecer, vou entrar em condutividade e chamar um espírito do além para me dizer o poderá estar a acontecer :

- tens o tamanho da entrada de blog com 600px ... quando uma destas entradas não cabe horizontalmente, passa para baixo.

estará o espírito enganado ? se sim, diz para teremos de entrar em esquemas mais complexos de obtenção de informação como contactar o CIA, pois não tenho outra forma de saber o que um pessoa pretende sem o dizer ..


IRC : sim, é algo que ainda existe >> #p@p

Share this post


Link to post
Share on other sites
Gonka

Ora bem... O body está bem simples:

body
{
    margin:auto;
    width:6000px;
    heigth:100%;
}

Como dá para perceber, quero fazer com que os posts sejam apresentados na horizontal.

Eles estão a aparecer na hoziontal, mas não assumem o layout que quero implementar. Em vez de isso aparecem todos desorganizados..

Eu quero varios containers com os respectivos posts lá dentro...

Share this post


Link to post
Share on other sites
Gonka

Ok... Tenho isto no CSS:

body 
{
    margin:auto;
    width:5500px;
    height:100%;
    background: #101010;
    color: gray; 
    font-family: Helvetica;
    font-size:16px;
    overflow:auto;
    overflow-y:hidden;
}

.blog-container
{
    display:inline;
    border: 10px white;
    width:600px;
    height:400px;
    margin-left:600px;
    margin-top:40px;
}

.blog-column
{
    color:White;
    font-size:22px;
    float:left;
    margin-top:20px;
        margin-left:40px;
}

.blog-content
{
    float:left;
    width:500px;
    margin-top:40px;
    margin-left:20px;
    text-align:justify;
    word-wrap: break-word;
}

.first-nav
{        
    font-size:20px;
margin-left:120px;
margin-bottom:10px;
display:inline;
}

.nav
{
    font-size:20px;
margin-left:20px;
margin-bottom:10px;
display:inline;
}

Mas está a retornar isto...

screengl.jpg

O container parece não existir, visto que não aparece nenhum border. A continuação dos posts aparecem sem nexo algum. Os posts em sí não aparecem de acordo com o margin que defini e por fim o segundo navegador salta de linha..

Alguém me consegue explicar o que estou a fazer de mal?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.