Jump to content

Wordpress - Versão PHP


joanalemos
 Share

Recommended Posts

Boas, meti um site de wordpress no servidor e o servidor apresenta este erro:

O seu servidor está a correr o PHP na versão 5.1.6 mas o WordPress 3.3.1 necessita de, pelo menos, a versão 5.2.4.

Alguém sabe alguma maneira de meter o WordPress para uma versão mais antiga sem perder o site feito css's divs nas paginas etc etc, regredir na versão do WordPress mas manter o site se me faço entender??

Thanks 😛

Link to comment
Share on other sites

Não é possível.

Não se ajustam pacotes de software a requisitos mais baixos, mas sim o contrário, actualizam-se para os requisitos necessários (ou superiores).

Além disso, é sempre boa ideia manter o PHP (e o MySQL, e o Apache/Nginx/lighttpd) actualizado para a última versão estável.

"Para desenhar um website, não tenho que saber distinguir server-side de client-side" - um membro do fórum que se auto-intitula webdesigner. Temo pelo futuro da web.

Link to comment
Share on other sites

Claro que dá para sacar uma inferior. O que tu queres é a última do ramo 3.1 (a 3.1.4).

Mas não o faças. Há várias razões pelas quais um pacote é actualizado: segurança, funcionalidades, performance. Ao instalares uma versão inferior à última estável, estás a assumir que todas as actualizações que foram feitas não te interessam. No caso concreto do Wordpress, pode até haver templates e plugins que não funcionem.

Actualiza o PHP. Esse é que é o caminho. Ou há razões extraordinariamente fortes para não o fazer (e, com tantos anos disto, não vejo nenhuma), ou é pura teimosia ignorante.

"Para desenhar um website, não tenho que saber distinguir server-side de client-side" - um membro do fórum que se auto-intitula webdesigner. Temo pelo futuro da web.

Link to comment
Share on other sites

Cara Joana,

Acho que você não se deu conta do que disse  :wallbash:

Uma coisa é ter a possibilidade e não evoluir outra é não ter condições e ficar preso a versões antigas.

Se hoje está a trabalhar com o WP, talvez um dia venha a trabalhar com o Moodle. Neste caso sugiro que veja este tópico que iniciei.

http://www.portugal-a-programar.pt/index.php?showtopic=50876

Link to comment
Share on other sites

Boas, ao tentar actualizar o servidor, a pagina de update deixou de aparecer e fica totalmente branca.

Alguém me pode dar uma dica como passar isto, ja ligamos aqui para a parallels e para a esotérica que e quem fornece o serviço e passa de um para o outro a bola e nao resolvem nada, se alguem conseguir dar uma dica ficaria muito agradecido, e que esperei esperei e o update nao foi feito

Link to comment
Share on other sites

Quando referes a página de update, estás a fazer referência à página na área de cliente. É isso?

Tenta aceder com outro browser (limpando os cookies). Creio que haja outro botão que reponha a versão (situação) anterior...

Ou está a querer dizer que abriste essa página com o bloco de notas, salvaste o ficheiro e ficou tudo branco?

Link to comment
Share on other sites

Obrigado pela resposta 🙂

Não o problema não e de php nem nada disso, foi ao fazer o update para o 5.3 no servidor coisa que acabou por nao acontecer :s

No painel de admin do servidor dedicado ao clicar no botao update deixou de dar para actualizar o plesk o php tudo, a pagina fica em branco :s eu sei que a duvida nao tem nada a ver coom o portugal a programar mas visto que me ajudaram no resto ja vos pode ter acontecido o mesmo deixo so a duvida a ver se alguem pode ajudar 😄

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.