Jump to content
Sign in to follow this  
ninjanPT

não aparecem os dados inseridos na DataGridView

Recommended Posts

ninjanPT
Private Sub Button1_Click(sender As System.Object, e As System.EventArgs) Handles Button1.Click
        Dim cod_lab, cod_responsavel As Integer
        Dim sala, bloco As String
        cod_responsavel = ComboBox1.SelectedItem()
        cod_lab = Label2.Text
        sala = InputBox("Insira a sala pretendida")
        bloco = InputBox("Insira o bloco pretendido")

        'LaboratorioTableAdapter.Adapter.InsertCommand.CommandText = "INSERT INTO laboratorio (cod_lab,sala,bloco,cod_responsavel) VALUES ('" & cod_lab & "','" & sala & "','" & bloco & "','" & cod_responsavel & "')"


        ligacao.Open()

        Dim sql = "INSERT INTO laboratorio (cod_lab,sala,bloco,cod_responsavel) VALUES ('" & cod_lab & "','" & sala & "','" & bloco & "','" & cod_responsavel & "')"

        'Dim sql = "INSERT INTO Treinador (cod_lab,sala,bloco,cod_responsavel) VALUES (@cod_lab,@sala,@bloco,@cod_responsavel)"

        Dim cmd As SqlCommand = ligacao.CreateCommand
        'cmd.Parameters.AddWithValue("@cod_lab", TextBox1.Text)
        'cmd.Parameters.AddWithValue("@sala", TextBox2.Text)
        'cmd.Parameters.AddWithValue("@bloco", TextBox3.Text)
        'cmd.Parameters.AddWithValue("@cod_responsavel", TextBox4.Text)

        cmd.CommandText = sql

        cmd.ExecuteNonQuery()

        MsgBox("Registo Efectuado Com Sucesso", vbInformation)
        ligacao.Close()

        form_inserçao_lab.LaboratorioTableAdapter.Adapter.SelectCommand.CommandText = ("Select * from laboratorio")
        form_inserçao_lab.LaboratorioTableAdapter.Fill(form_inserçao_lab.LaboratorioDS.laboratorio)

        Me.Close()
    End Sub

Share this post


Link to post
Share on other sites
Blackvelvet

na datagrid ou na tabela????

não vejo no teu codigo o caminho para a bd.

Exemplo:

Dim myConnectionString As String = _
         "Data Source=.\SQLEXPRESS; Initial Catalog=(nome tabela); Integrated Security=SSPI;"

Share this post


Link to post
Share on other sites
ninjanPT

está num módulo:

Module Module1
    Public strcon As String = "Data Source=.\SQLEXPRESS;AttachDbFilename=C:\Users\admin\Desktop\Trababalho vb\PAP\PAP\gestor de laboratorios\gestor de laboratorios\gestor.mdf;Integrated Security=True;User Instance=True"
    Public ligacao As New SqlClient.SqlConnection(strcon)
End Module

Share this post


Link to post
Share on other sites
Caça

Não é aconselhável utilizar dois métodos diferentes para aceder à base de dados na mesma aplicação, o mais certo é não estares a trabalhar com a mesma base de dados.


Pedro Martins

Não respondo a duvidas por PM

Share this post


Link to post
Share on other sites
ninjanPT

Mas eu estou, é a unica que tenho neste momento até.

E já explorei várias alternativas, simplesmente não funciona

Share this post


Link to post
Share on other sites
acao

boas

penso que no insert , no cod_lab e no cod_responsabel tens aspas simples a mais,

Vê se é isso.

cumps

acao

Share this post


Link to post
Share on other sites
ninjanPT

boas

penso que no insert , no cod_lab e no cod_responsabel tens aspas simples a mais,

Vê se é isso.

cumps

acao

Parecem-me bem, mas o problema duvido que venha daí, porque ele insere bem os dados na base de dados, só não aparecem na DGV por nada deste mundo

Share this post


Link to post
Share on other sites
acao

eu nunca usei esses comando para a dgv, mas tu fechaste antes a ligação à base de dados, não será por isso!

não estarás a fechar a ligação ao select?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.