Jump to content
lokbelo

s7-200 e elipse SCADA

Recommended Posts

lokbelo

Eu gostaria de saber sobre comunicação ethernet entre s7-200 e elipse SCADA. Se alguem puder me ajudar.

grato!

Share this post


Link to post
Share on other sites
lokbelo

  Eu estou tentando construir um supervisorio com o elipse ESCADA, porém não consigo saber qual driver usar.

  Tenho um CLP S7-200 e um modulo ethernet 234 da SIEMENS e também um cabo PPI para porta USB que comunica direto com a CPU. Eu estou tentando usar o driver "Elipse Driver SIEMENS MProt (MPI/PPI/ISO-TCP) v2.09 Build 1" mas não consegui configura-lo para comunicar.

  É a primeira vez que trabalho com supervisorio e não sei o que devo configurar ou como estabelecer a comunicação ou qual driver usar e sobre sua configuração.

Muito obrigado pela sua atenção.

Share this post


Link to post
Share on other sites
bubulindo

Se vais usar a carta Ethernet, terás de configurar uma comunicação TCP ou UDP dessa carta para algum lado.

Usando a porta USB para comunicar com o protocolo PPI (Os Simatic 200 usam PPI, os 300 e 400 usam MPI), provavelmente não precisas disso.

De resto, dei uma vista de olhos pelo manual, mas não consegui grande informação, provavelmente seria mais simples se tivesse o computador à minha frente. Experimenta como disse com o protocolo PPI. Se calhar terás de adicionar uma morada do PLC, mas consegues ver isso no programa do PLC.


include <ai se te avio>

Mãe () {

}

Share this post


Link to post
Share on other sites
lokbelo

Ainda não consegui. So comunico com o STEP 7 MicroWIN usando PPI via porta USB. Até configurei o modulo, descarreguei no autómato via PPI, configurei a comunicação do MicroWIN, mas não consegui estabelecer a comunicação. Também é a primeira vez que tento faze-lo.

Share this post


Link to post
Share on other sites
lokbelo

Se vais usar a carta Ethernet, terás de configurar uma comunicação TCP ou UDP dessa carta para algum lado.

Usando a porta USB para comunicar com o protocolo PPI (Os Simatic 200 usam PPI, os 300 e 400 usam MPI), provavelmente não precisas disso.

De resto, dei uma vista de olhos pelo manual, mas não consegui grande informação, provavelmente seria mais simples se tivesse o computador à minha frente. Experimenta como disse com o protocolo PPI. Se calhar terás de adicionar uma morada do PLC, mas consegues ver isso no programa do PLC.

Não consegui ainda comunicar com o supervisorio via protocolo PPI. A carta Ethernet 243-1 eu acho que consegui configurar mas não consegui estabelecer comunicação nenhuma.

Share this post


Link to post
Share on other sites
bubulindo

Consegues fazer um ping ao endereço que configuraste na carta?


include <ai se te avio>

Mãe () {

}

Share this post


Link to post
Share on other sites
nokPT

Consigo sim.

Então tens que conseguir comunicar com o MicroWin por ethernet.

Tens que configurar o Set-PG/PC Interface para a porta de ethernet.


Ricardo Timóteo

Share this post


Link to post
Share on other sites
lokbelo

Então tens que conseguir comunicar com o MicroWin por ethernet.

Tens que configurar o Set-PG/PC Interface para a porta de ethernet.

Eu configurei o Set-PG/PC Interface. Mas não ouve comunicação. Tambem configurei a carta de ethernet.

Share this post


Link to post
Share on other sites
nokPT

Já não configuro esta carta há muito tempo, a CP está na 1ª slot? Está a chamar as rotinas criadas pelo Wizard, no programa? Está a usar alguma memória V (0.x..160.x)?


Ricardo Timóteo

Share this post


Link to post
Share on other sites
lokbelo

Já não configuro esta carta há muito tempo, a CP está na 1ª slot? Está a chamar as rotinas criadas pelo Wizard, no programa? Está a usar alguma memória V (0.x..160.x)?

A CP esta na 1ª slot. Não estou chamando nenhuma rotina, estou trabalhando sem usar o programa que desenvolvi, estou apenas tentando estabelecer comunicação entre o PC e o autómato para depois comunicar com o supervisorio. Não estou usando nenhuma memoria, somente uma entrada e uma saida, ambos digitais.

Share this post


Link to post
Share on other sites
nokPT

No fim do wizard, são criadas 1 ou 2 rotinas, se for só 1, tens que a chamar sempre, se for 2, uma é chamada sempre e a outra no start-up.

Creio que tens que chamar a rotina, pelo menos 1 vez, para configurar o autómato, mas já não tenho a certeza.


Ricardo Timóteo

Share this post


Link to post
Share on other sites
lokbelo

No fim do wizard, são criadas 1 ou 2 rotinas, se for só 1, tens que a chamar sempre, se for 2, uma é chamada sempre e a outra no start-up.

Creio que tens que chamar a rotina, pelo menos 1 vez, para configurar o autómato, mas já não tenho a certeza.

Foi criada somente uma. Ao chama-la no Main tenho que configurar o bloco, você sabe o que colocar no "CP_Ready"?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.