Ir para o conteúdo
dezinh20

Problemas com o Datagrid

Mensagens Recomendadas

dezinh20    0
dezinh20

estou com um problema no meu datagrid,

quando eu coloco um banco nele.. ele mostra, tudo certinho

mas quando eu atualizo ele e coloco outro banco

ele me coloca o segundo + o primeiro banco

ou seja ele esta me mostrandos os dois bancos, sendo que só deveria me mostrar um

eu ja fiz

datagridview.datasource = nothing

datagridview.datasource = ""

ja tentei limpar o dataset fazendo

banco.clear()

banco.reset()

mas nada adianta.. não consigo limpar este Datagrid de forma alguma... nem colocar um novo, porque ele não remove o antigo...

como faço?

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites
dezinh20    0
dezinh20
 myService.Reset()
        MS.DataSource = Nothing
        SQL = "SELECT  distinct iduser_forcadastro,for_nome, for_cpf, for_RG,fori_Profissao,for_IE,for_IM,for_RS,for_endereco,for_cidade,for_bairro,for_estado,for_cep,for_idade,for_img  FROM user_forcadastro ORDER BY iduser_forcadastro ASC"
        IDados(SQL, myService)
        MS.DataSource = myService

Partilhar esta mensagem


Link para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!

Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.

Entrar Agora


×

Aviso Sobre Cookies

Ao usar este site você aceita os nossos Termos de Uso e Política de Privacidade