Ir para o conteúdo
  • Revista PROGRAMAR: Já está disponível a edição #59 da revista programar. Faz já o download aqui!

marcoenxuto

[Windows Phone] Problema do EntitySet em System.Data.linq.dll

Mensagens Recomendadas

marcoenxuto    0
marcoenxuto

Boas,

Detectei um problema na framework do Windows Phone, nomeadamente na componente de Linq.

Depois de escavar tanto ao longo destes dias, reparei que, ao correr a aplicacao sample de Local Databases o event Hanlder attach_ToDo simplesmente nao executava as suas linhas de codigo.

Inseri um issue no site msdn, até agora nao obtive resposta.

O que propunha era o seguinte:

Façam download do sample no site do msdn e executem no VS2010, com os breakpoints em attach_ToDo, detach_ToDo.

Para mais info ver aqui: http://forums.create.msdn.com/forums/t/94242.aspx

Verifiquem se a aplicacao para no breakpoint, assim que inserem um novo todo.

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
Caça    24
Caça

Atenção que o VS tem um pequeno bug quando está a correr em 64 bits, não acontece a toda a gente, mas pode ser o teu caso.

O bug é que quando estás a executar o código e ocorre uma excepção, a excepção não é disparada e as linhas de código seguintes não são executadas, aparentemente o código foi executado uma vez que não disparou qualquer erro mas na realidade não foi.

Pressiona Ctrl + Alt + E

No item Common Language(...) checa o Thrown e o User-unhandled

Põe o programa a correr e testa.


Pedro Martins

Não respondo a duvidas por PM

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites
marcoenxuto    0
marcoenxuto

Boas,

Obg pela dica.

Estive a ver o stack trace:

> mscorlib.dll!System.ThrowHelper.throwVersion37CompatException(System.ExceptionType newEType = FileNotFoundException, string newString = "File or assembly name 'System.Windows.debug.resources, Version=2.0.5.0, Culture=en-US, PublicKeyToken=7cec85d7bea7798e', or one of its dependencies, was not found.", System.ExceptionType oldEType = IOException, string oldString = "File or assembly name 'System.Windows.debug.resources, Version=2.0.5.0, Culture=en-US, PublicKeyToken=7cec85d7bea7798e', or one of its dependencies, was not found.") + 0x19 bytes

Supostamente falta um ficheiro, ja coloquei. No entanto rebenta na mesma... :S

Update: http://social.msdn.microsoft.com/forums/en-us/windowsphone7series/thread/2B040008-A240-470D-91AF-E998984FFF12

Partilhar esta mensagem


Ligação para a mensagem
Partilhar noutros sites

Crie uma conta ou ligue-se para comentar

Só membros podem comentar

Criar nova conta

Registe para ter uma conta na nossa comunidade. É fácil!

Registar nova conta

Entra

Já tem conta? Inicie sessão aqui.

Entrar Agora

×

Aviso Sobre Cookies

Ao usar este site você aceita os nossos Termos de Uso e Política de Privacidade. Este site usa cookies para disponibilizar funcionalidades personalizadas. Para mais informações visite esta página.