Jump to content
Sign in to follow this  
Ribamar

Problema com caracteres ao usar utf-8

Recommended Posts

Ribamar

Boas

Estou a usar um cms em que a base de dados esta com collation utf8_general_ci .

O site esta em utf-8.

o problema é que o simbolo do euro € no site aparece como € .... como posso contornar esta situação? no phpmyadmin no campo simbolo da moeda o simbolo aparece correctamente. no site é que aparece com aquele caractere esquisito.

cpts

Share this post


Link to post
Share on other sites
taviroquai

Viva,

Como foi introduzido na base de dados o simbolo € ? Pelo editor WYSIWYG do CMS? Pelo código PHP? Pelo phpmyadmin?

Talvez a forma como foi introduzido não tenha passado correctamente o código do caracter em UTF-8...

Share this post


Link to post
Share on other sites
bolovsky

e a pergunta que falta, com que encode é que o teu script está gravado? é que se tens a DB com utf-8, o encode do site em utf-8 e por acaso gravaste o ficheiro em iso-8859-1, ou cp-1252 (formatos muito frequentes em editoresTexto/IDEs), vai-te arruinar o encode..... (e pelo caracter que mostras, estou capaz de arriscar que tens o ficheiro em cp-1252)....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.