Jump to content
Sign in to follow this  
Miudadestimida

Problema com PHP + Eggdrop

Recommended Posts

Miudadestimida

Boas pessoal.

Estou a tentar mandar mensagens para o meu canal de irc usando um simples script em php. O problema é que o eggdrop da timeout na ligação.

A TCL usada é a seguinte:

listen PORTA script xxGRAB
proc xxGRAB { NewIDX } {

control $NewIDX torrent:CTL
putlog "Msg: Received connection $NewIDX"
}

proc torrent:CTL { IDX Args } {
putlog "Msg: $Args"
putserv "PRIVMSG #canal :$Args"
}

PHP:

<?
$fs = fsockopen("IP", "PORTA", $errno, $errstr, 50);
if($fs) {
       sleep(8);
       fwrite($fs, 'this is a test');  
       fclose($fs);                
        }
die ("feito!");
?>

E dá-me sempre este erro:

<bot> [04:23:47] Telnet connection: ip/56217

<bot> [04:23:47] Timeout/EOF ident connection

<bot> [04:23:55] Lost telnet connection to telnet@ip/56217

O TCL e o Script pareciam tão simples... O que é que eu poderei estar a fazer de errado?

Obrigado desde já.  :wallbash:

Share this post


Link to post
Share on other sites
Miudadestimida

O objectivo é basicamente mandar mensagens através  de uma página de php para um canal de irc através de uma TCL que corre no eggdrop.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site you accept our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.